Contents

Getting Started ................................................................. 1
  About Accounting CS and the Report Designer ...................... 1
  Navigating the Report Designer ........................................... 2
    Navigation ........................................................................ 2
    Report regions .................................................................. 4
    Design Tools frame .......................................................... 4

Adding a New Client Record ................................................. 5
  Entering client information manually ................................... 5
  Downloading the sample spreadsheet ................................... 6
  Importing data from the sample spreadsheet ....................... 7

Modifying Financial Statements ........................................... 9
  Understanding account groupings ....................................... 9
  Opening a predefined financial statement ............................ 11
  Previewing a predefined financial statement ......................... 11
  Copying a predefined financial statement ............................ 13
  Viewing and modifying cell, row, column, and region properties ........................................ 14
    Cell Properties .............................................................. 14
    Row Properties .............................................................. 15
    Column Properties ........................................................ 16
    Region Properties ........................................................ 17
  Working in a financial statement ....................................... 18
    Page setup ....................................................................... 18
    Cell, row, and column setup ............................................ 18
    Cell formatting ............................................................. 20
Working with variables, formulas, functions, and periods ............................................. 22
Variables .................................................................................................................. 22
Formulas .................................................................................................................. 24
Functions ................................................................................................................. 25
Periods .................................................................................................................... 27
Page breaks ................................................................................................................. 27
Conditional expressions ............................................................................................... 28

Using the Help & How-To Center ............................................................................. 29
Getting Started

This walkthrough covers some basic information about the design and functionality of the Report Designer — specifically to help you produce financial statements. Although it is not intended to show you all of the application features and capabilities, this walkthrough explains some of the basic features and processes in the Report Designer. To get the most out of this walkthrough, read the pages in sequence and follow along with the documented steps in Accounting CS® and the Report Designer.

In this chapter, we will:

- Provide a general overview of Accounting CS and the Report Designer.
- Explain how to navigate and use the main screen in the Report Designer, including the toolbars, Reports list frame, design grid, and Design Tools frame.

About Accounting CS and the Report Designer

Accounting CS combines write-up, trial balance, payroll, financial reporting, and client accounting functionality into one flexible and customizable platform. Reporting capabilities in the application let you customize a variety of standard reports, financial statements, and letters that provide value-added analysis for your clients. With the Report Designer, you can:

- Define report detail at the cell, row, column, or region level.
- Use repeating levels to group related data, such as account-specific detail in a report.
- Use variables to create global financial statements that can be used for multiple clients.
- Set up custom formulas and functions to print calculated values.
- Use conditional expressions to modify the content that displays in the financial statement when it is previewed or printed.
Navigating the Report Designer

Navigation

The Report Designer enables you to modify reports, financial statements, and letters to fit your specific needs. To begin using the Report Designer effectively, it is important that you become familiar with the workspace, which includes the following components.

- The **Standard toolbar** provides quick access to commonly used commands such as new report, save, print, print preview, and more.
- The **Current Client toolbar** lets you select the client for whom to generate the reports, financial statements, and letters.
- The **Formatting toolbar** provides quick access to commonly used formatting tools such as font, font size, font styles, alignment, and more.
- The **Formula bar** specifies the content for the selected cell. You can either enter a formula or text in the Formula bar or you can click the Insert Formula button to build a formula.
- The **Reports list frame** lists all reports, financial statements, and letters that are available for your firm and your clients.
- The **design grid** is the workspace for building a report, financial statement, or letter.
- The **Design Tools frame** enables you to access variables and text formatting controls, as well as to specify the cell, row, column, and region properties for the document.
Getting Started

Accounting CS: Financial Statement WalkThrough
Report regions

Each report, financial statement, and letter includes at least five regions – header, alternate header, body, footer, and alternate footer. You cannot delete the two header and two footer regions. A report, financial statement, or letter can have more than one region in the body of the document. Each report and financial statement is organized in a matrix layout similar to other electronic spreadsheets, with horizontal rows and vertical columns.

Design Tools frame

The Design Tools frame provides quick access to variables, text formatting, and cell, row, column, and region properties.

Note: You can undock the Design Tools frame and move it to other areas on your desktop, including to a second monitor. You can also drag-and-drop the frames to rearrange them within the Report Designer workspace.

Variables. Use variables to insert firm and/or client information into the current document. You can insert variables using one of the following methods.

- Click the Formula button to use the Formula dialog.
- Drag and drop the variable from the Design Tools frame into the appropriate cell.
- Double-click a variable to insert it into the selected cell.

Text. The fields in the Text section of the Design Tools frame enable you to quickly access formatting options that are also available in the Format > Cells dialog.

Properties. When you select a cell, row, column, or region, the Design Tools frame displays the settings relevant to that selection, such as the contents, grouping type, and grouping content. If you modify settings in a selected row or column of the design grid, the change affects all cells in the active selection.
Adding a New Client Record

In Accounting CS, you can set up new client records by manually entering all of necessary data or you can use client templates.

In this chapter, we will create a new client record that we will use to complete the steps later in this walkthrough. We will enter some of the client data manually, and then we will import additional client data from a sample spreadsheet.

Entering client information manually

Complete these steps to create the new client record.

1. Choose Setup > Clients and then click the Add button.

2. In the Add Client dialog:
   a. Enter ACSFSSC in the ID field.
   b. Enter Financial Statements Sample Company in the Client name field.
   c. Select MI from the State drop-down list.
   d. In the Services section, mark the Accounting checkbox.
   e. Click the Add button.

3. In the Main tab of the Clients screen, enter 12-3456789 in the EIN/SSN field.

4. Click the Accounting Information tab and verify or select the following:
   - Select 12/31/2015 from the Current fiscal year end date drop-down list.
   - Select Monthly from the Period frequency drop-down list.
   - Select 12/31/2015 from the Current period end date drop-down list.

5. Click the Enter button to save the client record.
Adding a New Client Record

---

**Downloading the sample spreadsheet**

Next, we will import data for our new client from a sample spreadsheet. The sample spreadsheet contains accounts and balances that will create data in the Setup > Chart of Accounts screen and the Actions > Enter Trial Balance screen.

Complete these steps to download the sample spreadsheet from our Help & How-To Center.

1. From the search field on the toolbar in Accounting CS, enter **chart of accounts spreadsheet**, and then click the button.

2. Click the **Spreadsheet import – Chart of Accounts** help topic in the search results list.

3. In the Sample spreadsheets section of the help topic, click the **Chart of Accounts (with current-year and prior-year balances)** link.

4. Depending on your browser or internet security settings, you may receive a prompt to Open, Run, or Save the spreadsheet file. Choose **Save** or **Save as** to download the spreadsheet file to the desired location on your computer.
Importing data from the sample spreadsheet

1. From any screen in Accounting CS, choose **File > Import > Spreadsheet** to open the Spreadsheet Import Wizard.

2. In the Source Data page, select **ACSFSSC** from the **Client name** field.

3. In the Import Type section, select **Chart of Accounts** from the **Data type** drop-down list.

4. In the Import File section, click the **Browse** button, highlight the sample spreadsheet you downloaded, and then click the **Open** button.

5. Click the **Next** button.
6. In the Column Mappings page, complete these steps.
   
   a. Map the columns as follows:

<table>
<thead>
<tr>
<th>Column</th>
<th>Map data as</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Account Number</td>
</tr>
</tbody>
</table>
   | B      | Account Grouping  
   |        | Account Classification Code |
   | C      | Account Grouping  
   |        | Account Classification Subcode |
   | D      | Account Description |
   | E      | Unadjusted Balance  
   |        | 12/31/2015  
   |        | Dr/Cr |
   | F      | Unadjusted Balance  
   |        | 12/31/2014  
   |        | Dr/Cr |

   b. Mark the Omit Row checkbox for the first row of spreadsheet data.
   
   c. Click the Next button.

7. In the Import Options page, select the Append to existing chart and Current period balances options and then click the Import button.

8. Review the Import Diagnostics page and click the Finish button.
Modifying Financial Statements

Accounting CS provides several predefined financial statements. If none of the predefined financial statements fit your needs, you can modify them in the Report Designer.

In this chapter, we will:

- Explain how the application uses account groupings for financial statement activity.
- Locate and open a predefined financial statement.
- Preview a financial statement.
- Copy a predefined financial statement to create a new financial statement.
- Discuss the concepts of Cell, Row, Column, and Region Properties.
- Modify a financial statement and show formatting capabilities.

Understanding account groupings

Accounting CS uses account groupings to group accounts for reporting purposes. The default account grouping is named Account Classification. It includes the required codes and subcodes that must be set up for every client's Chart of Accounts to allow the predefined financial statements to work automatically.

Let's take a look at the Account Classification codes and subcodes.

1. Choose Setup > Account Groupings.
2. Select Account Classification from the list on the left.

Note that the default codes are in the grid on the left and that the default subcodes (which correspond to the selected code) are in the grid on the right. For example, code CA (Current Assets) contains subcodes of CASH, MS, AR, INV, PE, and OCA.
Notes

- You cannot change the codes in the Account Classification account grouping, but you can add subcodes if necessary.

- You can define additional account groupings for special niche industries, or if you need to use different terminology (for example, for use in governmental or non-profit clients).

You can assign Account Classification codes and subcodes in the following areas.

- Setup > Chart of Accounts screen
- Actions > Enter Trial Balance screen
- Edit > Edit Multiple Accounts > Assign codes dialog (accessed from the Chart of Accounts screen or the Enter Trial Balance screen)
Let’s take a look at the Account Classification codes and subcodes assigned to an account.

1. Choose **Setup > Chart of Accounts**.
2. Select account **101 (Checking - General)** from the list on the left.

   Note that code **CA** is selected in the **Classification code** field and subcode **CASH** is selected in the **Classification subcode** field.

---

### Opening a predefined financial statement

To open a predefined financial statement, complete these steps.

1. Choose **File > Report Designer**.
2. Click the **Financial Statements** group button in the Reports list frame at the bottom-left.
3. Double-click the **Balance Sheet - Current Year - Prior Year** financial statement to open it.

### Previewing a predefined financial statement

To preview a financial statement for a particular client, complete these steps.

1. In the Current Client toolbar, verify that **ACSFSSC** is selected as the current client.
2. With the Balance Sheet - Current Year - Prior Year financial statement open, choose **File > Print Preview**.
3. In the Options dialog, verify the default settings and click OK to preview the financial statement.
The Print Preview screen provides a quick way to preview financial statements, but it also contains a number of useful tools in the toolbar.

- **Print All Reports.** Print all documents included in the print preview.
- **Print.** Print the selected document.
- **Copy.** Copy the selected document to the clipboard.
- **Find.** Search the document for keywords or amounts.
- **Annotations.** Insert text, lines, and other annotations to add notes and additional information.
- **Single or Multiple Page View.** Select the number of pages to preview at a single time.
- **Continuous Scroll.** Toggles the continuous scrolling option to browse seamlessly from one page to the next in the print preview.
- **Zoom In/Out.** Zoom in or out on the current page.
- **Page Navigation.** Browse to the next or previous page, with quick access to the first and last page of the document.
- **Selected Report.** Select a report from the dropdown menu in the upper-right corner to preview it.

When you finish reviewing the print preview options, close the Print Preview screen.
Copying a predefined financial statement

You can create a copy of a financial statement in the Report Designer so that you can customize that copy without altering the original.

1. With the Balance Sheet - Current Year - Prior Year financial statement open, choose File > Save As.
2. In the Save As dialog, enter Balance Sheet - Walkthrough Sample as the file name and click OK.
3. The financial statement opens in a new tabbed view in the design grid.

Notes

- As an alternative method, you can right-click a financial statement in the Reports list frame and choose the Copy and Paste commands to create a copy.
- If you customize a predefined financial statement and you want to restore it to the original version, select the financial statement in the Reports list frame and choose File > Restore Default.
- You can create custom folders for your clients in the Reports list frame to store your client-specific financial statements. For more information, see Associating custom folders with clients.
- Application updates that include changes to financial statements are applied to only the original predefined financial statements that have not been edited by your firm.
Modifying Financial Statements

Viewing and modifying cell, row, column, and region properties

Depending on what area of a financial statement is selected in the design grid, one of the following sections appears in the Design Tools frame – Cell Properties, Row Properties, Column Properties, or Region Properties.

Cell Properties

- Select cell B6 in the design grid to view its Cell Properties.
  - **Region.** Displays the region that corresponds to the current selection in the design grid.
  - **Cell.** Displays the cell reference that corresponds to the selected cell.
  - **Contents.** Enter text or click the Insert Formula button to create and insert a formula into the selected cell.
  - **Grouping type/Grouping content.** Select the grouping type and then select the applicable grouping content.
  - **Period.** Select the code that specifies the time periods from which to pull amounts. Click the Select Period button to open the Period dialog to view a complete list of period indicators and to create formulas.
  - **Amount type.** Select the amount type from which to pull amounts. If no amount type is selected, Balance will be used.
  - **Basis.** Select the basis from which to pull amounts. If no basis is selected, Adjusted will be used.
  - **Segments.** Select a segment code or combination of codes from a list of available segments that correspond to the current client.
  - **Print distinct values.** When marked, it enables variables to repeat only for each unique instance of the variable data.
  - **Print total amount.** When marked, it calculates the total amount for an amount variable that naturally repeats individual amounts.
  - **Repeat right.** When marked, it indicates a cell with a repeating variable that should repeat right rather than down.
Row Properties

- Select row 6 in the design grid to view its Row Properties.

- **Region.** Displays the region that corresponds to the current selection in the design grid.

- **Row.** Displays the row reference that corresponds to selected row.

- **Contents.** Enter text or click the Insert Formula button to create and insert a formula into the selected cells.

- **Grouping type/Grouping content.** Select the grouping type and then select the applicable grouping content.

- **Period.** Select the code that specifies the time periods from which to pull amounts. Click the Select Period button to open the Period dialog to view a complete list of period indicators and to create formulas.

- **Amount type.** Select the amount type from which to pull amounts. If no amount type is selected, Balance will be used.

- **Basis.** Select the basis from which to pull amounts. If no basis is selected, Adjusted will be used.

- **Title row.** When marked, it indicates that the selected row is a title row. Title rows are automatically repeated on subsequent pages and are commonly used for rows that include column-heading text.

- **Print zeros.** When marked, it indicates that the selected row should print even if all amounts in the row are zero. When cleared, zero-amount rows do not print.

- **Print distinct values.** When marked, it enables variables to repeat only for each unique instance of the variable data.

- **Optional section/Section name/Print by default.** When marked, it indicates that the current selection can optionally be set for inclusion or exclusion at print time. Specify a name for the optional section. To include the section by default at print time, mark the *Print by default* checkbox.
Column Properties

- Select column B in the design grid to view its Column Properties.

- **Region.** Displays the region that corresponds to the current selection in the design grid.

- **Column.** Displays the column reference that corresponds to the selected column.

- **Contents.** Enter text or click the Insert Formula button to create and insert a formula into the selected cells.

- **Period.** Select the code that specifies the time periods from which to pull amounts. Click the Select Period button to open the Period dialog to view a complete list of period indicators and to create formulas.

- **Amount type.** Select the amount type from which to pull amounts. If no amount type is selected, Balance will be used.

- **Basis.** Select the basis from which to pull amounts. If no basis is selected, Adjusted will be used.

- **Segments.** Select a segment code or combination of codes from a list of available segments that correspond to the current client.

- **Title column.** When marked, it indicates that the selected column is a title column. Title columns are automatically repeated on subsequent pages and are commonly used for columns that include row-heading text.

- **Print zeros.** When marked, it indicates that the selected column should print even if all amounts in the column are zero. When cleared, zero-amount columns do not print.

- **Print total amount.** When marked, it calculates the total amount for an amount variable that naturally repeats individual amounts.

- **Optional section/Section name/Print by default.** When marked, it indicates that the current selection can optionally be set for inclusion or exclusion at print time. Specify a name for the optional section. To include the section by default at print time, mark the Print by default checkbox.
Region Properties

- Select the title bar for region **Main** in the design grid to view its Region Properties.

  - **Region.** Displays the region that corresponds to the current selection in the design grid.

  - **Optional region/Region name/Print by default.** When marked, it indicates that the current region can optionally be set for inclusion or exclusion at print time. Specify a name for the optional region. To include the region by default at print time, mark the *Print by default* checkbox.
Working in a financial statement

The Report Designer provides a number of convenient features to help you create, edit, and print your financial statements.

Page setup

You can make changes to the overall format of financial statements by modifying the page setup. For example, you can customize the settings for margins, page orientation, headers and footers, date options, watermarks, and page borders.

2. Click each tab to view the available page setup options and then click OK to close the dialog.

Cell, row, and column setup

You can make changes to specific areas of financial statements by modifying cell, row, and column formatting.

Let’s take a look at some of the setup and formatting used in the Balance Sheet - Walkthrough Sample financial statement that you copied from the predefined financial statement earlier in this chapter.

1. Select cell A1 in the Main region and note the following:
   - The contents of the cell (Assets) appears in the cell in the design grid, in the Formula bar above the design grid, and in the Contents field in Cell Properties.
   - Cells A1 through D1 were merged to form this cell. To merge cells in the design grid, select the cells to merge and then click the Merge and Center button in the Formatting toolbar.
2. Select cell B3 in the Main region and note the following:
   - The contents of this cell ([System.FinancialStatement.PeriodEndDate]) is a variable. When you print or preview this financial statement, this variable is replaced by the ending date of the period you selected for the financial statement.
   - The period CY (Current year-to-date) in the Period field in Cell Properties indicates the period end date that the cell is based on.
3. Select row 6 in the Main region and note the following:
   - The Row Properties include Account Classification as the Grouping type and CA as the Grouping content.
   - The Print zeros checkbox is not marked in Row Properties, so the statement will automatically exclude any core account with zero balances.
   - The row is grouped into repeating level 1 by using the Format > Row > Group into Repeating Level command. Because the row contains the [ChartofAccountsActivity.Core.GLAccountDescription] variable in column A and the [ChartofAccountsActivity.Core.Amount] variable in columns B and D, each core account and its corresponding balance repeat in separate lines for all core accounts assigned to the Account Classification code CA.
4. Choose **File > Print Preview** and click OK in the Options dialog. Note that row 6 displays a line for each account assigned to code CA (Current Assets).

<table>
<thead>
<tr>
<th>Current Assets</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Checking - General</td>
<td>$18,235.21</td>
<td>$81,252.41</td>
</tr>
<tr>
<td>Checking - Payroll</td>
<td>$10,373.62</td>
<td>3.00</td>
</tr>
<tr>
<td>Petty Cash</td>
<td>1,880.20</td>
<td>1,060.00</td>
</tr>
<tr>
<td>Cash - Savings</td>
<td>283,162.41</td>
<td>110,443.21</td>
</tr>
<tr>
<td>Marketable Securities</td>
<td>5,000.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Billed Receivables</td>
<td>46,931.40</td>
<td>65,442.70</td>
</tr>
<tr>
<td>Unbilled Receivables</td>
<td>31,094.96</td>
<td>27,895.76</td>
</tr>
<tr>
<td>Unbilled Expenses Receivable</td>
<td>4,960.35</td>
<td>5,884.56</td>
</tr>
<tr>
<td>Accounts Receivable - Employees</td>
<td>8.00</td>
<td>1,590.00</td>
</tr>
<tr>
<td>Deposits &amp; Prepaid Expenses</td>
<td>4,600.00</td>
<td>4,600.00</td>
</tr>
</tbody>
</table>

**Total Current Assets**

|          | 405,218.35 | 235,779.72 |

5. Click the **Close** button to close the Print Preview screen.

6. Select row **17** in the Main region and note the following:

   - The **Row Properties** include **Account Classification** as the Grouping type and **NPE : AD** as the Grouping content.
   - The **Print zeros** checkbox is not marked in Row Properties, so the statement will automatically exclude this row if it totals to zero.
   - The row is grouped into repeating level 1. Because the row contains text in column A and the [ChartofAccountsActivity.Core.Amount] variable in columns B and D, and because the **Print total amount** checkbox is marked in Cell Properties for cells B17 and D17, only the total balance is displayed for *all* core accounts assigned to the Account Classification code/subcode **NPE : AD**.

7. Choose **File > Print Preview** and click OK in the Options dialog. Note that row **17** displays a single total line for the accounts assigned to code **NPE** (Net Property and Equipment) and subcode **AD** (Accumulated Depreciation).

<table>
<thead>
<tr>
<th>Property and Equipment</th>
<th>28,000.00</th>
<th>28,000.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leasehold Improvements</td>
<td>24,315.07</td>
<td>24,315.07</td>
</tr>
<tr>
<td>Furniture &amp; Fixtures</td>
<td>9,681.00</td>
<td>9,681.00</td>
</tr>
<tr>
<td>Office Equipment</td>
<td>60,461.01</td>
<td>26,116.01</td>
</tr>
<tr>
<td>Software</td>
<td>6,925.60</td>
<td>6,925.60</td>
</tr>
</tbody>
</table>

**Less Accumulated Depreciation**

| (48,892.07) | (51,243.72) |

**Net Property and Equipment**

| 68,248.81  | 35,629.21  |

8. Click the **Close** button to close the Print Preview screen.

9. Select column **D** and note that this column is a copy of column **B**, but with a different period indicator applied.
Note: Beyond some Client and System variables, the most common variables used in financial statements are the following:

- To display the GL account number for repeating accounts:
  [ChartofAccountsActivity.Core.GLAccount]

- To display the GL account description for repeating accounts:
  [ChartofAccountsActivity.Core.GLAccountDescription]

- To display the GL account balance for repeating accounts or a total of accounts, depending on the formatting applied:
  [ChartofAccountsActivity.Core.Amount]

Cell formatting

You can make font, format, alignment, and border changes to specific cells of financial statements by modifying the cell formatting.


2. Choose Format > Cells and note the following:

   - In the Font tab, the font options are set with the following formatting:

     | Font       | Tahoma     |
     |------------|------------|
     | Size       | 8          |
     | Style      | Regular    |
     | Color      | Black      |
     | Underline style | Single accounting |
     | Transparency | 0      |
     | Case       | <None>     |
     | Strikethrough | <None> |

   - In the Format tab, the category is set to Amount with the following formatting:

     | Decimal places | 2          |
     | Dollar sign    | Non-repeating fixed $ |
     | Negative amounts | (123.99) |
     | Zero amounts   | 0          |
     | Use 1000 separator (,) | Marked |
     | Use zero when no data | Marked |
     | Numbers (99)   | Marked     |
In the Alignment tab, the alignment options are set with the following formatting:

<table>
<thead>
<tr>
<th>Horizontal</th>
<th>Right</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical</td>
<td>Top</td>
</tr>
<tr>
<td>Indent</td>
<td>0</td>
</tr>
</tbody>
</table>

In the Border tab, the Style selection is set to None so that no borders appear.

3. You do not need to make any changes to this cell formatting, so click the Cancel button to close the dialog.

**Notes**

- If you make any changes in this dialog and multiple cells are selected, the settings in the Format Cells dialog will be applied to all selected cells when you click OK to save the changes.

- Many settings in the Format Cells dialog are also available in the Formatting toolbar and in the Text section of the Design Tools frame. This allows you to change individual settings without opening the Format Cells dialog.
Working with variables, formulas, functions, and periods

You can add elements to financial statements to define exactly what data to print and you can maintain global financial statements that can be used for multiple clients.

Let's take a look at some variables, formulas, functions, and period indicators in this financial statement.

Variables
You can insert variables using a couple of different methods in the Report Designer.

Using the Variables tree
2. Choose Edit > Delete to clear the contents of the cell.
3. Click the Variables group button in the Design Tools frame (or choose Insert > Variable).
4. In the Variables tree, click the + sign next to the Chart of Accounts Activity branch.
5. Click the + sign next to the Core sub-branch.
6. Double-click the GL Account Description variable name (or drag and drop it from the Variables tree into cell A6).
Using the Formula dialog


2. Clear the contents of the cell.

3. Choose Insert > Formula (or click the Insert Formula button in the Formula bar above the design grid or in the Contents field in Cell Properties).

4. In the Variables tree in the Formula dialog, click the + sign next to the Chart of Accounts Activity branch.

5. Click the + sign next to the Core sub-branch.

6. Click the GL Account Description variable name.

7. Verify that the Formula field displays the full variable within brackets as [ChartofAccountsActivity.Core.GLAccountDescription].

8. Click OK to save and close the dialog.
Formulas
You can create simple or complex formulas to calculate values across a variety of elements in the Report Designer, such as summing together variables, cell, row, or column values, fixed amounts, and so forth.

Example 1: Adding individual cell values
1. Select cell B20.
2. Clear the contents of the cell.
3. Choose Insert > Formula.
4. In the Cell field, enter B11.
5. Click the Plus button in the Operators section.
6. In the Cell field, enter B13.
7. Click the Plus button in the Operators section.
8. In the Cell field, enter B15.
9. Click the Plus button in the Operators section.
10. In the Cell field, enter B17.
11. Verify that the Formula field displays the full formula within brackets as \([B11 + B13 + B15 + B17]\).
12. Click OK to save and close the dialog.

Example 2: Adding a range of row values
1. Select cell B20.
2. Clear the contents of the cell.
3. Choose Insert > Formula.
4. In the Row fields, enter 11 in the first field and enter 17 in the second field.
5. Verify that the Formula field displays the full formula within brackets as \([\text{Row}(11:17)]\).
6. Click OK to save and close the dialog.
Functions
You can create functions to display or calculate specific values in the Report Designer, such as displaying dates, counts, or a running total with user-defined parameters.

Example: Displaying two dates with different formatting and period indicators
1. In the Header region, select cell A4.
2. Clear the contents of the cell.
3. Choose Insert > Formula.
4. In the Details section, click the Functions option.
5. In the Formula field, enter As of (including a trailing space).
6. In the Functions grid, click the Date row header.
7. In the Variable 1 field, click the Variables button.
8. In the Variables tree of the Variables dialog, click the + sign next to the System branch.
9. Click the + sign next to the Financial Statement sub-branch.
10. Click the Period End Date variable name.
11. Click OK to save your selection and close the dialog.
12. In the Date format field, select MMMM d, yyyy.
13. In the *Period* field, select **CY**.

14. In the *Formula* field, enter **and** (including both a leading space and a trailing space).

15. In the *Date format* field, select **yyyy**.

16. In the *Period* field, select **1PY**.

17. Verify that the *Formula* field displays the full formula within brackets as

   As of \[Date(System.FinancialStatement.PeriodEndDate,"MMMM d, yyyy","CY")\] and
   \[Date(System.FinancialStatement.PeriodEndDate,"yyyy","1PY")\].

18. Click OK to save your selections and close the dialog.
Periods
You can use period indicators to pull amounts for a specific time period in the Report Designer. A period indicator is commonly applied to cells, but it can also be applied as a parameter of certain variables and functions.

1. Select column B.
2. Select CY (Current year-to-date) from the drop-down list in the Period field in the Column Properties.
3. Select column D.
4. Select 1PY (1 prior year-to-date) from the drop-down list in the Period field in the Column Properties.

Notes
- The drop-down list in the Period field includes commonly used period indicators.
- You can apply period indicators to cells in the Period field in Cell Properties, Row Properties, or Column Properties, but they are most commonly applied to all cells within a given column via Column Properties.
- If you use differing period indicators in the cells within a given column, the Period field in Column Properties will be blank and you will need to use Cell Properties to view and assign the period indicators.
- The Period dialog enables you to create a formula for a calculation with multiple period indicators. For example, for a monthly client you may want to add the three most recent periods (current period, 1 period ago, and 2 periods ago) with a formula of \((CP) + (CP-1) + (CP-2)\) to calculate a quarterly total.

Page breaks
You can add page breaks to financial statements to define exactly where you want a new page to begin.

Notice the dotted red line between rows 28 and 29. This indicates that a page break has been inserted to begin a new page immediately before row 29.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th>Liabilities and Equity</th>
</tr>
</thead>
<tbody>
<tr>
<td>28</td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Notes
- To add a page break, select a row or column where the new page should begin and choose Insert > Page Break.
- To remove a page break, select a row or column with an existing page break immediately before it and choose Insert > Remove Page Break.
Conditional expressions

You can add conditional expressions to financial statements that are based on specific criteria that determine whether a section should be printed.

Let's take a look at an existing conditional expression in this financial statement.

1. Select row 22.

2. Choose Format > Conditional Expression and note the following:
   - The condition applied to this row tests whether any lines will be included for non current assets on row 23 by using the Row Count function.
   - If the row count of row 23 is greater than zero (0), then it will print row 22.
   - If the row count is not greater than zero (0), then the condition is complete and it will not print row 22.

3. You do not need to make any changes to this conditional expression, so click the Cancel button to close the dialog.

**Notes**

- To add a conditional expression, select a cell or row and choose Insert > Conditional Expression.
- To remove a conditional expression, select a cell or row with an existing conditional expression and choose Insert > Remove Conditional Expression.
- A small green triangle symbol in the upper-right corner of a cell or row indicates that a conditional expression has been applied to that cell or row.
Using the Help & How-To Center

Our Help & How-To Center provides extensive information about using the Report Designer. A good topic to start with is the Report Designer overview.

To access the Help & How-To Center, use any of the following methods.

- Enter a search term in the search field in the toolbar to search for topics related to that term.
- Click the Help & How-To button to open a topic explaining the current screen and click the down arrow to open a list of tasks and topics related to the screen.
- Press F1 to view help that is relevant to the current screen.
- Choose Help > Help & How-To to open the Browse subjects for Accounting CS topic.

In the Help & How-To Center, use the toolbar to find the information you need.

Note: Every topic in the Help & How-To Center includes a box on the right that provides quick access to alerts and other timely information.