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Introduction 
The Utilities > Data Conversion > ProSystem fx > Engagement Trial Balance command in Creative 
Solutions Accounting™ (CSA) allows you to convert and import trial balance data from ProSystem fx® 
Engagement versions 6.0.x to 7.0.x into Trial Balance CS® within CSA and the CS Professional Suite® 
Accounting Products. 

To avoid possible delays in converting your data, do not install any updates to ProSystem fx 
Engagement. Doing so could change the format of the client data and could require an update to the CSA 
conversion program to enable you to convert your client data. This conversion program was written to 
convert data only from ProSystem fx Engagement v.6.0.x – 7.0.x, as noted above. 

Read this entire document before converting your client data. 

Conversion program overview 
The overall objective of the ProSystem fx Engagement trial balance to Trial Balance CS conversion 
program is to convert data from the trial balance worksheets in ProSystem fx Engagement trial balance to 
Trial Balance CS in CSA. You can then use the converted data to create financial statements and trial 
balances, to print reports in CSA, and to provide data for Engagement CS. This conversion can be used 
in conjunction with the ProSystem fx Engagement conversion to provide more comprehensive 
information. The conversion utility converts only one trial balance worksheet from ProSystem fx 
Engagement into one CSA client and can convert the worksheet on an annual basis.  

Due to differences in processing calculations and data structures between ProSystem fx Engagement 
and CSA, some ProSystem fx Engagement data cannot be converted. Therefore, you should not 
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expect to exactly duplicate results from ProSystem fx Engagement using the converted data 
without adding or modifying the appropriate data in CSA. The specific items that cannot be converted 
and conversion exceptions are listed in the section of this document that starts on page 8. 

Note: This conversion utility is not designed to convert data from ProSystem fx Trial Balance. If you need 
to convert from ProSystem fx Trial Balance, open CSA, choose Help > Help & How-To and enter 
ProSystem fx Trial Balance conversion guide in the search field. 

Processing steps required for each client prior to running the 
conversion program 
 We strongly recommend that you make a backup of the ProSystem fx Engagement client data before 

beginning the conversion process. The conversion program will not change any of your ProSystem fx 
Engagement data. If you need to modify the data in ProSystem fx Engagement as part of the 
conversion process, making a backup will enable you to restore the original data. 

 The ProSystem fx Engagement to CSA conversion program assumes that you have finished the 
processing period for the client in ProSystem fx Engagement and that you will be processing the next 
period’s transactions in CSA. If you have already begun a new processing period in ProSystem fx 
Engagement, you should not run the conversion until you have posted all transactions for that period.  

For example, if you are processing November for monthly client 123, you should post the transactions 
in the November period in ProSystem fx Engagement and then convert to CSA prior to entering any 
December transactions. 

Note: We recommend that you not close the year before converting your ProSystem fx Engagement 
client. Employee pay items and general ledger transactions are converted only for the current year. 
Closing the year would cause pay items and transactions to be zero and would stop any of last year’s 
transactions from converting. 

 The conversion program generates a report in PDF that is saved in the ProSystem fx Engagement 
client data folder. This report contains notes and information on changes you may need to make to 
the client data in CSA. We recommend that you print this report after finishing the conversion process 
but before importing the client into CSA. You need to have Adobe® Reader® version 7.0 or higher 
installed to view and print this report. If Adobe Reader is not already installed on your computer, 
choose Help > On the Web > Adobe Reader from the CSA main window; this takes you to the Adobe 
website from which you can download and install the Reader. 

 To avoid possible delays in converting your data, do not install any updates to ProSystem fx 
Engagement. Doing so could change the format of the client data and could require an update to the 
CSA conversion program to enable you to convert your client data. This conversion program was 
written to convert data only from ProSystem fx Engagement v.6.0.x – 6.11.100, as noted above. 

 Prior to running the conversion, please be sure that you have installed your CS Professional Suite 
Accounting Products applications on the machine where the Conversions CD will be run. 

Installing the Conversions CD 
1. Uninstall any previously installed versions of the CS Professional Suite Accounting Products 

Conversions CD. 

http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/pdfs/conversionguide_prosystemfxtb_to_csa_tbs.pdf?product=csa&mybanner=1
http://www.adobe.com/
http://www.adobe.com/
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a. From the Window® Start menu, choose Control Panel. (On some Windows operating systems, 
you may need to choose Settings > Control Panel.) 

b. Double-click Add Remove Programs. 

c. Scroll to CS Accounting Conversions (or to CSI Accounting Conversions) and highlight that 
item. 

d. Click the Change/Remove button. 

e. At the prompt, click Yes to uninstall the program. 

2. Place the enclosed Conversions CD in the CD drive on your computer. 

3. The setup program will open automatically, or you can do the following to open it: 

a. Open Windows Explorer and navigate to your CD drive. 

b. Double-click SETUP.EXE. 

4. Follow the prompts on the screen to install the CSA Conversion programs. 

5. After the conversion program has been successfully installed, store the CD in a secure place. 

Notes 

 You need to install the conversion program on each local machine from which you will run the 
conversion program. 

 Once you have converted all of your accounting client data, you can remove the Accounting 
Conversion program from your computer by repeating step 1 above. 
 

Before converting the client data 
Before converting your trial balance data, review the data in ProSystem fx Engagement. Please follow the 
suggestions below to prepare your data for conversion. 

1. Review the Chart of Accounts data associated with the trial balance you will be converting. CSA 
requires that you set up a Chart of Accounts mask and number your accounts to conform to the mask 
format. You should confirm that all the account numbers in this trial balance conform to a single 
format, and you will need to use that same format as the Chart of Account mask in CSA. 

2. CSA allows account numbers that consist of up to 60 alphanumeric characters and separators 
(hyphens and slashes, plus a single decimal). Any other characters will be stripped from the account 
number during the conversion. 

3. During the conversion, verify that all account numbers are associated with an “Account Type”. Only 
the accounts that are associated with one of the available account types (Asset, Liability, Expense, or 
Revenue) will be converted. All other accounts will be excluded from the conversion. 

4. The conversion will accept only one Tax account group, which is used only to assign a tax code to 
your accounts. The Tax group does not convert to CSA as a grouping schedule. You should 
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determine which account group to assign as the Tax group. Note that tax codes are not converted if 
you choose not to select a Tax group. 

5. The conversion accepts a maximum of five grouping schedules. You should determine which account 
groups to convert. If you choose not to convert any account groups, you will need to create the 
grouping schedules in CSA manually.  

Converting the client data prior to import into CSA 
Complete these steps to create the ProSystem fx Engagement export files. The export file is a specially 
formatted file that CSA can use to import your data. The conversion program does not change your 
original ProSystem fx Engagement data in any way. 

Important! The conversion program cannot create an export file for a client that is locked by 
ProSystem fx Engagement. Ensure that the client is not in use and exit ProSystem fx Engagement before 
continuing. We recommend that the binder in ProSystem fx Engagement to which the trial balance is 
associated be synchronized with the Central File Room before converting. 

1. Double-click the CS Conversion icon on your desktop to start the conversion program. If you did not 
install the shortcut, click Start on the Windows taskbar and then choose Programs > Creative 
Solutions > CS Conversions.  

2. In the Conversion Type field, select Trial Balance. 

3. In the Competitor field, select ProSystem fx Engagement trial balance. 

4. In the Input Data Folder field, enter the path to the ProSystem fx Engagement client data you want to 
convert. The path defaults to C:\Pfx Engagement\TB\Data. If your ProSystem fx Engagement data is 
in a different location, click the Browse button to navigate to the drive and folder. 

5. Click Start to begin the conversion. 

6. The Select client to convert screen lists all clients found in the specified data folder. Select a client 
and then click the Continue button.  

7. The Select engagement to convert screen lists all binders found for the client. Select an 
engagement and then click the Continue button.  

8. The Select trial balance to convert screen lists all trial balances found in the selected engagement. 
Select the correct trial balance and then click the Continue button.  

9.  ProSystem fx Engagement does not explicitly specify whether an account is an asset, liability, equity, 
revenue, or expense account type. However, CSA requires that you assign an account type to each 
converted account. In the Select accounts to convert screen, mark a checkbox to assign an 
account type, and then specify the accounts to assign to that type. Repeat this step for all four 
account types. Only accounts assigned to a type are converted.  

Important! The Select accounts to convert screen highlights account numbers that do not follow 
the same Chart of Accounts mask. If you select accounts highlighted with different colors, you will not 
be able to import the trial balance into CSA. If all the account numbers follow the same Chart of 
Accounts mask, no items are highlighted. 
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10. The Select groups to convert screen lists all Groupings found in the selected trial balance. Assign 
the Tax group and up to five Account groups to be converted and then click the Continue button.  

11. Click the Continue button to begin the conversion process.  

12. When the conversion is complete, click OK. To process another client, repeat steps 5 to 12 above. 
Otherwise, click the Close button and continue to the next step. 

Note: If you have a very large client database with many transactions, the conversion process may 
take several minutes to complete. Allow the conversion program time to complete the process. 

Important! Because the conversion program names the import files based on the ProSystem fx 
Engagement client ID, the conversion program overwrites the conversion import files if a second trial 
balance is to be converted for the same client to another client in CSA. If this occurs, these clients 
must be processed one at a time to avoid overwriting the Client Data Transfer Report and the 
accounting data files. Therefore, we strongly recommend that you convert and then import the clients 
one client at a time.  

13. After creating the export files and prior to importing the converted client data into CSA, you should 
print the conversion report. To print this report, choose Start > Run on the Windows taskbar and 
enter the same ProSystem fx Engagement client data path you entered in step 4 above. Open the file 
labeled with <first 6 characters of the ClientID>_T.PDF. For example, if the ProSystem fx 
Engagement client ID was ABCDEFG, the conversion report will be named ABCDEF_T.PDF. 

Note: If more than one local file room is present (for example, because more than one staff has logged 
into ProSystem fx on the conversion computer), the local file room associated with the Admin login is 
used. You should log into ProSystem fx Engagement as Admin and synchronize the binders to ensure 
that the proper information is converted.  

Importing the converted files into CSA 
Complete these steps to import the converted files for a client from ProSystem fx Engagement into CSA.  

1. Start CSA by double-clicking the desktop shortcut. 

2. Create a new client in CSA by choosing File > New Client. For more information on creating a new 
client, choose Help > Help & How-To and enter New Client [File menu] in the search field. If you are 
converting engagement and trial balance information, you will need to select Engagement CS, Trial 
Balance CS, and the Financial Reporter module when adding the client  

Important! When you add a new client to CSA, you must enter the current period end date and the 
current fiscal year end date exactly as they appear in the ProSystem fx Engagement. The conversion 
utility converts all trial balances to CSA as annual data. 

3. From the CSA main window, choose Utilities > Data Conversion > ProSystem fx > Engagement 
Trial Balance. 

4. In the first field of the ProSystem fx Engagement Import dialog, enter the location of the ProSystem fx 
Engagement data files to import into CSA. This is the same folder location you specified in Step 4 of 
the section entitled Converting the client data prior to import into CSA.” 

5. Specify the client ID from the drop-down list in the Client to Import field. 

http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/topics/hidd_clientprop.htm?product=csa&mybanner=1


 

TL 27556 Conversion Guide: Trial Balance Data from ProSystem fx Engagement to Trial Balance CS 
Page 6 Copyright 1998 - 2014 by Thomson Reuters. All rights reserved. 

6. Click the Import button. 

7. Once the import has finished, make any necessary changes or corrections to the converted data as 
specified in the sections of this document entitled “Items transferred during conversion of data from 
ProSystem fx Engagement” and “Conversion notes and exceptions.” 

Items transferred during conversion of data from 
ProSystem fx Engagement 
The following tables identify fields in ProSystem fx Engagement that are converted to Trial Balance CS in 
CSA. The tables are organized by screens in ProSystem fx Engagement and CSA and denote the 
necessary CSA screen navigation.  

General ledger account information 
ProSystem fx 
Engagement field 
name 

CSA menu navigation 
CSA field name 

Comments and additional 
information 

 Setup > Chart of Accounts 

Account Number Account See “Conversion notes and exceptions” 
for more information on the conversion 
of the account numbers. 

Account Type Type See “Conversion notes and exceptions” 
for more information on the conversion 
of the account type. 

Account Description Description  

Unadjusted Balance Balance See “Conversion notes and exceptions” 
for more information on the conversion 
of the current year balances. 

Tax Group and 
Subgroup assignment 

Tax Code See “Conversion notes and exceptions” 
for more information on the conversion 
of the tax codes. 

Journal entries 
ProSystem fx 
Engagement field 
name 

CSA menu navigation 
CSA field name 

Comments and additional 
information 

 Tasks > Adjusting Journal Entries 

JE #  Reference  See “Conversion notes and exceptions” 
for more information on the conversion 
of Journal Entry numbers. 

Type Entry Types See “Conversion notes and exceptions” 
for more information on the conversion 
of types. 
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 Date See “Conversion notes and exceptions” 
for more information on the conversion 
of dates. 

Account # Account  

Description Description  

Debit/Credit Amount  
 

Grouping codes and subcodes 
ProSystem fx 
Engagement field 
name 

CSA menu navigation 
CSA field name 

Comments and additional 
information 

 Setup > Grouping Schedules 

Grouping List Grouping Schedule 
Description 

See “Conversion notes and exceptions” 
for more information on the conversion 
of grouping codes. 

Group Index Code  

Group Description Code Description  

Subgroup Index Subcode  

Subgroup Description Subcode Description  
 

Items not transferred during conversion of data from 
ProSystem fx Engagement 
Although most trial balance data from ProSystem fx Engagement is converted, some data cannot be 
converted due to differences in application features and data structures between ProSystem fx 
Engagement and CSA. The following items are not converted. 

Consolidated trial balance 
Consolidated trial balances are not converted.  

Write-up and general ledger trial balances 
Trial balances formatted as Write Up or General Ledger cannot be converted. 

General client information 
Client name, address, EIN, entity type, and fiscal year end are not converted. You can add this 
information to the client in the CSA Client Properties dialog during the client setup or after the conversion 
has been completed.  
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Groups and ratio groups 
Groups and ratio groups are not converted.  

Financial statements 
Reports, and financial statements cannot be converted. Workpapers can be converted using the 
ProSystem fx Engagement to Engagement CS conversion utility. 

Conversion notes and exceptions  
This section provides details on conversion notes and exceptions between the trial balance data from 
ProSystem fx Engagement and the converted data in CSA. Conversion exceptions may include 
differences in field lengths between ProSystem fx Engagement and CSA, the need for manipulation of 
data to conform to CSA requirements, and so forth. 

Account number 
While ProSystem fx Engagement does not have a Chart of Accounts mask setup available, most of your 
accounts will be entered using a similar format. CSA requires that you set up a Chart of Accounts mask 
and number your accounts to conform to the mask format. For more information about acceptable mask 
and account number formats, choose Help > Help & How-To and enter Chart of Accounts mask special 
information and examples in the search field. Here are some examples of differences you may see: 

 If account numbers include leading zeros, when creating the CSA client you must mark the Allow 
leading zeros checkbox on the New Client > General Information tab. If that checkbox box is left 
unmarked, the import will strip the leading zeros. 

 Alphanumeric characters and separators (hyphens and slashes, plus a single decimal) are allowed in 
the CSA Chart of Accounts mask. If your accounts in ProSystem fx Engagement contain other 
characters, the conversion will remove the characters. In the event that this causes duplicate Chart of 
Account numbers, the duplicates will be renumbered. The CLIENTID_T.pdf (where CLIENTID 
represents the ID of the client that you’ve converted) will alert you to these changes and should be 
checked after creating the conversion files but prior to importing into CSA. 

Important! Your Chart of Accounts mask in CSA must match the setup of your ProSystem fx 
Engagement accounts. If an account is renumbered during the conversion, you must set up your 
Chart of Accounts mask to be large enough to accommodate the renumbered account. Failure to do 
so will result in an error message upon import. For more information, choose Help > Help & How-To 
and enter Chart of Accounts mask special information and examples in the search field. 

 While multiple separators (hyphens and slashes) can be used in the CSA Chart of Accounts mask, 
only one decimal can be used. If your accounts in ProSystem fx Engagement contain more than one 
decimal, the conversion program will remove the extra separators.  

Account type 
Multiple account types can be assigned to an account in ProSystem fx Engagement, but only one type is 
allowed for each account in CSA. You will be prompted during the conversion to select the account type 
(asset, liability/equity, revenue, or expense) for each account. If an account is not assigned a type, that 
account will not be converted to the Chart of Accounts. 

http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/common/coa_maskexamples_defn.htm?product=csa&mybanner=1
http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/common/coa_maskexamples_defn.htm?product=csa&mybanner=1
http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/common/coa_maskexamples_defn.htm?product=csa&mybanner=1
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Journal entries 
If an account is not assigned a type but the account is referenced in a journal entry, the account number 
in the journal entry will be 999. Therefore, we recommend that all accounts in the Chart of Accounts be 
assigned to an account type. Journal entries with a JE # of 1 are converted as Reference 1.1. The 
Journal Entry Date defaults to the current period ending date. 

Unadjusted balance 
Due to differences between ProSystem fx Engagement and CSA, only the current-year balances can be 
converted. The conversion uses the year-end date in the ProSystem fx Engagement binder to assign a 
date to the unadjusted balances.  

Grouping codes 
Only five grouping schedules are allowed in CSA. The conversion program will convert up to five grouping 
schedules that have been selected during the conversion process.. 

Tax codes 
The Tax Grouping List selected during the conversion program converts as account tax codes. M3 Option 
codes are not converted. For more information, choose Help > Help & How-To and enter Schedule M-3 
tax code assignment in the search field. 

Verifying your converted data 
Although the conversion utility has been designed to convert your data as accurately as possible, careful 
examination of the converted client data is recommended.  

Complete the following steps after the conversion has finished: 

1. Make all the necessary changes as noted in the “Conversion notes and exceptions” section of this 
document. 

2. In ProSystem fx Engagement, print the trial balance report that you converted. 

3. In CSA, print the Trial Balance Report and the Adjusting Journal Entry Report.  

4. Compare the reports. If the information contained in the ProSystem fx Engagement report does not 
match the information in the CSA reports, you will need to determine which journal entries or account 
balances are invalid or missing and enter the information into CSA manually. Other reports are 
available in both applications if you cannot determine the discrepancy using the reports listed above. 

Help and Support 

Help & How-To Center 
For answers to questions on using CSA, access the Help & How-To Center by choosing Help > Help & 
How-To, by clicking the  button on the toolbar, or by pressing CTRL+Y. For more information, including 
sample searches, see Finding answers in the Help & How-To Center.  

http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/gl_tb/schedule_m_3_tax_code_assignment_defn.htm?product=csa&mybanner=1
http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/gl_tb/schedule_m_3_tax_code_assignment_defn.htm?product=csa&mybanner=1
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/getting_help/using_online_help.htm?product=csa&mybanner=1
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Product support 
From the Support Contact Information page on our website, you can complete a form to send a question 
to our Support team. To speak directly with a Support Representative, call (800) 968-0600, press 2 for 
Product Support, and listen to the available options. Normal weekday support is available from 9:00 a.m. 
to 8:00 p.m. eastern time. For additional details (including extended support hours for tax season and 
hours for other applications), visit the Support section of our website. You can also access the Support 
section from within CSA by choosing Help > Additional Resources > General Support Information. 

Website resources and email subscriptions 
Visit our website to access the ARNE Community (an online user forum), to learn about training courses, 
to view blogs and articles, and more. You can access the website from within CSA by choosing Help > 
On the Web > CS Professional Suite Home Page. 

We issue application update notices via email. You can sign up to receive these notices by visiting the My 
Account section of our website. You’ll need to create a web account (if you don’t already have one) and 
then sign up for the Email Subscription service where you can indicate which notices you want to receive. 

 

 

http://cs.thomsonreuters.com/support/contact.aspx
http://cs.thomsonreuters.com/support/
http://cs.thomsonreuters.com/
http://cs.thomsonreuters.com/myaccount/
http://cs.thomsonreuters.com/myaccount/
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