Contents

Introduction............................................................................................................... 1
  Opening the sample database .................................................................................. 1
  Backing up the sample database .............................................................................. 2

Walkthrough Exercises............................................................................................ 5
  User preferences for billing ..................................................................................... 5
    Setting up user preferences for billing ................................................................. 5
    Other billing preferences ....................................................................................... 7
  Firm preferences for billing ................................................................................... 7
    Enabling the approval process for billing ............................................................. 7
    Other firm billing preferences .............................................................................. 8
  Using the Billing Worksheet .................................................................................... 9
  Using the Billing screen .......................................................................................... 12
    Selecting the WIP to bill ....................................................................................... 12
    Standard Bill ......................................................................................................... 14
    Quick Bill ............................................................................................................ 15
    Zero Bill ................................................................................................................ 17
  Detail billing .............................................................................................................. 18
    Overview of the Summary tab ............................................................................. 18
      Entering billing information in the Summary tab .............................................. 19
    Overview of the Time & Expense Entry tab ...................................................... 21
      Editing a transaction in the Time & Expense tab .............................................. 22
      Smart Bill ............................................................................................................ 24
      Allocating an adjustment to a different staff member ....................................... 26
      Adding an adjustment entry ............................................................................. 27
  Progress billing ........................................................................................................ 29
    Creating a progress bill – Summary tab ............................................................... 29
    Clearing a progress bill ......................................................................................... 32
    Creating a progress bill – Time & Expense tab ................................................. 33
  Relieving nonbillable time and expenses ............................................................... 35
  Composing an invoice ............................................................................................ 36
  Previewing an invoice ............................................................................................. 39
Contents

Approving and posting an invoice.................................................................39
Editing invoices.........................................................................................41
Unbilling an invoice..................................................................................42
Viewing the Journal ................................................................................44
Recurring bills ..........................................................................................44
Creating a recurring bill description .........................................................45
Setting up a recurring bill for the client’s engagement ..............................45
Generating a recurring bill .................................................................46
Previewing and printing invoices .................................................................47
Previewing an invoice .............................................................................48
Printing an invoice ..................................................................................49
Printing an invoice to NetClient CS .........................................................50
Custom invoice formats ...........................................................................55
Setting up a custom invoice format using the Format Wizard ...............55
Customizing invoice and statement formats .............................................61
  Toolbars and menus ............................................................................61
  The Properties pane .............................................................................62
Restoring the sample database .................................................................63
Introduction

This walkthrough introduces you to the process of billing your clients in Practice CS. After you have completed the walkthrough, you will have a good understanding of the various methods of billing available in Practice CS. You will also learn about producing invoices and creating custom invoice formats.

Note: This walkthrough assumes you are familiar with using Practice CS or that you have read chapter 3, Program Overview, in the Practice CS Getting Started guide.

Opening the sample database

To perform the exercises in this walkthrough, you will start Practice CS and log in to the Sample database as staff CAT. To log in, follow these steps.

1. Start Practice CS.

2. In the login dialog, select Sample in the Open Firm field.

3. In the Staff ID field, select CAT.

Note: If you previously marked the Remember login information checkbox, hold down the SHIFT key when you double-click the Practice CS icon and continue to hold down the SHIFT key until the login dialog appears.
4. Click OK.

Back up the sample database

Data that you enter while performing the exercises in this walkthrough will affect the Sample database. Therefore, we recommend that you make a backup of the Sample database before you begin so that it is available for use in other Practice CS walkthroughs.

**Note:** If you are running Practice CS through the Virtual Office CS™ module, the Backup menu command is not available. We recommend that you install a local copy of Practice CS so that you can back up the Sample database. For instructions on installing the application, please see chapter 2, Installation Instructions, in the *Practice CS Getting Started* guide.

To back up the Sample database, follow these steps.

1. In Practice CS, choose File > Backup.
2. In the *Backup File* field, enter the path and file name for the backup, or click the browse button and navigate to the backup file location. The backup file will have a file extension of BDF.

![Backup File](image)

*Note:* The backup file will be created on the computer where the data resides. The path specified here must be a valid path on that computer.

3. Click OK.

4. When prompted that the backup is complete, click OK.

*Note:* After you complete this walkthrough, you can restore the sample database. For instructions, see “Restoring the sample database” on page 63.
Walkthrough Exercises

Practice CS offers a wide variety of billing methods to bill for your firm’s services, and provides custom formatting options for producing professional invoices and statements. The following exercises will illustrate how to use the available billing methods and how to work with invoice formats in Practice CS.

User preferences for billing

Practice CS user preferences (Setup > User Preferences) allow you to customize certain areas of the application so that you can perform your work more easily and efficiently. User preferences are available for Time & Expense Entry, Billing, Receipt & Adjustment Entry, and for the overall application (System). User preferences are specific to each staff member.

Use the Billing tab to select whether to bill by client or by engagement, whether to display work-in-process (WIP) during billing, and to specify rounding methods for billing. You can also choose a default invoice date, and which tab of the Billing screen you would like to see at startup. You can change these settings at any time.

Setting up user preferences for billing

In this exercise, you will explore the various user preferences available for billing in Practice CS.

1. Choose Setup > User Preferences, and then click the Billing tab.

2. The date you choose in the Default invoice date field will be the invoice date for each client displayed in Detail Billing. You can choose Today's date, Period end date, or Last date used. For this walkthrough, choose Period end date.

3. In the Default Wip through field, select Invoice date. This date serves as a WIP cut-off date. Only WIP dated on or before this date will be available for billing.

   Note: If the WIP through date falls after the invoice date, the invoice date serves as the WIP cut-off date.

4. Verify that the Implied decimal on amounts checkbox is marked. When this checkbox is marked, the application enters .00 after amounts that you enter.
When it is not marked, the application inserts a decimal two places to the left of the number that you enter.

5. **Mark zero invoices as printed:** For this walkthrough, clear this checkbox. Marking this checkbox toggles the Printed column in the Print Invoices & Statements screen to “Yes” for invoices with zero bill amounts, enabling you to exclude them from your selection when printing invoices.

6. In the **Bill by** field, select Engagements from the drop-down list. Your selection here determines whether the Billing screen contains client engagements or clients only.

**Note:** If your firm is licensed for the Practice CS Project Management module, you can also choose to bill by project.

7. Verify that the **Show WIP when selecting clients to bill** checkbox is marked. When this checkbox is marked, the Billing screen includes a column showing the WIP balances available for billing.

8. Use the **Start-up tab** field to select the tab you would like to be active whenever you open Detail Billing, either Summary or Time & Expenses. Verify that Summary is selected from the drop-down list.

9. You can choose to round your billing amounts when billing at standard. Select the **Standard rounding** option.

10. When you choose to round billing amounts, you must enter a rounding increment. The default increment is 1 dollar. For this exercise, leave the default.

11. Review all other settings to make sure they match the illustration.

12. Click **OK** to save your preferences and close the dialog.
Other billing preferences

Automatically apply open credits — If you mark this checkbox, the application automatically applies open credit amounts (receipts, credit memos, or write-offs) to a client's invoice when you save the invoice. For this walkthrough, do not mark the checkbox.

Automatically display Apply Open Credits dialog — When this checkbox is marked, the Apply Open Credits dialog opens automatically when you save an invoice for a client with open credits. In this dialog, you can either manually enter the amounts to apply, or have the application auto apply the credits.

Automatically select subsidiary Clients when selecting parent Clients — When this checkbox is marked, subsidiary clients (that is, clients that have a parent client selected in Setup > Clients > Billing and A/R tab) will be automatically selected when you select the parent client in billing.

Time & Expense Descriptions — You can mark checkboxes for each item that you want to include in billing grids. For this walkthrough, verify that the Comment and Biller Note checkboxes are marked.

Firm preferences for billing

In addition to user preferences, your firm may wish to establish some firm-wide setup decisions for billing, approving and posting, security, and so on. Your firm's administrator, or another staff member with security permission to make firm-wide settings in the application, can enable the approval and posting process for billing.

Enabling the approval process for billing

1. Choose Setup > Firm, and then click the Preferences tab.
2. Under Approval/Posting process, verify that the Required for Billing checkbox is marked. When this checkbox is marked, a staff member with the authority to review invoices must approve an invoice on review before it can be posted.

![Image of Practice CS interface showing Approval/Posting settings]

3. If necessary, click Enter to save your changes.

You can also enable the approval process for Time & Expense Entry and for Receipt & Adjustment Entry. For this walkthrough, do not mark these checkboxes.

**Other firm billing preferences**

If you want Practice CS to accept data via integration with other CS Professional Suite applications, mark the Integrate this Firm with other solutions checkbox.

*Note:* This checkbox can only be marked for one firm database at a time.

For this walkthrough, do not mark the checkbox.
Using the Billing Worksheet

If your firm prefers to make billing decisions on paper, you can print the Billing Worksheet to assist you.

1. Choose File > Print Reports.

   **Note:** You can also click the Firm button in the navigation pane, then click the Print Reports action icon.

2. Highlight the Billing Worksheet report, and then click the Select button.

   **Note:** You can also double-click a report to select it.

3. In the Selection tab of the Report Options section, you can specify the report date (Today’s Date, Period End Date, Prior Period End Date, or Custom). Verify that Period End Date is selected in the **Report date** field.

4. Click the Layout tab.

   Use the Layout tab to sort and group the data on the report. Here you can select a level of detail for the report and choose an item to sort by. You can also choose up to three levels of grouping for this report. Each grouping level on the printed report will have a header and a footer, with the footer containing subtotals.
5. Verify that the following settings are selected.
   - *Group Clients by*: Client Office
   - *Group Detail by*: Engagement

6. Click the Preview Selected button.
7. To exit the preview, click the Back button on the toolbar.

Notes

- You can also print the Billing Worksheet directly from the Billing screen. Mark the checkbox for each client or engagement you want to select, right-click, and choose Preview Billing Worksheet for Selected from the context menu.

- You can select any custom report that is based on the Billing Worksheet report by choosing Preview Billing Worksheet For Selected > Select Report. You can also set report options for the selected report.
Using the Billing screen

With Practice CS you can bill your clients on screen, using a variety of billing methods to accommodate your firm’s arrangements with individual clients. You can bill using as much or as little detail as you need.

In the Billing screen you can bill by clients or engagements, review and approve invoices (if your firm uses an approval process), and generate recurring bills.

*Note:* If you are licensed for UltraTax CS,® you can also use the Billing screen to accept or reject invoices forwarded from UltraTax CS. See the topic *Working with integrated invoices* in the Help & How-To Center for more information.

Selecting the WIP to bill

Before you begin billing, you must select the clients or engagements that you want to bill. Use the Bill Engagements tab of the Billing screen to make your selections.

*Note:* The default name for this tab is Bill Engagements. The name of the tab changes depending on whether you have set your user preferences to bill by engagements or by clients. If you are licensed for the Practice CS Project Management module, you can also choose to bill by project.

1. Open the Billing screen (Actions > Billing).

   *Tip:* You can also open the Billing screen by clicking the Clients button in the navigation pane and then clicking the Billing action icon, or by pressing CTRL+B.

2. Mark the *Positive Wip* checkbox to display only clients or engagements with a positive WIP balance.
Notes

- If you want to further narrow down the list of clients or engagements, click the show filter button at the top of the screen and select an item (for example, Client ID) from the Filter field to filter the screen by that item. See the topic Filtering your data in the Help & How-To Center for more information about creating and using filters.

- To improve performance in Practice CS wherever large lists of items are displayed, results are limited to a pre-determined maximum size. When a drop-down list displays results that are limited, the message “Results limited” appears at the end of the list.

   ![Results Limited]

   Get More Items

   If the data you are looking for is not included in the limited results, refine your sort order, search criteria, and/or filter to narrow down the data displayed in the list. To display more items in the drop-down list, click the Get More Items button.

3. When you are satisfied with the client list, mark the checkbox for each client or engagement that you want to bill. For this exercise, select the following clients and engagements.

<table>
<thead>
<tr>
<th>Client</th>
<th>Engagement</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACEADVERT</td>
<td>CONSULTING</td>
</tr>
<tr>
<td>Ace Advertising</td>
<td></td>
</tr>
<tr>
<td>BINGS</td>
<td>INDIVTAX</td>
</tr>
<tr>
<td>Sally Bing</td>
<td></td>
</tr>
<tr>
<td>CRAWFORD</td>
<td>PAYROLL</td>
</tr>
<tr>
<td>Crawford Steak House</td>
<td></td>
</tr>
</tbody>
</table>

Notes

- To quickly select multiple clients, click the Select All button at the top of the screen, or right-click the list and choose Select All from the context menu. You can also press ALT+A or CTRL+A on your keyboard to select all.

- To deselect all, click the Deselect All button, or right-click and choose Deselect All from the context menu. You can also press ALT+E on your keyboard.
4. The Billing Selection pane displays the client engagements you selected for billing. When this list is unsorted, the engagements appear in the list in the order in which they were selected. When you open the engagements to bill them, they will open in the order in which they are listed.

- Click the Auto Hide button when you want to hide the pane.

- Click the Auto Hide button again to “pin” the pane so that it stays on screen.

5. For this walkthrough, click the Auto Hide button to hide the Billing Selection pane.

6. Click the Deselect All button.

After you have selected the clients or engagements you want to bill, you can choose the billing method (Standard Bill, Quick Bill, Zero Bill, or Detail Bill) to use.

**Standard Bill**

The Standard Bill method is useful if you want to quickly bill a client for their full WIP balance without making any adjustments. However, because we selected standard rounding in as a user preference for billing, there may be small adjustments on WIP due to rounding.

*Note:* To use Standard Bill, you must have an invoice format set up for the selected client. To set up a client’s invoice format, choose Setup > Clients, click the Billing and A/R tab, and select the appropriate format in the Default invoice format field. For this walkthrough, invoice formats have already been set up for the sample clients.
1. Mark the checkbox for client HANNA, engagement INDIVTAX.

2. Click the Standard Bill Selected button.

3. Click Yes to continue.

After you bill a client with Standard Bill, the client's invoice will be listed on the Review tab of the Billing screen.

Quick Bill

Another fast method for billing clients without the level of detail involved in Detail Billing is Quick Bill. With Quick Bill, you can bill multiple clients on a single screen.

1. In the Bill Engagements tab, select the BUSINESSTAX engagement for client Alpha Promotions.

2. Click the Quick Bill Selected button.

3. In the *Generate using invoice date* field, use the period end date (4/30/2014) as the invoice date for this exercise.
4. In the *Billed* field, enter **3000.00**.

**Notes**

- You can enter an amount in either the *Billed* or the *Adjusted* field, and the application will complete the other field for you.

- If the bill amount is less than the WIP amount and the adjusted amount is set to 0.00, the remaining amount will appear in the *Carryover* field. This remaining amount will be available the next time you bill the client.

5. If you need to bill individual WIP items, you can click the expand button to view and work with the WIP detail for the selected client engagement. For this exercise, do not change the WIP detail.

6. When you are finished entering the billing amounts, click the Generate Invoices button.

After you bill a client with Quick Bill, the client’s invoice will be listed on the Review tab of the Billing screen.
Zero Bill

Use Zero Bill to bill the selected clients’ engagements at zero, allowing you to immediately write off all WIP for the engagement.

**Note:** Just as with Standard Bill, the selected client must have an invoice format set up.

1. Mark the checkbox for the PAYROLL engagement for client CRAWFORD.

2. Click the Zero Bill Selected button.

3. To zero bill the selected clients, you would click Yes. For this walkthrough, however, click No, then click the Deselect All button on the Billing screen.
Detail billing

For engagements that require greater control over the billing amounts or invoice presentation, use Detail Billing. The Detail Billing screen offers a variety of ways to bill at any level of detail you might need. In Detail Billing, you can:

- standard bill, partial bill, progress bill, or “smart bill”
- add or delete adjustment entries
- bill and edit individual WIP items
- relieve WIP for nonbillable items
- select invoice formats and due dates
- compose your invoice and preview it on screen
- allocate adjustments to a different staff member

**Note:** Before you begin, you should set up your user preferences for billing, such as default due date, rounding methods, and so on. See “Setting up user preferences for billing” on page 5 for more information.

Overview of the Summary tab

- To access the Summary tab, select an engagement in the Billing screen and click the Detail Bill Selected button. For this walkthrough, select the CONSULTING engagement for client ALPHA.
Use the Summary tab to specify invoice information, bill amounts, due dates, and adjustments. You can also use this tab to enter progress bills (which are discussed beginning on page 28).

The Billing Selection list on the left side of the screen shows all of the clients / engagements that you have selected for billing.

**Tips**

- Click the Edit Selection List button at the bottom of the list if you need to add or remove clients / engagements from your selection list during billing.
- Click the Dashboard link at the bottom of the screen to open the current client's dashboard, where you can view the client's billing and A/R totals and other client information.

The following fields provide information about the invoice.

- **Number** — Practice CS automatically assigns the next highest available invoice number in this field, but you can enter a different number, if necessary. The application will verify that the number you enter has not already been used.
- **Date** — The Date field shows the invoice date. You can change this date, if necessary.
- **Reference** — If you have marked the *Enable default invoice reference number* checkbox in the Billing and A/R tab of the Firm setup screen, this field displays a reference number generated by Practice CS. The reference number uses a combination of invoice-related fields that you specify when you set it up.
- **Due Date** — The Due Date is calculated based on your firm’s billing and A/R default settings. You can change this date, if necessary.
- **Format** — This field shows the default invoice format assigned to the client in the Clients setup screen. You can choose a different one, if necessary.
- **Office** — This field shows the office to which the invoice has been assigned.
- **Billing Instructions** — Displays instructions that were entered on the Billing and A/R tab of the Clients setup screen.
- **Invoice Notes** — Use this field to enter any notes about the invoice.

**Entering billing information in the Summary tab**

In this exercise you will bill client ALPHA for the full WIP amount and then save the invoice.

1. With the CONSULTING engagement for client ALPHA still open in the Detail Billing screen, enter **7350.00** in the Billed column of the *Time* row.
2. Press the TAB key.

3. You can use the **Format** field to select a different invoice format. Choose **Engagement Invoice Format**.

4. For this exercise, do not enter an amount in the Adjusted column (leave 0.00 entered).

5. Click the Save button.

*Note:* When you save an invoice, the Detail Billing screen opens the next selected client. If no other clients are selected, clicking the Save button returns you to the Billing screen.
6. In the Billing screen, click the Review tab. The invoice that you saved for client ALPHA’s CONSULTING engagement now appears in the list of invoices.

Overview of the Time & Expense Entry tab
The Time & Expense tab of the Detail Billing screen shows the WIP detail for the selected client or client’s engagement. You can bill at the level of individual WIP transactions, or you can summarize the transactions for billing by marking any of the Summarize By checkboxes. If you right-click the list, you can use the context menu to choose how to bill the selected entries, unbill entries, print the list of time entry transactions, and edit the transactions directly from this screen.

To best demonstrate this tab, let's first create a new time entry for client QBL.

1. Choose Actions > Time & Expense Entry.
2. In the Sheet date field, choose 4/4/2014.
3. Enter the following item:

<table>
<thead>
<tr>
<th>Client</th>
<th>Engagement</th>
<th>Activity</th>
<th>Hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>QBL</td>
<td>CONSULTING</td>
<td>FIELDWORK</td>
<td>3.25</td>
</tr>
</tbody>
</table>

Now let’s return to the Billing screen and bill engagements for client QBL.

1. Choose Actions > Billing, and then click the Bill Engagements tab.
2. Verify that the Positive Wip checkbox is marked.
4. Click the Detail Bill Selected button.
5. In the Detail Billing screen, click the Time & Expense tab.
6. Mark the *Engagement* checkbox to summarize the time and expense entries by engagement.

7. Click the button for the BUSINESSTAX engagement to expand the row, and note the transaction detail shown.

![Image of Time & Expense tab]

**Note:** The Time & Expense tab also shows links and custom fields from the Time & Expense Entry screen. For more information on links and custom fields, see the following topics in the Help & How-To Center:

- Adding links
- Adding custom field information in Time & Expense Entry

**Editing a transaction in the Time & Expense tab**

In the Time & Expense tab, you can edit a WIP transaction directly from the Detail Billing screen.

1. Clear the *Engagement* checkbox so that the time and expense entries are not summarized.

3. Right-click the transaction and choose Edit Selected Entries from the context menu.

4. The Time & Expense Entry screen opens, where you can edit the information as needed.

5. Change the hours from 3.25 to **2.75**.

6. Click the Back button on the toolbar to return to the Detail Billing screen.
7. In the Detail Billing screen, note the changes in the *Hours* and *WIP Amt* fields for the 4/4/2014 entry.

**Smart Bill**

Smart Bill allows you to distribute bill amounts and adjustments among the selected transactions in Detail Billing. To use Smart Bill, follow these steps.

1. In the Time & Expense tab, mark the checkboxes for all of the BUSINESSSTAX engagements (leave the CONSULTING engagement unmarked).

2. Right-click again and choose Smart Bill Selected.
3. In the Smart Bill dialog, the *Selected Amount* field shows the total amount of the selected transactions.

4. The amount in the *Billed* field is equal to the *Selected Amount*. You can enter a different amount in the *Billed* field, if necessary, to make an adjustment. For this exercise, enter $3,150.00.

5. Press ENTER. The *Adjusted* field shows the difference between the *Selected Amount* and *Billed* fields.

6. Click OK to complete the Smart Bill.

7. Note how the adjusted amount is distributed among the individual WIP transactions.

8. Click the Save button.
Allocating an adjustment to a different staff member

If necessary, you can allocate an adjustment to a staff member other than the one who originally made the entries. Suppose that you would like to allocate the adjustment of $12.50 in the previous exercise from staff member JPW to staff member MHR.

1. In the Billing screen, click the Review tab.
2. Mark the checkbox for client QBL, invoice total 3,150.00.
3. Right-click and choose Open Selected from the context menu.
4. In the Detail Billing screen, click the Time & Expense tab.
5. Mark the checkbox for the ASSIGNBUD activity transaction with staff member JPW.
6. Right-click and choose Allocate Adjustment to a Different Staff from the context menu.
7. In the Allocate Adjustment to a Different Staff dialog, select MHR from the drop-down list.
8. Click OK.
9. Note that the adjustment of $12.50 has been reallocated from staff member JPW to staff member MHR.

10. Click the Save button.

**Adding an adjustment entry**

If you need to make an adjustment entry during Detail Billing, you can do so by right-clicking and choosing Add Adjustment Entry from the context menu. Adjustment entries allow you to create an entry in Detail Billing without going through Time & Expense Entry.

1. In the Billing screen, click the Bill Engagements tab.
2. Select the INDIVTAX engagement for client BINGS, Sally Bing.
3. Click the Detail Bill Selected button.
4. In the Detail Billing screen, click the Time & Expense tab.
5. Right-click and choose Add Adjustment Entry from the context menu.
6. In the Adjustment Entries dialog, enter the following information.

<table>
<thead>
<tr>
<th>Client</th>
<th>Engagement</th>
<th>Activity</th>
<th>Staff</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>BINGTA</td>
<td>INDIVTAX</td>
<td>CLIENTMEET</td>
<td>JPW</td>
<td>92.50</td>
</tr>
</tbody>
</table>

*Note:* If you are licensed for the Project Management add-on module, the Adjustment Entries dialog will have an additional Project column.

7. Click OK. Note the adjustment entry in the Time & Expense Entry tab.

8. Click the Save button.
Progress billing

Progress billing is a billing method that allows you to generate a bill for a client without relieving any WIP. There are several reasons you might want to use a progress bill:

- To bill a client before staff time entry has been performed
- To bill a client up front for work that is yet to be performed
- To bill a client for an engagement that is to last more than one billing cycle

**Note:** Your firm may want to set up a designated activity to track progress bills. Practice CS does not require that you create a separate activity for entering progress bills, but you may find that creating one makes it easier to track progress bills.

Creating a progress bill – Summary tab

1. In the Billing screen, select the CONSULTING engagement for client QBL (Collins, Brown & Lewis Adv).
2. Click the Detail Bill Selected button.
3. In the Detail Billing screen, click the Progress button.
4. Enter the following data in the Progress Bill dialog.

<table>
<thead>
<tr>
<th>Engagement</th>
<th>Activity</th>
<th>Staff</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONSULTING</td>
<td>PROGRESS</td>
<td>CAT</td>
<td>1,000.00</td>
</tr>
</tbody>
</table>

5. Click OK.

6. Notice the $1,000 Billed amount and the -$1000.00 Carryover.

7. In the Format field, select Engagement Invoice Format.

8. Click the Preview tab to preview the invoice.
9. Click Save to save the invoice and return to the Billing screen.

10. Click the Review tab.

11. Right-click the grid and choose Deselect All.

12. Select the $1,000 invoice for client QBL.
13. Click the Post Selected button to post the invoice to accounts receivable.

Clearing a progress bill
After you have created a progress bill, you will eventually need to relieve the progress bill and associate it with time and expense entries. To clear a progress bill, follow these steps.

1. Click the Bill Engagements tab.
2. Clear the Positive Wip checkbox.
3. Select the CONSULTING engagement for client QBL.
4. Click the Detail Bill Selected button.
5. Click the Time & Expense tab. Notice that all staff time has been entered, and you can see the $1,000 progress bill.
6. To clear all WIP, enter **0.00** in the *Billed* field at the bottom of the screen and press ENTER. Notice the reversal of the progress bill and allocation of billing to the WIP amounts.

![Image of detailed billing screen]

7. Click the Save button.

**Note:** You can also use this procedure to clear progress billings if there is no WIP, and to bill additional amounts instead of zero.

---

**Creating a progress bill – Time & Expense tab**

You can also create progress bills if you are using the Time & Expense tab for detail billing.

1. In the Billing screen, click the Bill Engagements tab.
2. Mark the *Positive Wip* checkbox.
3. Select client BINGS (Bing, Sally), engagement INDIVTAX.
4. Click the Detail Bill Selected button.
5. In the Detail Billing screen, click the Time & Expense tab.
6. Right-click and choose Add Progress Entry from the context menu.

7. Enter the information as shown below.

8. Click OK.
9. The progress entry appears as a new item in the grid.

![Image of Detail Billing screen showing progress entry]

10. Click the Save button.

**Relieving nonbillable time and expenses**

Use the Nonbillable tab of the Detail Billing screen to track time spent on nonbillable activities and relieve WIP for nonbillable items such as firm administrative activities and holidays.

1. Choose Actions > Billing.
2. Clear the Positive WIP and Negative WIP checkboxes.
3. Select the AUDIT engagement for client AAC.
4. Click the Detail Bill Selected button.
5. In the Detail Billing screen, click the Nonbillable tab.
6. Mark the Relieved checkbox.

7. Click the Save button to relieve the WIP.

Composing an invoice

Use the Compose tab of the Detail Billing screen to make changes to the appearance of the invoice that you send to your client. You can view the invoice detail as it would appear on the invoice, change text formatting and alignment, add and remove rows of text, and rearrange blocks of text in the invoice as needed.

You can also edits amounts in the Compose tab, if:

- The sum of the edited amounts equals their subtotal, and
- The sum of subtotals equals the total billed amount in the Summary tab of the Detail Billing screen.

1. In the Billing screen, click the Review tab.
2. Select invoice #349 for client ALPHA.
3. Right-click and choose Open Selected from the context menu.

4. In the Format field, choose Entry Detail by Engagement.

5. Click the Compose tab.

6. Click the Spell Check button.

7. When the spell check is complete, click OK.
8. Click the Add Free Form Text Row button on the toolbar.

   Tip: Hold the cursor over a button on the toolbar for a tool tip.

9. With the free form text row selected, click the Insert Standard Text button on the toolbar.

10. In the Standard Text dialog, select CONSULTING, and then click OK.

11. In the Define Text Prompt dialog, enter **Federal tax return** in the Text field, and click OK.

12. Select all the text in the bottom row, and click the Italic button in the toolbar.
Previewing an invoice

In Practice CS you can preview your invoices as they will appear to your client, before printing. You can use either the Preview tab of the Detail Billing screen or the Review tab in the Billing screen.

1. With the invoice for client ALPHA still open in Detail Billing, click the Preview tab.

2. After you review the appearance of your invoice, click the Save button to return to the Billing screen.

Approving and posting an invoice

If your firm has selected the approval process for billing, each invoice must be approved before it can be posted. Use the Review tab of the Billing screen to approve and post invoices.

**Note:** Even if your firm does not require an approval process, you can use the Review tab to access invoices after they have been created in case you need to make further changes.
To approve and post an invoice, follow these steps.

1. In the Billing screen, click the Review tab. 

2. Verify that the Unapproved only checkbox is marked and the Unposted only checkbox is not marked.

3. Right-click and choose Deselect All.

4. Mark the checkbox for the invoice for client HANNA (Hanna, Jason).

5. Click the Preview Selected button to preview the invoice on screen. When you are satisfied with the invoice, click the Back button on the toolbar.

6. Click the Approve Selected button to approve the invoice.

*Note:* The Approve Selected and Post Selected buttons are available only if your firm is using the approval process.

7. Clear the Unapproved only checkbox.
8. Note that the Approved by column shows the initials (CAT) of the staff member who approved the invoice.

9. Select the HANNA invoice again and click the Post Selected button to post it.

10. Clear the checkbox to deselect it.

**Note:** To unapprove or unpost an invoice, select the invoice, right-click and choose Unapprove Selected or Unpost Selected from the context menu.

**Editing invoices**

When necessary, you can change the date, due date, notes, office, or reference number on one invoice or multiple invoices at once. To edit a single invoice, you open it as we have done in previous exercises. To edit multiple invoices, follow these steps.

1. In the Review tab, mark the *Unapproved only* and *Unposted only* checkboxes.

2. Select invoices 349 and 350 for client ALPHA.

3. Right-click and choose Edit Selected from the context menu.

4. In the Edit Selected Invoice dialog, select Due Date from the first drop-down list. This is the data we will update.
5. From the second drop-down list, select 5/31/2014 as the new due date.

6. Click OK.

7. At the prompt, click Yes to continue.

8. Note that the due date on these two invoices is now 5/31/2014.

9. Clear the checkboxes for invoices 349 and 350.

Unbilling an invoice

If you need to delete an invoice after you have saved it, you can do so using the Review tab.

**Note:** If your firm is using the approval process, you must unapprove an invoice before you can edit or delete it. To unapprove or unpost an invoice, select the invoice, right-click and choose Unapprove Selected or Unpost Selected from the context menu.

1. In the Billing screen, click the Review tab.

2. If necessary, unmark the *Unapproved only* and *Unposted only* checkboxes.

3. Select invoice 345 for client ACEADVERT (Ace Advertising).
4. Right-click and choose Unapprove Selected from the context menu.

**Note:** Unapproving both unapproves and unposts the invoice.

5. Right-click again and choose Delete Selected from the context menu.

6. When prompted, click Yes to confirm.

7. Click the Bill Engagements tab. Note that after you unbill an invoice, the WIP is available for billing again.
Viewing the Journal
Click the Review tab, and then click the Journal button to view the Invoice Journal report showing all invoices currently on the Review tab. This report provides a list of the invoices on review and their components (invoice number, date, amount, surcharges, taxes, and so on).

Note: You can click the down arrow on the Journal button and select any custom report that is based on the Invoice Journal report. You can also set options for the selected report.

Recurring bills
With Practice CS, your firm can quickly generate invoices for engagements that are billed on a recurring basis. Before you can generate recurring bills, you need to perform a couple of setup steps:

1. Create a recurring bill description that describes how often the billing occurs (for example, monthly or quarterly)

2. Add or edit the client engagement that will have the recurring bill. You will set up recurring bill information on the Recurring Bills tab for the applicable engagement.

After you have created the recurring bill description and added it to the client’s engagement, use the Generate Recurring Bills tab of the Billing screen to generate the invoice.
Creating a recurring bill description

1. From the Setup menu, choose Recurring Bill Descriptions.
2. Click the Add button.
3. In the Description field, enter **Bi-weekly payroll** to describe the type of recurring bill.
4. Click Enter to save the description.

Setting up a recurring bill for the client’s engagement

Next, add a new engagement or edit the existing engagement that will have the recurring bill.

1. Choose Setup > Clients.
2. In the Clients screen, double-click client BROWNJ (Brown, Jerald & Elizabeth).
3. Click the Engagements tab.
4. Select the PAYROLL engagement from the Engagements list.
5. Click the Recurring Bills subtab.
6. In the Description field, select Bi-weekly payroll from the drop-down list.
7. In the Method field, select Progress from the drop-down list.

*Note:* For a detailed description of each of the available recurring bill methods, see the topic **Setting up engagements for a client** in the Practice CS help.

8. In the Amount field, enter **100.00**.
9. In the Staff field, select CAT from the drop-down list.
10. In the Activity field, select PROGRESS (Progress Billing) from the drop-down list.

11. Click Enter to save your changes.

Generating a recurring bill

To generate a recurring bill using the engagement you have set up, follow these steps.

1. Open the Billing screen (Actions > Billing).
2. Click the Generate Recurring Bills tab.
3. The Generate using invoice date field shows the date that will be used as the invoice date. For this exercise, use the current period end date (4/30/2014).
4. Mark the checkbox to select engagement Payroll Services for client BROWNJ.

5. Click the Generate Selected button.

6. At the confirmation, click OK.

The generated invoice is now available in the Review tab.

---

Previewsing and printing invoices

From the Review tab of the Billing screen, you can preview and print invoices that have been placed on review.

**Notes**

- If you are using the approval process, mark the checkbox for the invoices you want to post and then click the Post Selected button. If you are not using the approval process, invoices are posted as soon as you save them.
- Even if your firm does not require an approval process, you can use the Review tab to access invoices after they have been saved in case you need to make further changes.
Previewing an invoice

1. In the Billing screen, click the Review tab.

2. If necessary, unmark the *Unapproved only* and *Unposted only* checkboxes to display all invoices.

3. Select invoice 348 for client HANNA (Hanna, Jason).

4. Click the Preview Selected button.

**Note:** The Preview Invoices screen’s toolbar allows you to navigate through multiple-page invoices, find text within the invoice, toggle between single- and multiple-page view, and zoom in or out. For a brief description of each toolbar button, hold your cursor over the button for a tool tip.

5. Click the Back button on the toolbar to exit the preview.
Printing an invoice

To print an invoice, follow these steps.

1. With invoice 348 for client HANNA still selected, click the Print Selected button.

   In the Print dialog, you can choose to print the invoice to one or more of the following outputs:

   - **Printer**: Sends the invoice to the default printer for your workstation. To print to another printer, select it from the drop-down list.

   **Note**: When **Output to printer** is selected, you also have the option to print labels for the selected invoices. For more information, please see the topic **Printing labels and letters** in the Help & How-To Center.

   - **FileCabinet CS**: If you are licensed for FileCabinet CS, mark this checkbox to send the invoice to FileCabinet CS when you print. If the client for which you are printing does not yet have a drawer set up in FileCabinet CS, Practice CS will create one with the same name as the client’s Practice CS client ID.

     If you want to create a link to the printed invoice in FileCabinet CS, mark the **Create Invoice Link to FileCabinet CS Document** checkbox.

   - **File**: Allows you to print to a file (*.pdf, *.html, *.rtf, *.txt, *.tif, or *.xls). The file is saved in the folder that you specify in the field provided.

     If you want to create a link to the output file, mark the **Create Invoice Link to File** checkbox.
• **E-mail:** Allows you to print the invoice as a specific file type and then email it to the client. The message will be sent to the email address for the Billing Contact listed on the Contact Info tab of the Clients setup screen. The subject line of the email will be "[Invoice] from [name of your firm]." The message will include the invoice as an attachment, along with the text "Please find [invoice] #[number] from [name of firm] attached to this email."

2. For this exercise, mark the Output to printer checkbox.

3. If necessary, select a printer from the drop-down list, or use your default printer.

4. If marked, clear the Output to file checkbox.

5. Click OK to print the invoice.

*Note:* You can also print invoices by choosing File > Print Invoices & Statements.

---

**Printing an invoice to NetClient CS**

If you are licensed for NetClient CS, you can enable clients who have a NetClient CS account to pay their invoices online.

*Note:* NetClient CS allows you to create personalized, secure web space — a portal — for each of your contacts. Your contacts access their customized portals through your website using unique logins and passwords, so security is preserved at all times. You and your contacts can use NetClient CS portals in a variety of ways, including exchanging documents, gathering financial data, and accessing software.

To make an invoice available online for a contact, you need to perform some firm and client setup steps. The following example walks you through these steps.

2. Mark the Enable printing invoices to NetClient CS checkbox.

**Note:** You must also have a CS Payment account configured. To configure CS Payment, click the link and log in using your NetStaff CS® login and password, or you can create a new account if you do not have one.

3. Choose Setup > Clients.

4. In the Clients screen, double-click the client you want to enable to pay online invoices.

5. Click the Contact Info tab and choose the contact whom you would like to receive the invoice.

6. In the Portal field, select the client’s NetClient CS account from the drop-down list.
7. Click the Actions button, and select **Enable NetClient CS Invoices for <name of client>** from the drop-down list.

8. Click Enter to save your changes.

To make the invoice available in the client’s portal, print the invoice and send the output to NetClient CS.

1. Select the invoice that you want to print to NetClient CS.

2. Click the Print Selected button.
3. In the Print dialog, mark the Output to NetClient CS checkbox.

![Print dialog with Output to NetClient CS checkbox highlighted]

4. Click OK. If you are prompted to post the invoice, click Yes.

An icon in the NetClient CS column indicates that the invoice has been printed.

![NetClient CS invoice status icon]

5. After you have printed the invoice to the NetClient CS portal, the client receives an email message with the subject line A new invoice has been made available.
6. The client logs in to NetClient CS and clicks the **My Invoices** link to access the invoice.

7. The client selects the open invoice, clicks the Pay Selected button, and enters their credit card information to pay the invoice.

8. After the client submits the payment, your NetFirm CS™ administrator will receive an email message with the subject line *Receipt of payment* to let you know that the client has paid the invoice. Use the Receipt & Adjustment Entry screen (Actions > Receipt & Adjustment Entry > Integrated Receipts tab) to accept the receipt.
Custom invoice formats

Practice CS comes with default invoice formats that may suit your firm's needs. In addition to the default formats, you can create your own custom formats tailored specifically to your firm. To create a new custom format, first open the Custom Formats setup screen by choosing Setup > Custom Formats.

Creating a custom format begins with the Format Wizard, where you can specify which information to include or omit on the invoice. After you complete the Format Wizard, you can make further changes to the layout of the invoice using the designer screen.

Setting up a custom invoice format using the Format Wizard

To create a custom invoice format, use the Format Wizard to select information that will appear on your custom invoices.

1. Choose Setup > Custom Formats to open the Custom Formats setup screen.
2. Right-click in the Custom Formats list and choose Add Invoice from the context menu.

![Custom Formats Menu]

**Notes**

- You can base a new custom format on an existing one. To do this, right-click a custom format in the list and choose Copy Format from the context menu. A new custom format is added to the list with the name “Copy of <Name of format you copied>.” You can change the name of the new format by right-clicking it, choosing Edit from the context menu, and then clicking the Format Wizard button in the toolbar.

- To delete a custom format, right-click it in the formats list and choose Delete from the context menu. If the format has been selected for use with statements or invoices, you will not be able to delete it.

- Additional formats can be found in the Practice CS Library portlet, which is available on any dashboard. These formats were created by the Practice CS Development or Support teams, and in some cases by other users of Practice CS. You can preview these formats, and import any of them for use by your firm.
3. In the Main tab, enter **Sample format** to identify the custom format you will create in this exercise.

4. Click Next.

5. In the Heading Information tab, select information to print in the header of the invoice. The information you select in this tab prints only at the top of the first page.

- **Firm Information**: In this section, mark checkboxes for firm information you want to add to the header. This data is drawn from the home office information in the Office setup screen. If you want to add your firm's logo to the invoice, mark the *Logo* checkbox, navigate to the logo graphic file, and click Open. By default, the logo will be added to the left of the firm information in the header and resized to fit a default size determined by the application. You can change the default placement and sizing later on the designer screen.
Walkthrough Exercises

- **Client Information:** In this section, mark checkboxes for client information you want to add to the header. This data is drawn from the Clients setup screen.

- **Invoice Information:** In this section, mark checkboxes for the information you want included in the header. Mark the *Lead In Text* checkbox to add the text “For professional service rendered as follows” at the bottom of the header.

6. Click Next.

7. In the Billing Information tab, select how you would like billing information represented on client invoices. You can group billing information according to certain criteria, and include specific field details from the billed entries to provide additional detail on the invoices.

- **Grouping Options:** You can specify up to four groupings to summarize time and expense billing information, and for each grouping you can choose to show hours/units and/or billed amounts.

- **Entry Detail Fields:** You can include specific fields for individual WIP transactions on the invoice if you want to provide your clients with additional details. Select a field in the Available pane on the left and click the button to move the field to the Selected pane on the right. Field information will appear below grouped time and billing information on the invoice.

8. Click Next.
9. The A/R Information tab enables you to include different types of accounts receivable information in the statement or invoice.

- Mark the **A/R Recap** checkbox to include a recap of the client's A/R activity.
- Mark the **A/R Ledger** checkbox to include more detailed information about the activity related to the accounts receivable balance.
- Mark the **A/R Aging** checkbox to add a five-period aging section to the invoice.
- Mark the **Dunning Messages** checkbox to include the dunning messages from the Billing and A/R tab of the Firm setup screen.

*Include A/R information through:* Select Invoice Date from the drop-down list.

10. Click Next.
11. The Pay Stub Information tab enables you to include a pay stub at the bottom of the last page of the invoice, and to choose the information that is included on the stub.

- Mark the **Include a pay stub** checkbox to add a pay stub to the custom format. Practice CS will automatically create a dashed divider line and the label "Please return this portion with payment" at the top of the pay stub.

- **Pay Stub Information**: In this section, mark the checkbox for each item you want to include on the pay stub. Client information is drawn from the Clients setup screen and will include the phone number designated as primary. If you mark the A/R Terms checkbox, Practice CS will add the text from the A/R Terms field in the Billing and A/R tab of the Firm setup screen.

12. Click the Finish button to complete the custom invoice format.
Customizing invoice and statement formats

When you click the Finish button in the Format Wizard, Practice CS closes the wizard and opens the designer on the Custom Formats setup screen. You can use the designer to customize the layout of your custom invoice format. You can also use the designer to customize existing formats.

When the designer screen is open, there is an additional Page Setup command available (File > Page Setup), which opens the Report Settings dialog. Use this dialog to adjust page setup, printer settings, styles, and global settings for custom formats.

Toolbars and menus

The designer screen's toolbars provide various commands for working with the layout and appearance of your custom format. You can move these toolbars around by clicking and holding the left edge of a toolbar and dragging it to a new location. For more information on the toolbars available in the designer screen, see the topic Custom formats toolbars in the Help & How-To Center.

In addition to the toolbars, the designer provides an additional Format menu, which appears only when you are using the Custom Formats screen. This menu provides another way to access most of the commands from the Formatting and Layout toolbars, as well as a command for opening the Format Wizard.
Note: The availability of some commands in the Format menu depends on what you have selected within the designer screen.

The Properties pane

On the right side of the designer screen is the Properties pane, which displays properties for the currently selected item within the layout. When you select an object within the designer, the Properties pane displays data for that object. If you have not selected an object within the designer, this pane displays basic properties for the section of the format that has focus, such as background color.

Within the Properties pane, you can make detailed changes to objects in the designer. For example, rather than dragging an object around the layout, you can select it on the layout and specify its exact placement by changing the X and Y values under the General property.

To change the appearance of fonts, select a text box and click the button next to the Font property to open the Font dialog, where you can choose properties such as font name, font style, font size, and strikeout or underline effects.

Note: Font properties affect all text within the selected text box.

To change the alignment of text within a text box, click the drop-down arrow to the right of the Alignment property to select a different value, such as Center, Right, or Justify.
Restoring the sample database

After you have completed this walkthrough, you should restore the sample database that you backed up (see “Backing up the sample database” on page 2). Use the restored sample database to complete other Practice CS walkthroughs.

1. From the File menu, choose Restore.
2. In the Restore dialog, enter the path to the backup file that you want to restore, or click the browse button to navigate to the backup location (usually X:\Program Files\Microsoft SQL Server\MSSQL$CREATIVESOLUTION\Data, where X: is the drive on the computer where the data resides).
3. In the Restore File Location dialog, click the backup file that you want to restore, and click OK.
4. In the Restore dialog, enter a new name for the database in the New Firm name field.

Note: When you restore the Sample database, you must give it a different name. The restore process in Practice CS does not overwrite an existing database, and Practice CS does not allow firm databases with duplicate names. Therefore, you will need to give the database a different name when you restore it (for example, Sample1). The name may contain only alphanumeric characters.