Error: Font OCR-A BT does not support style Regular

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Scenario

You may see the following error message:

  • When previewing or printing a payroll form.
  • If the Edit Payroll Tax Forms screen is blank.

The error may not display if the payroll tax form prints with wingding characters.

Error message

System.ArgumentException:

Font 'OCR-A BT' does not support style 'Regular'

Cause

The necessary font file used is missing or outdated. Many payroll tax forms require the use of the OCR-A BT font on forms generated by the application.

Solution

  1. In your computer's Control Panel, select Fonts.
  2. Find and delete any fonts that begin with CSI, such as:
    • CSI Forms Normal
    • CSI Forms New Normal
    • CSI MICR E13B Normal
    • CSI MICR E13B V2 Regular
    • CSI OCRA BT Regular
    • CSI OCRB Regular

    If there are no CSI fonts listed, continue to next step.

  3. Delete the following fonts:
    • OCR-A BT Regular
    • OCR-B Normal

    Notes:

    • You may have all or only some of the OCR fonts listed above.
    • Deleting fonts that begin with OCR and are not listed above may cause printing problems within other installed applications.
    • Fonts cannot be deleted by browsing to the C:\Windows\Fonts folder. You will get a message that the file is in use or open by another program.
    • Deleting fonts makes them unavailable for other programs. Only delete the fonts you are sure you are not using.
  4. Reboot your computer.
  5. Run Desktop setup.

Note: If you are using Virtual Office or SaaS, you may be able to resolve this issue by uninstalling and reinstalling the Citrix application.

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Internal only

If the above steps do not work, have the user check another machine for the missing fonts. 

Did you know fonts can be copied from one machine to another?
  1. Open Windows Explorer (Windows key + E).
  2. Navigate to C:\Windows\Fonts.
  3. Copy the font files you want from the Fonts folder to a network drive or a thumb drive.
  4. Then, on the second computer, drag the font files to the Fonts folder, and Windows will automatically install them.

If there isn't a second computer with the missing fonts, you can copy the fonts from your machine and send them to the user. Remember to change your email "From" to Thomson Reuters Support email before you send the email.

Word of caution: Send only the missing fonts used by Thomson Reuters. Why? Most fonts are copyrighted, and should not be transferred from system to system without regard to that copyright. Since most fonts end up on a system when new software is installed or when a special font is purchased and installed, you'll want to check the original documentation that came with the software or font. It should spell out exactly whether you can freely transfer the font from one system to another.