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Introduction 
The Utilities > Data Conversion > ProSystem fx Engagement command in Engagement CS allows you 
to convert and import engagement data from ProSystem fx® Engagement versions 5.0.x to 7.0.x into 
Engagement CS® within Creative Solutions Accounting™ (CSA) and the CS Professional Suite® 
Accounting Products. To determine which version of ProSystem fx Engagement is installed, choose Help 
> About in ProSystem fx Engagement. 

This conversion guide details the steps to convert ProSystem fx Engagement client data, identifies items 
both converted and not converted, documents exceptions that may be encountered during the conversion 
process, and provides suggestions for reviewing converted data. Use this document as a primary 
reference for the ProSystem fx Engagement data conversion. 

Please read this entire document prior to starting the conversion of client data.  

Conversion program overview 
The objective of the ProSystem fx Engagement to Engagement CS conversion is to provide both 
comprehensive and accurate conversion data from the ProSystem fx Engagement client for use in CSA 
and Engagement CS. 

Due to differences between Engagement CS and ProSystem fx Engagement such as processing 
procedures, calculations, and data file storage, some data is either modified or cannot be converted. 

Important! Additions and/or modifications to converted client data in Engagement CS may be required to 
exactly duplicate engagement and workpaper information after the conversion. 
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Installing the conversion program from the CS Professional 
Suite Accounting Products Conversions CD 
1. Uninstall any previously installed versions of the CS Professional Suite Accounting Products 

Conversions CD. 

a) From the Windows® Start menu, choose Control Panel. (On some Windows systems, you may 
need to choose Settings > Control Panel.) 

b) Double-click Add or Remove Programs. 

c) Scroll to CS Accounting Conversions (or to CSI Accounting Conversions) and highlight that 
item. 

d) Click the Change/Remove button. 

e) At the prompt, click Yes to uninstall the program. 

2. Place the CS Professional Suite Accounting Products Conversions CD in the CD drive on your 
computer. 

3.  The setup program will open automatically, or you can do the following to open it: 

a. Open Windows Explorer and navigate to your CD drive. 

b. Double-click SETUP.EXE. 

4. Follow the prompts on the screen to install the CSA conversion program. 

5. After the conversion program has been successfully installed, store the CD in a secure place. 

Notes . 

 The conversion program is installed only on the local computer. You need to install the conversion 
program on each computer from which you will run the conversion program. 

 Once you have converted all of your accounting client data, you can remove the Accounting 
Conversions program from your computer by repeating step 1. 

 The ProSystem fx Engagement Workpaper Management module must also be installed on the hard 
drive (C:\) of the local computer. 

Steps required prior to running the conversion program  
1. We strongly recommend that you make a backup of the ProSystem fx Engagement client data before 

beginning the conversion process. The conversion program will not change any of your existing data. 
If you need to modify the data in ProSystem fx Engagement as part of the conversion process, 
making a backup will enable you to restore the original data. 

2. Prior to converting the engagement data from ProSystem fx Engagement, you must have an 
Engagement CS client already set up in CSA to accept the converted data. You can either create a 
new Trial Balance CS® plus Engagement CS client from scratch or use an existing client. When 
setting up the client in CSA, do not mark the Enable multi-staff functionality in Engagement CS 
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checkbox on the Trial Balance tab until after the client data has been converted from Engagement 
Manager to Engagement CS. (If you were to mark that checkbox prior to converting, the required 
conversion option would not be available in CSA.) 

3. Verify that the current period end date entered in the binder properties in ProSystem fx Engagement 
matches a valid GL date for the Engagement CS client. 

4. In ProSystem fx Engagement, synchronize data from the central file room to the local file room. The 
conversion uses the local file room to obtain the data, not the central file room. 

5. Specify the staff member information for the binder to be converted in the Staff tab of the CSA Setup 
> System Configuration > Administration dialog. This information consists of the ProSystem fx 
Engagement staff member equivalents of the Staff ID, First Name, and Last Name fields. The Staff ID 
field in CSA is equivalent to the Initials field in the Staff Profile tab of ProSystem fx Engagement, 
which ensures binder staff assignment information is converted correctly into the new engagement. 
This information is available for all clients after a staff member has been set up in CSA. 

6. Download and apply all available CSA application updates via CS Connect.™ Using the most current 
version of Engagement CS helps to ensure the accuracy of the engagement conversion. 

Important!  

 If you would like to convert trial balance data from ProSystem fx Engagement to Trial Balance CS, we 
recommend that you convert the trial balance data into CSA prior to converting the ProSystem fx 
engagement data for the same client in Engagement CS. For detailed information, please refer to the 
PDF document entitled “Conversion Guide: Trial Balance Data from ProSystem fx Engagement to 
Trial Balance CS.” 

 Excel workpapers that have been marked as final in Microsoft Excel 2007 (under Microsoft Office 
Button > Prepare > Mark as Final) cannot be converted. The option should be turned off for each 
work paper prior to conversion. 

Converting and importing the client data into 
Engagement CS 

Important! When converting large or complex sets of engagement files for a ProSystem fx Engagement 
client, you should expect the conversion and import process to take a significant amount of time. Please 
wait for the process to be completed. 

After installing the ProSystem fx Engagement to Engagement CS conversion program, use the following 
steps to create the converted data files for import into CSA. 

The conversion process does not modify existing client data in ProSystem fx Engagement. However, it is 
strongly recommended that you create a backup of the original client prior to any processing. 

1. Be sure that the Pro System fx Engagement binder has been synchronized with the Local File Room 
and that any instances of this binder or workpapers are closed on your workstation. Choose Tools > 
Take Over All Workpapers in the ProSystem fx Engagement binder to make sure that the 
appropriate access permissions for all workpapers are converted. We recommend that you 
synchronize the client data to be converted with the ADMIN account. 

2. In CSA, open the Engagement CS client into which you want to convert engagements and then 
choose File > Engagement CS. 
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3. Choose Utilities > Data Conversion > ProSystem fx Engagement from the Engagement CS menu 
bar. 

Important! You must have access to the trial balance in order to access the conversion menu. If you 
do not have access, this option will be grayed out. 

Prior to beginning the conversion, close all open instances of Microsoft Word and Microsoft Excel so 
as to not interfere with the conversion. 

4. The conversion program lists all of the clients found in the Local File Room. Highlight the client to 
convert and click Continue. 

5. A dialog opens and lists all of the binders/engagements for the selected client that are available for 
conversion. Select a single binder or multiple binders to be converted as engagements for the client. 

6. Click Continue to begin the data conversion process and then follow the prompts that appear on the 
screen. 

7. During the conversion process, the Rename dialog opens automatically if duplicate binder names, tab 
names, or workpaper names exist within or between binders in the original client. At this point you 
can rename these items or click past them to accept the new default name. (For more information 
regarding duplicate names, see Duplicate names on page 6.) 

8. At the prompt indicating the conversion process is complete, click OK to begin importing the 
converted data into Engagement CS. 

9. After the import process has been completed for each engagement, you will be prompted to confirm 
whether or not you want to refresh documents from the converted engagement. 

 To create read-only metafile images visible in the engagement, click Yes. 

 To bypass the creation of the read-only metafile images, click No. If you have Microsoft Office 
2007 or newer installed on the conversion machine, we recommend that you choose No to avoid 
potential conflicts during the refresh. 

Note that metafile images are not created for workpapers in formats other than the more common file 
formats such as PDF, JPG, BMP, RTF, etc. 

10. At the prompt indicating the engagements have been imported successfully, click OK. 

11. After the import process is complete, you may use the Engagement Properties dialog in 
Engagement CS to set up staff and workpaper assignments for each converted engagement. For 
details on setting up and using staff and workpaper assignments in Engagement CS, open CSA and 
choose Help > Help & How-To and enter the following in the search field: 

 Assigning staff to a new engagement 

 Assigning staff privileges in a new engagement 

 Assigning workpapers in a new engagement 

Notes  

 The refresh process may take several minutes to complete depending on the number and/or size of 
workpapers in the engagement. To create the read-only images for a single engagement document 
as needed, open the workpaper and save the changes. As an alternative, you can create the read-

http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/es/es_proc/assigning_staff_to_a_new_engagement.htm?product=csa&mybanner=1
http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/es/es_proc/assigning_staff_privileges_in_a_new_engagement.htm?product=csa&mybanner=1
http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/es/es_proc/assigning_workpapers_in_a_new_engagement.htm?product=csa&mybanner=1
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only metafile images at a later time for all workpapers within the engagement by choosing Edit > 
Refresh All Documents. 

 Read-only metafile images of workpapers must be created prior to storing the engagement in 
FileCabinet CS.® However, PDF documents are an exception. PDF documents are embedded in their 
original form, and read-only metafile images are not needed for storage of PDFs in FileCabinet CS. 

 If the current period end date, year end date, or sequence of the converted binder is invalid, you will 
be prompted with a message indicating that the period’s XML file cannot be created. If you receive 
this message, click OK to complete the conversion process. After the conversion, be sure to review 
and change the following as needed: the current fiscal year end date, the current period end date, 
and the period frequency on the General Ledger tab or the Trial Balance tab of the File > Client 
Properties dialog in CSA. 

 If more than one local file room is present, for example because more than one staff member has 
logged into ProSystem fx on the conversion computer, the local file room associated with the Admin 
login will be used. If more than one staff member accesses ProSystem fx Engagement from the 
computer that you are converting on, you should log into ProSystem fx Engagement as Admin and 
synchronize the binders to ensure that the proper information is converted. 

 Depending on your security-level settings in Microsoft Excel, you may receive warning prompts 
regarding links, add-ins, and macros. Click No through these messages and, after the conversion is 
complete, verify that these settings are correct in Excel. Because possible security restrictions could 
affect the conversion of these documents, we recommend that you remove all protection from 
documents before converting. 

 The Server Busy dialog may appear during the conversion stating that a file cannot be accessed. In 
this dialog, you can click the Retry button to continue the conversion. If the conversion seems to stop 
on an Excel workpaper but no dialog appears, the Server Busy dialog may be behind the Converting 
Excel Workpapers dialog. To see and access the Server Busy dialog, simply move the Converting 
Excel Workpapers dialog to another place on the screen. 

Items transferred during data conversion 
The following information is provided to identify ProSystem fx Engagement items that automatically 
convert to Engagement CS. 

Engagement information 
Binder current period ending date, beginning date, due date, index, name, and tree structure are 
converted. The binder date converts as the engagement ending date. The engagement start date is left 
blank in Engagement CS to be completed at the user’s discretion. The engagement start and end dates 
can be changed as needed. 

Folder information 
Tabs are converted as folders in the engagement Tree View. The tab name is converted as the folder 
name. If an index is used, a hyphen is added as a separator between the index number and tab name 
when naming the converted folder. 

Engagement staff assignments 
The converted binders’ assigned staff initials and names are converted as engagement assignments.  
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Workpaper information 
Workpaper name, index and staff assignment information are converted. 

Workpaper signoff 
Signoff initials, name, signoff type, and signoff date are converted. 

Workpaper / document types 
Microsoft Word and Microsoft Excel documents, journal entry reports, write-up journal entry reports, trial 
balance, trial balance summary reports, manual document references, ProSystem fx trial balance 
workpapers, ProSystem fx Fixed Asset FAC files, XML files, HTML files (engagement reports), Adobe® 
PDF files, and other third-party documents such as text and image files are converted. 

Note: Trial balance workpapers converted as Excel files should be opened within the Engagement CS 
workspace by right-clicking the file in the tree view and choosing the Open with Excel command.  

Conversion notes and exceptions 
This section provides details on conversion notes and exceptions between ProSystem fx Engagement 
data and the converted Engagement CS data. Conversion exceptions are items that require manipulation 
of ProSystem fx Engagement data to conform to Engagement CS requirements. 

Duplicate names 
Engagements, folders, workpapers, and workpaper references with duplicate names in a ProSystem fx 
Engagement client are converted with unique names. By default, all duplicate names are renamed during 
the conversion using standard Windows naming conventions. 

During the conversion process, you will have the opportunity to rename these duplicate items. The 
Rename dialog enables you to pause the conversion process and rename the items in ProSystem fx 
Engagement or to use the automatic names provided by the conversion program. It is important to note 
that if an item is renamed the same as another item in the conversion dialogs, the former item is renamed 
automatically. 

In addition, if any binder from ProSystem fx Engagement duplicates an existing engagement name in 
Engagement CS, the engagement is automatically renamed with a unique name. 

Workpaper references 
Engagement CS requires workpapers to have reference values. Workpapers with no value for index are 
assigned a reference value during the conversion. You may rename the workpaper reference if desired. 

Engagement tree structure 
The order and appearance of the engagement in Engagement CS after the conversion may differ from 
ProSystem fx Engagement. Note, however, that all items are converted to the correct folder locations 
within the engagement. To provide maximum flexibility, Engagement CS does not automatically sort 
folders and workpapers. The order of folders, workpapers, and documents can be changed to meet 



Conversion Guide: ProSystem fx Engagement to Engagement CS TL 27555 
Copyright 1998 – 2014 by Thomson Reuters. All rights reserved.  Page 7 

personal preferences. Folders, workpapers, and documents can be moved within an engagement. Click 
the folder, workpaper, or document and then drag and drop it into another location in the tree view.  

Excel workpapers 
Excel workpapers are modified during the conversion process for removal of add-ins, macros, and/or 
links. This includes the removal of formulas and replacement with the result of all non-default Microsoft 
Excel formulas. All read-only Excel files are converted with read-write permission. 

Manual workpapers 
Manual workpapers are converted as text documents during the conversion. 

ProSystem fx Trial Balance workpapers 
Trial balance workpapers (*.AWP) files are converted without modification. You may create a PDF file of 
these items or copy them into an Excel document before or after the conversion is complete. 

Finalized binders 
Finalized binders are converted as wrapped-up engagements in Engagement CS. 

Workpaper signoff types 
While ProSystem fx Engagement allows multiple signoffs for each workpaper, only one signoff per signoff 
type (preparer or reviewer) is converted. Signoff types are converted as follows: 

 “Preparers” converts as Preparer. 

 “Reviewers” converts as Reviewer. 

If the staff member’s initials and first and last names have not already been set up in CSA or vary from 
the CSA values, only the initials appear for the signoff types. 

Staff assignments 
The Staff assignment type does not exist in ProSystem fx Engagement. All engagement staff assignment 
types are converted as Preparer. 

Punctuation marks in names 
Certain punctuation marks (% * : “ < > ? / \ and &) are replaced during the conversion process. If 
contained in the names for engagements, folders, or workpapers, these punctuation marks are replaced 
as follows: 

 Forward ( / ) and Backslash ( \ ) items are replaced with a dash ( - ).  

 All other punctuation marks are replaced by spaces or blanks.  
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Items not converted 
This section provides detailed information about items that are not converted. The following items cannot 
be converted because of differences in data file structures between ProSystem fx Engagement and 
Engagement CS. Some of these items may not be needed following the conversion. However, other 
items may require manual data entry either prior to or following the import of converted data into 
Engagement CS. 

Workpapers not within tabs 
Workpapers not contained within a tab cannot be converted. This includes all workpapers within the 
Unfiled Workpapers, Conflicts, Published Workpapers, and Trash folders. To convert these workpapers 
be sure to move them into a tab prior to the conversion. 

Firm information 
Firm information cannot be converted. 

Client properties 
General client information, client address information, and comments are not converted. This information 
may be added to general information in the CSA Client Properties dialog during the client setup or after 
the conversion has been completed. Client groups and clients assigned to these groups are not 
converted. 

Staff properties 
Staff properties such as titles, login passwords, and so forth cannot be converted. This also includes staff 
groups, teams, and team member assignments. This information may be set up on the Staff and Groups 
tabs of the Setup > System Configuration > Administration dialog in CSA. For more information, choose 
Help > Help & How-To and enter Setting up group and staff privileges in the search field. 

Central file room 
Binder and workpapers can only be converted from Local File Rooms. 

Engagement and workpaper password information 
Engagement and workpaper password information cannot be converted. 

Engagement and workpaper history 
Binder and workpaper history cannot be converted. 

Engagement backups, templates, and packages 
Engagement backups, templates, and packages cannot be converted. 

http://csqa.thomson.com/ua/acct_pr/csa/cs_us_en/es/es_proc/setting_up_group-staff_privileges_for_users_of_es.htm?product=csa&mybanner=1
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Workpaper notes and templates 
Workpaper notes and templates cannot be converted. 

Trial balance client information  
If you would like to convert trial balance data from ProSystem fx Engagement to Trial Balance CS, we 
recommend that you convert the trial balance data into CSA prior to converting the ProSystem fx 
engagement data for the same client in Engagement CS. For detailed information, please refer to the 
PDF document entitled “Conversion Guide: Trial Balance Data from ProSystem fx Engagement to Trial 
Balance CS.” 

For the import and conversion of non-ProSystem fx Engagement trial balances, there are conversions 
available from several products. GoSystem® Audit and ProSystem fx Trial Balance (formerly Avision) are 
two such examples of trial balance conversions that are available. For further information about trial 
balance conversions into CSA from non-ProSystem fx Engagement products, open CSA choose Help > 
Help & How-To and enter PDFs for the conversion guides in Creative Solutions Accounting in the search 
field and then select the appropriate conversion PDF to view. 

Suggestions for reviewing converted data 
To verify converted data, careful examination of client is recommended.  

 Verify each of the engagements converted. 

 Verify workpapers transferred in the engagement. 

For additional client data information, print the Data Conversion Report (as described below). 

Before you begin processing engagements in Engagement CS, you may need to modify global items 
such as staff setup and group privileges. 

Data Conversion Report 
The ProSystem fx Engagement to Engagement CS conversion program automatically creates a Data 
Conversion Report for each client to help you identify special differences in the data that result during the 
conversion process. In most instances, no action is required. 

We recommend that you print the Data Conversion Report and store it with the client files in your office. 
Each such report is saved in PDF format. (Note that you need to have Adobe® Reader® version 7.0 or 
higher installed to view and print the report. If you do not have Adobe Reader installed on your computer, 
open CSA and choose Help > On the Web > Adobe Reader. This takes you to Adobe’s website from 
which you can download and install the Reader.) 

To open the Data Conversion Report in Adobe Reader, do the following: 

1. Using My Computer or Windows Explorer, navigate to the folder where the client’s Engagement CS 
client data and conversion file are stored. 
 
Example: C:\WINCSI\CSAData\xxxxxx (where xxxxxx represents the 11-character Engagement CS 
client ID). 

2. Double-click the xxxxxx.PDF file to open it. 

Most items noted in the report are strictly informational, although you may need to make manual 
modifications to certain items in CSA (such as abbreviations, truncations, and so forth). 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdf_topics/pdfs_for_conversion_guides_in_csa.htm?product=csa&mybanner=1
http://www.adobe.com/
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Note: Each instance of the conversion for a client deletes the existing Data Conversion Report PDF file. 
Therefore, you may want to first copy the file to a separate folder on your hard drive or add it to the 
engagement before running the next conversion.  

Help and Support 

Help & How-To Center 
For answers to questions on using CSA, access the Help & How-To Center by choosing Help > Help & 
How-To, by clicking the  button on the toolbar, or by pressing CTRL+Y. For more information, including 
sample searches, see Finding answers in the Help & How-To Center.  

Product support 
From the Support Contact Information page on our website, you can complete a form to send a question 
to our Support team. To speak directly with a Support Representative, call (800) 968-0600, press 2 for 
Product Support, and listen to the available options. Normal weekday support is available from 9:00 a.m. 
to 8:00 p.m. eastern time. For additional details (including extended support hours for tax season and 
hours for other applications), visit the Support section of our website. You can also access the Support 
section from within CSA by choosing Help > Additional Resources > General Support Information. 

Website resources and email subscriptions 
Visit our website to access the ARNE Community (an online user forum), to learn about training courses, 
to view blogs and articles, and more. You can access the website from within CSA by choosing Help > 
On the Web > CS Professional Suite Home Page. 

We issue application update notices via email. You can sign up to receive these notices by visiting the My 
Account section of our website. You’ll need to create a web account (if you don’t already have one) and 
then sign up for the Email Subscription service where you can indicate which notices you want to receive. 

 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/getting_help/using_online_help.htm?product=csa&mybanner=1
http://cs.thomsonreuters.com/support/contact.aspx
http://cs.thomsonreuters.com/support/
http://cs.thomsonreuters.com/
http://cs.thomsonreuters.com/myaccount/
http://cs.thomsonreuters.com/myaccount/
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