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1  
Welcome! 

This guide is designed to introduce you to the concepts, terminology, and 
features of the Engagement CS® and the Creative Solutions Accounting™ 
(CSA) platform within the CS Professional Suite® Accounting Products 
software, so you can process client data efficiently and accurately.  

Fully integrated with Trial Balance CS,® Engagement CS offers 
advanced reporting and diagnostic features and a completely paperless 
engagement process. From compilation and review to audit, it provides a 
robust, flexible, and secure environment in which to perform all your 
engagements. Microsoft® Windows® (Vista or higher) standard interface 
and menus lessen the learning curve for your employees. 

Licensed users of Engagement CS enjoy the full benefits of using the 
following CSA applications. 

 Trial Balance CS. The timesaving features of Trial Balance CS 
make it ideal for handling engagements with maximum efficiency. It 
enables you to switch the basis for your financial statements from 
cash to accrual, tax, book, and more. 

 Financial Reporter module. Makes it easy to design custom 
financial statements, footnotes, and charts or graphs. It also allows 
you to choose collation sequences and quantities for standard 
reports, customized financial statements, and transmittal letters, and 
to set up customized report profiles that include all reports and 
statements that you run for each client. 

Engagement CS also includes complete integration with PPC’s 
Checkpoint®  Tools (including PPC’s SMART Practice Aids® and PPC’s 
Workpapers,™ and PPC’s Reference Library – now known as PPC’s 
Interactive Disclosure Libraries™), and other guidance tools available in 
Microsoft® Word® or Excel® format. 
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Installing the application and completing some 
initial setup steps 

For detailed instructions on installing the application, please refer to the 
CS Professional Suite® Accounting Products Installation and Program 
Essentials guide, which you received with your application. You can view 
or print this guide in Portable Document Format (PDF) by searching on 
Installation and Program Essentials guide (PDF) from the Search field 
in any CSA topic in the Help & How-To Center. 

Note: This guide also includes details on using the application’s help 
topics, on setting up CS Connect,™ and on setting up administrative 
information and user preferences. 

Learning about Windows 
This guide assumes that you are already familiar with using Microsoft 
Windows and its conventions. To view help on using your Windows 
operating system, click the Start button in the Windows taskbar and 
choose Help and Support. 

Learning about Engagement CS 
 CSA and Engagement CS help topics. The comprehensive help 

topics in our Help & How-To Center provide the primary 
documentation for learning about and using CSA (including 
Trial Balance CS and Engagement CS). The help topics include 
information about features, data-entry windows, and procedures, as 
well as links to conversion guides and other special-topic guides, 
show-me videos, FAQs, troubleshooting tips, and much more. For 
more information about using the help, refer to the chapter entitled 
“Getting Help” in the CS Professional Suite Accounting Products 
Installation and Program Essentials guide. 

 Engagement CS Getting Started guide. This guide provides an 
overview of the features available in Engagement CS. 

 Engagement CS Tutorial. It is strongly recommended that you 
complete the exercises in the tutorial after you have read the 
Engagement CS Getting Started guide. The tutorial takes you briefly 
through some of the main processing steps in Engagement CS 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/csa_installation_essentials.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/csa_installation_essentials.pdf
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 Financial Reporter Tutorial. This document provides sample 
exercises for creating and printing financial statements. If you have 
purchased Engagement CS, you also have a printed copy of this 
document. 

 Training and consulting services. We offer training courses and 
consulting services for Engagement CS. For complete details, please 
visit the Training section of our website at 
cs.thomsonreuters.com/training. 

 Annual Users’ Conference. Thomson Reuters hosts an annual 
conference. We offer workshops for users of CS Professional Suite 
applications at all levels of experience. For details, visit our website 
at cs.thomsonreuters.com. 

About this guide 
This getting started guide provides an overview of the features available 
in the application, a section that describes tasks involved in setting up an 
engagement, and an overview of the main engagement processing 
functions in the application. Details about each of the following 
engagement processing steps are discussed in this guide. 

 Setting up the engagement environment prior to processing data for 
your own clients. 

 Processing engagement client data and engagement workflow. 

 Collaborating with other engagement staff, including tasks such as 
the following. 

https://cs.thomsonreuters.com/training
https://cs.thomsonreuters.com/
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Where to begin 
Please read the CS Professional Suite Accounting Products Installation 
and Program Essentials guide for detailed instructions on installing the 
software, checking your monitor settings, setting up CS Connect, and 
using the CSA help. 

After you install CS Professional Suite Accounting Products application, 
please read each section of this getting started guide and follow all of the 
steps. As you are working, use the context-sensitive help topics for 
details about each field or option, and open the Help & How-To Center to 
access more complete information on using the application. 

Once you are familiar with the Engagement CS features, menu 
commands, and toolbars, we strongly recommend that you take 
advantage of the setup examples in the Engagement CS Tutorial. 

 

 

 

 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/csa_installation_essentials.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/csa_installation_essentials.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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2  
Application Overview 

This section of the getting started guide provides a brief overview of the 
main features of Engagement CS, as well as features in CSA that are 
specifically related to Engagement CS. 

Engagement CS application features 
Easy to use, with professional results 

With the multi-staff feature enabled in the application, individual staff 
members have the ability to work in the Master Client Data (MCD) at the 
same time as other staff members when they are connected to a 
common network. 

Alternatively, they can send documents and receive them on a separate 
workstation or laptop for work on the Local Client Data (LCD). When staff 
member(s) have completed their work, they can send the updated 
engagement documents to a common network location, and the master 
engagement then receives those documents. 

You can use the synchronize feature as another way of updating the 
MCD and the LCD without having to send/receive documents on a 
regular basis. 

When you are licensed for FileCabinet CS and have it installed, you can 
easily store engagements that have been finalized and are ready for 
archiving for a completely paperless office. 
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Integration with other CSA products 
Engagement CS is fully integrated with Trial Balance CS and the 
Financial Reporter module to provide you with a flexible and secure 
environment in which to prepare engagements. You can add, modify, or 
delete journal entries (if you have been assigned the privileges to do so). 

Staff members who are assigned the trial balance can perform the 
following tasks. 

 Open the trial balance in the Engagement CS workspace.  

 Set up grouping schedules, tickmarks, balance definitions, and 
additional amounts in CSA. 

 Move a CSA financial statement, transmittal letter, or report into the 
engagement. 

 Create an indirect or direct cash flow worksheet to analyze account 
balances. 

Integration with Microsoft Word and Excel 
You can launch Microsoft Word and Excel workpapers within or outside 
of the Engagement CS workspace to take advantage of the integrated 
menus that enable you to insert the following. 

 Formulas using CSA trial balance data. 

 Workpaper links. 

 Staff ID and date when a procedure is completed. 

 Tickmarks. 

 Multiple formulas. 

 Signoffs. 

 Text variables. 

In addition, you can recalculate amounts in a Word or Excel workpaper 
as updates are made to the linked engagement client in CSA. 
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Paperless engagement 
You can use Engagement CS to organize and file all your currently 
active engagement documentation in one location. 

Security setup in CSA 
 The staff in charge of the engagement can define groups on the 

Groups tab of the Setup > System Configuration > Administration 
dialog in CSA. You can set up each group by a staff in charge to 
perform specific tasks within engagements. The staff in charge may 
also override task assignments on an engagement-by-engagement 
basis. 

 The staff in charge of the engagement can set up individual staff 
members with password access on the Staff tab of the Setup > 
System Configuration > Administration dialog in CSA. 

Guidance aids  
Engagement CS works in conjunction with the following industry 
standard guidance aids (if you have the appropriate products installed). 

 Practitioner’s Publishing Company’s (PPC’s) Checkpoint Tools 

 PPC’s Practice Aids™ 

 PPC’s Workpapers 

 PPC’s SMART Practice Aids 

 PPC’s Reference Library (now known as PPC’s Interactive 
Disclosure Libraries) 

 Any other guidance available in Microsoft Word or Excel format 

Review notes 
You can easily add review notes to individual workpapers, folders, and 
engagements that can be viewed in the Notes window of the 
Engagement CS workspace. A reviewer or another staff member 
assigned to the engagement team can review, reply to, and clear these 
notes at a later time. 
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Send / Receive features 
Multiple staff members who have been added to the engagement and 
assigned workpapers can use Engagement CS to send documents out of 
and back in to the Master Client Data when working in the Local Client 
Data. This method also enables staff to reassign and send documents to 
other staff members in the field. 

Multi-staff feature 
Engagement CS enables more than one staff member to work in the 
Master Client Data at the same time. In addition, this feature provides an 
alternative method for sending and receiving selected workpapers to the 
Local Client Data. 

Synchronization 
You can use the synchronize feature to update the Master Client Data 
and staff members’ Local Client Data on-the-fly, without sending / 
receiving documents from the master or local client engagement. 

Storage of multiple file types 
You can store virtually any type of file can be stored with an engagement 
and/or placed inside a workpaper. You can view and/or edit Word and 
Excel workpapers from within Engagement CS. (You can edit other files 
in their own applications.) 

Wrap up 
You can take advantage of the Wrap Up wizard in Engagement CS to 
clear / delete review notes, review signoffs, and finalize all your 
engagement documents and workpapers. 

Roll forward 
When you decide to roll forward the current engagement, you can 
choose to include engagement items such as programs, checklists, 
workpapers, and other practice aids. The roll forward process creates a 
new engagement, updates the technical content, and replaces selected 
documents to prepare your engagement environment for the next year. 
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Send engagement to file / email 
You can create a PDF version of the engagement and save it to a 
location on your local drive or network location or as an email 
attachment. 

Send engagement to FileCabinet CS 
You can take advantage of the CS Professional Suite Accounting 
Products integration capabilities by storing the final version of your 
engagements to FileCabinet CS (if you are a licensed user of FileCabinet 
CS and have it installed). 

Send engagement to GoFileRoom 
You can take advantage of Engagement CS’s integration with 
GoFileRoom® software to store the final version of your engagements (if 
you are a licensed user of GoFileRoom and have it installed). 

Archive engagements 
You can use the archive engagements feature to securely store 
engagements that you no longer need to view in the engagement 
workspace. This feature also allows you to restore a copy of the archived 
engagement and delete the existing archives. 
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Menu commands 
Each of the headings in the menu bar that appears at the top of the main 
window contains a pull-down menu of commands that cause 
Engagement CS to perform a specific function, such as opening a 
particular window or dialog. Note that some of the menus are dynamic — 
that is, the commands may differ 
depending on where you are in 
the application. 

The name of each menu 
includes one underlined letter. 
To open a particular pull-down 
menu and see its commands, 
you may do either of the 
following:  

 Click the menu name with 
the left mouse button. 

OR 

 Press the ALT key plus the 
underlined letter in the menu 
name. For example, to open 
the File menu (shown here), 
press ALT+F. 

By displaying the commands of 
each of the pull-down menus, 
you can get an overview of the 
main features in 
Engagement CS. Note that when 
you place the mouse pointer 
over a menu command, a short 
description of that command appears at the left edge of the status bar (at 
the bottom of the CSA main window). 
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When Engagement CS is licensed and installed with the CSA 
application, the menu bar includes commands to perform the functions 
listed in the following table. 

Menu Functions 
File Adding a new document, folder, or engagement; opening and 

closing an engagement client; accessing client properties or 
engagement properties; printing; viewing notes or workpaper 
diagnostic reports; consolidating clients; rolling forward the 
engagement; changing the period to process; sending 
engagements to file, FileCabinet CS (when licensed), or 
GoFileRoom (when licensed); creating, restoring or deleting 
archives; processing unfiled workpapers; adding new clients; 
saving clients with a new ID; renaming clients: and deleting 
clients; backing up or restoring data; accessing CS Connect; 
exiting to CSA; exiting from CSA entirely. 

Edit (Available commands are specific to the active window.) 
Copying or pasting a document; renaming a folder or 
engagement; deleting a document; editing workpaper 
properties; signing off workpapers; opening a document in the 
engagement workspace or launching it in Word or Excel 
(depending on the document selected); adding a new review 
note or editing an existing review note; undoing the checkout 
status of documents; undoing the Disconnect status of a 
document; refreshing a document or all documents in the 
engagement; refreshing only outdated workpapers; finding a 
specific document in the engagement. 

View Selecting toolbars (standard, page navigation) and windows 
(tree view, notes) and windows to display; filtering by folder and 
showing all folders. 

Tasks Assigning or opening the Trial Balance; adding or viewing 
journal entries; performing tax reconciliations; checking out 
engagement documents to the Local Client Data; receiving 
checked-in documents from the LCD; receiving checked-out 
documents from the Master Client Data and checking in 
documents for the MCD; synchronizing data; disconnecting / 
reconnecting Excel or Word workpapers; wrapping up an 
engagement; accessing and retrieving the PPC Reference 
Library; accessing and retrieving PPC’s SMART Practice Aids; 
converting engagements from PPC’s Engagement Manager® or 
ProSystem fx® Engagement; accessing or releasing the Trial 
Balance; updating workpaper links.  
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Menu Functions 
Utilities Importing Fixed Assets CS® journal entries; importing ASCII 

files, spreadsheets, QuickBooks® account balances, Payroll 
Journal Entry XML import; creating a rounding journal entry; 
exporting to ProfitCents;® sharing data and employee 
demographic data across CSA products and between CSA and 
other CS Professional Suite products; transferring information 
from one client to another; exporting reports to ASCII or DIF file; 
exporting client tax data via Lacerte,® ProSystem fx,® and 
ProSeries;® performing data conversion from PPC’s 
Engagement Manager, ProSystem fx® Engagement, GoSystem 
Audit, GoSystem Fund, Workpapers Plus, ProSystem fx® Trial 
Balance, AICPA Accountant’s Trial Balance; accessing 
FileCabinet CS (for a FileCabinet CS licensee). 

Setup Setting up and maintaining the Chart of Accounts; setting up 
and maintaining account groups, additional amounts; setting up 
and maintaining Tax Code Account Groupings; setting up and 
maintaining Grouping Schedules; tickmarks, balance 
definitions; setting up and maintaining indirect / direct cash flow 
worksheets, prior year amounts; printing the Cash Flow 
Analysis Report; transferring cash flow lines; setting up global 
system configuration items such as, signoff types, 
GoFileRoom® Index Mapping, staff/group privileges, 
administrative privileges (from the Administration dialog), and 
text variables; setting up and maintaining user preferences in 
Creative Solutions Accounting and Engagement CS. 

Window Arranging the open windows in the CSA workspace; switching 
between open data-entry windows. 

Help Opening the Engagement CS help browser; opening PPC’s 
Practice Aid Manager help topics; accessing PPC’s Online 
Library; accessing PPC Checkpoint Tools; accessing Capital 
Confirmation; removing temporary files; accessing the Repair 
dialog. 

 Tips 
 Some of the menu commands have corresponding buttons on the 

Engagement CS toolbar.  

 Several of the most commonly used menu commands, such as New 
Document or Print, have special shortcut key combinations that allow 
you to execute the command quickly from your keyboard. (For a list 
of these keyboard shortcuts, refer to “Appendix: 
Keyboard Shortcuts” at the end of this guide.) 
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Toolbar 

 

The toolbar buttons provide a quick, convenient method for executing 
common commands in Engagement CS. To perform an action using the 
toolbar, simply click the appropriate button on the toolbar. 

If you let the mouse pointer pause for a moment over a toolbar button, 
you’ll see the “ToolTip” name for that button. The following table 
describes each button on the toolbar. 

Button Action 

 
Open Client. Opens the Open Engagement Client dialog 
where you can select a client from the list to open in the 
Engagement workspace. 

 
Engagement Properties. Opens the Engagement Properties 
dialog where you can modify existing properties for the current 
engagement. 

 
New Folder. Opens the New Folder dialog, where you can 
enter a name for the new folder. 

 
New Document. Opens the Insert Engagement document 
wizard.  
Shortcut key: CTRL+N. 

 
Trial Balance. Opens the Trial Balance window in the 
engagement workspace. 

 
Journal Entries. Opens the Adjusting Journal Entries window 
in the engagement workspace. 

 
Scan pages. Opens the Scan Images dialog (available only 
when there is an active connection to a scanner) where you 
can scan single or multiple pages into a single or multiple Word 
documents to be included in the current engagement. 

 
Print. Opens the Print dialog, which allows you to set a variety 
of printing parameters.  
Shortcut key: CTRL+P 

 
Show / Hide Notes. Displays or hides sticky notes. 

 
New notes. Opens the Review Notes dialog, which allows you 
to add a review note. 
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Button Action 

 
Filter. Opens the Filter dialog, which allows you to highlight a 
folder you want to filter. When you click the Done button, only 
that folder and its contents appear in the Tree View window.  

 
Show all Folders. Returns the Tree View window to the 
original view, which displays all folders.  

 
Refresh Documents on Demand. When toggled on (pressed), 
you can open, update, and close workpapers multiple times 
without invoking an automatic refresh of the workpapers within 
the engagement. Workpapers that are outdated appear with 
red text in the Tree View window until manually refreshed. 
When toggled off (not pressed), workpapers do not display as 
red text when they are outdated but refresh automatically when 
saved and closed. 

 
PPC’s Reference Library. If appropriately licensed, opens 
PPC’s Reference Library (now known as Interactive Disclosure 
Libraries).  

 
FileCabinet CS. If appropriately licensed, opens FileCabinet 
CS, where you can store the final version of your 
engagement(s) or other important documents and workpapers. 

 
Exit to CSA. Saves and closes the current engagement in the 
Engagement CS workspace and returns to CSA. 

 
SMART Practice Aids.® If appropriately licensed, opens 
PPC’s SMART Practice Aids. 

 
First Page. Takes you to the first page of the document you 
are viewing. 

 
Previous Page. Takes you to the previous page of the 
document you are viewing. 

 
Next Page. Takes you to the next page of the document you 
are viewing. 

 
Last Page. Takes you to the last page of the document you 
are viewing. 

 
Zoom In. With each click, the object in the Document View 
window increases in size. 

 
Zoom Out. With each click, the object in the Document View 
window decreases in size. 
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Engagement CS workspace  
Viewing and resizing windows 

By toggling the toolbar and window items on and off in the View menu, 
you can choose to display or hide these toolbars and windows.  

 To view or hide an item, choose View and toggle on or off the toolbar 
or window you want to view or restore. 

 You can also hide the Tree View window by clicking the  in the 
upper-right corner. You can hide the Notes View window by clicking 
the  in the upper-left corner. Restore either window by choosing 
View and checking the window(s) you want to restore. 

 You can adjust the width or height of the Notes View window or Tree 
View window by positioning the mouse pointer over the horizontal or 

vertical border. When the mouse pointer changes to , click and 
hold the border and drag it to the size you want. 

Tree View window  
You can use the Tree View window in Engagement CS to view all client 
engagements, and to organize the folders and documents within each 
engagement. Expand any portion of the tree view by clicking . 

 Collapse any portion of the tree view by clicking . 

 

 View information about the workpaper, such as warnings, who the 
workpaper is assigned to, number of review notes, and signoff 
information. 

 You can also choose to view only those engagements or folders that 
you currently want to work with in the Tree-view window. Choose 
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View > Filter by Folder, highlight the folder you want to work with, 
and click OK.  

 

 View only the folder you are working in by selecting it and clicking 
the Filter button. 

 Restore your view of all folders by clicking the Show all Folders 
button. 

Notes View window  
 Expand any portion of the Notes View window by clicking .  

 Collapse any portion of the Notes View window by clicking . 

 To modify a note, or to add / remove a sticky note from a document, 
highlight the note, right-click the Notes View window, and choose 
Edit Note, Delete Note, Add Sticky Note, or Remove Sticky Note.  
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Document View window properties 
This window takes up any area in the workspace that is not occupied by 
the Tree View and Notes View windows. Resizing the other windows 
allows you to manipulate the size and position of the Document View 
window. 

To display a tab for each open document at the bottom of the Document 
View window, choose Setup > User Preferences. On the 
Engagement CS tab mark the Use tabbed Window View checkbox.  
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Note: You can use the Zoom In  and Zoom Out  buttons on the 
Engagement CS toolbar to enlarge or shrink the workpaper image in the 
engagement workspace. 

Workflow elements in Engagement CS 
The following diagram illustrates the processes involved in creating, 
organizing, reviewing, and completing an engagement using 
Engagement CS. 
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3  
Engagement Setup 

This section of the Engagement CS Getting Started guide provides a 
brief overview of several of the main processing features in 
Engagement CS that are performed during the setup phase of the 
engagement. 

For additional information on how to use each feature, you can consult 
the comprehensive Engagement CS help in the Help & How-To Center. 
From within Engagement CS, you can choose Help > Help & How-To to 
open the “Welcome to Engagement CS” topic. You can click the Browse 
Subjects or Index links, as well as enter search terms in the search field 
at the top of any CSA help topic in the Help & How-To Center. 

Overview of the setup dialogs 
Accounting engagements are defined and configured with “building 
blocks” of information that individual staff members can work on 
separately in the field and then check back in to or synchronize with the 
Master Client Data for a cycle of review, re-assignment, final check-in, 
and wrap-up by the staff in charge of the engagement. The staff in 
charge of the engagement must complete some preliminary global and 
engagement-specific setup in CSA (from the Setup > System 
Configuration > Administration dialog) to allow access to engagements 
by specific staff members and/or groups. 

 



Engagement Processing Overview  

20 Engagement CS Getting Started 

Note: If you are the staff in charge and are launching CSA and 
Engagement CS for the first time, you are required to set up a password 
and security level for yourself that allows you to open, add, edit, and 
delete engagement groups and staff members on the Groups and Staff 
tabs of the Administration dialog. 

Important! Because of certain data dependencies among the various 
setup dialogs, when adding new global or client-specific setup 
information in Engagement CS, you should visit the setup dialogs in the 
sequence in which we present them in this section. Please refer to the 
CSA Help & How-To Center for more detailed information about using 
each of the setup dialogs that we mention in the following sections. You 
can quickly open overview help for any dialog by pressing F1 or 
CTRL+F1. 

Setup > System Configuration > Administration dialog 
The Setup > System Configuration > Administration dialog in CSA 
enables the staff in charge to perform the following tasks. 

 Modify the master password and/or select an appropriate security 
level. (Engagement CS users must select Staff level security.) 

 For licensed users of FileCabinet CS, enable automatic backups of 
client data to FileCabinet CS. 

 Enable or disable data sharing between your CS Professional Suite 
applications. 

 Customize privileges for groups and assign staff members to these 
groups. For more details, choose Help > Help & How-To and enter 
Setting up user-specific security access in CSA in the search field of 
the Help & How-To Center. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/csa_platform/proc/setting_up_user-specific_security_access_in_csa.htm?Product=csa&banner=1
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Setting up group and staff privileges for Engagement CS users 
As the staff in charge of the engagement, you can set up multiple groups 
made up of one or more staff members of the engagement team on the 
Groups and Staff tabs of the Setup > System Configuration > 
Administration dialog. Assigning individual staff members to a group or to 
multiple groups allows them to perform user-specific engagement tasks 
yet limits their access to other areas of the application. Make your choice 
based on what you want the staff members to have access to most of the 
time. You can override your choices on a per-engagement basis. 
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Launching the application for the first time 
If you are launching CSA and Engagement CS for the first time as a staff 
in charge of the engagement, the Administrators group is set up by 
default. As a staff in charge of the engagement, add a staff ID for 
yourself first, mark the Administrators and Engagement CS User 
checkboxes on the Staff tab to enable you to add, open, and edit 
additional groups and staff members globally for each engagement. 

Note: When launching the application for the first time, the security 
setting Staff level security – log of staff activity maintained is marked 
by default. 

Important! The Groups and Staff tabs are available only when the Staff 
level security option on the Firm tab of the Administration dialog is 
selected (required for Engagement CS users). Privileges for groups must 
be defined from the Group Privileges dialog accessed from the Groups 
tab. Note that when the Staff level security option is selected the Security 
tab becomes unavailable. 

Setting up group privileges for Engagement CS 
users (required) 

If you are a staff member in charge of engagement processing, you may 
use the Groups tab of the Setup > System Configuration > Administration 
dialog in CSA to set up groups and customize privileges for each group. 
From the Groups tab, you can click the Group Privileges button to open 
another multi-tab dialog where you can specify the CSA privilege 
options. 

1. From the CSA main window, choose Setup > System Configuration 
> Administration. 

2. On the Firm tab of the Administration dialog, enter the master 
password and then click the Continue button. 

3. Click the Groups tab, and then click the Add button to add a new 
group. 

4. Enter a group name and description for the new group.  
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5. Click the Group Privileges button and mark the desired options in the 
General and Financial Reporter tabs. 

Note: The tabs that appear in the Group Privileges dialog may vary 
based on which CSA licenses you have installed. 

6. Click the Engagements tab in the Group Privileges dialog and mark 
the options that you want to enable for this group. 
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7. Click OK to save your selections and return to the Administration 
dialog.  

8. Click the Enter button on the Groups tab to save your selections.  

Notes 

 When setting up engagement users in Engagement CS, we 
recommend that you mark only the Add potential journal entries 
checkbox and not the Add all journal entry types checkbox. This 
enables the staff assigned to the Trial Balance to change only the 
potential journal entries entered by engagement staff members to 
another type of journal entry (Adjusting, Tax Adjustment, 
Reclassifying, Other, or Budget), as necessary. 

 Group privileges that are set up on the Engagements tab of the 
Group Privileges dialog are global privileges, and apply to all staff 
members who are a part of that group when working in Engagement 
CS. However, the staff in charge can define engagement-specific 
privileges on the Staff Privileges tab of the Engagement Properties 
dialog in Engagement CS. The staff privileges assigned at the 
engagement level override the global privileges that are set up in 
the Groups > Group Privileges dialog in CSA, and apply to the 
current engagement only. 
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 Engagement CS-related group privileges are also found on the 
General and Financial Reporter tabs of the Group Privileges dialog. 
Privileges such as Client passwords, Delete clients, FileCabinet 
backup, Add/Edit groups, Add/Edit staff, Financial statement editor, 
and global financial statements all affect how you want engagement 
staff members to be set up for and perform tasks in an engagement. 

Setting up staff for Engagement CS users  
Use the Staff tab of the Setup > System Configuration > Administration 
dialog to add, edit, or delete staff records. You may choose to set up a 
password for a staff member in the password field of the Staff tab. The 
password is then required when that staff member launches CSA. 

1. Click the Staff tab in the Administration dialog, and click the Add 
button. 

2. Enter a unique staff ID using up to five alphanumeric characters. 
(Entering a Social Security number is optional.) 

3. Enter the staff member’s name, and then enter a unique password 
(optional) for the staff member (using up to 15 alphanumeric 
characters). 

4. In the Member of list, mark the appropriate checkboxes for the 
groups that apply to Engagement CS and this staff member. 

5. Mark the Engagement CS User checkbox to identify this user as a 
staff member who uses Engagement CS. (This checkbox must be 
marked to allow access to Engagement CS.) 
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6. Click the Enter button to save the settings for this staff member.  

 

7. When you have finished entering staff setup information for all staff 
members, click Done. 
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Customizing signoff types 
Engagement CS provides five signoff types. Two (Preparer and 
Reviewer) are pre-defined by the application and cannot be edited or 
renamed. You can customize the type description for one or more of the 
other three signoff types, and use them with any (globally) engagement 
client. 

Notes 

 CSA stores signoff types as global data and includes them when you 
back up or restore the global database. 

 If you edit a signoff type description in the Setup > System 
Configuration > Signoff Types dialog, the application displays the 
new description for that type number (not including wrapped-up 
engagements) for all engagements. 

1. Choose Setup > System Configuration > Signoff Types to open the 
Signoff Types dialog. Note that Preparer and Reviewer are the 
defaults for Types 1 and 2. 
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2. To customize a type, highlight Type 3, 4, or 5 and click the Edit 
button. (The Edit button is enabled only if Type 3, 4, or 5 is selected.) 

3. Enter a description of up to 50 alphanumeric characters in the 
Description field. 

4. Click the Enter button to save the customized type. 

5. Click the Done button to close the Signoff Types dialog. 
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Opening Engagement CS 
In CSA, choose File > Engagement CS to open the Engagement CS 
workspace, then choose File > Open Engagement Client to select from a 
list of available engagements to launch in Engagement CS. 

Note: If you mark the Launch Engagement CS after login checkbox on 
the Engagement CS tab of the Engagement CS User Preferences dialog, 
the application launches directly, without opening CSA first. 

Setting up user preferences in Engagement CS 
The Engagement CS User Preferences dialog allows you to define how 
you want to use and view the application when processing engagements 
for any client. The settings include general options for using the 
application as well as file locations for the Office Master Client Data and 
the Field Master Client Data. 

Master Client Data. The MCD is the central location where the 
engagement is created. For each client there is only one MCD. 

Local Client Data. The application creates Local Client Data when a 
member of the engagement team checks out and receives documents 
from the MCD to work on them locally in the field. There may be multiple 
LCD files for each CSA engagement. 

1. With Engagement CS open, choose Setup > User Preferences. 

2. On the Engagement CS tab in the Engagement CS User 
Preferences dialog, mark or unmark each of the options to suit your 
needs for all engagements. 
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 Use tabbed Window View. Mark this checkbox to display a tab 
for each document in the Document View window in the 
engagement workspace. 

 Open last client accessed when starting Engagement CS. 
Mark this checkbox to automatically open the last engagement 
client that was open in Engagement CS. 

 Prompt to attach sticky note when entering new review note. 
Mark this checkbox to have the application prompt you to attach 
a sticky note to the current workpaper each time you add a note. 

 Launch Engagement CS after login. Mark this checkbox to 
open Engagement CS automatically after logging in to CSA. 
(This option is appropriate for staff members who work mainly in 
Engagement CS.) 

 Open client when exiting to CSA. Mark this checkbox to open 
the client in CSA when exiting Engagement CS. 

 Use double click to open workpaper outside of Engagement 
CS. Mark this checkbox to open workpapers outside of the 
engagement workspace with a double-click of the mouse. 
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 Automatically share display area. Mark this checkbox to have 
the application automatically share the display area between 
document folders and the document currently visible. To control 
presentation, move the mouse over the window you want to see. 

 Refresh documents upon Sign Off. Mark this checkbox to 
have the application automatically refresh each document as 
part of the document signoff process. 

 Use single click to open PDF files inside Engagement CS. 
Mark this checkbox to open PDF documents with a single mouse 
click in Engagement CS. 

Office and Field Master Client Data 
Specify the paths to use when working in a network environment to 
enable synchronizing with the MCD in the office or in the field. 

 Office Master Client Data path. This is the location where the MCD 
is stored in a network environment when you are in the office.  

 Field Master Client Data path. This is the location where the MCD 
is stored in a network environment if you are setting up a peer-to-
peer network in the field. 

Follow these steps to specify the paths. 

1. In the Engagement CS User Preferences dialog, click the 
Synchronize tab and enter or browse to the location for the Office 
Master Client Data and the Field Master Client Data. 
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2. Click OK to save the settings, and close the Engagement CS User 
Preferences dialog. 

Note: For each user, the settings in this dialog apply to all engagements; 
they are not engagement specific. 

Refreshing documents on demand 
You can choose to have the application refresh documents on an on-
demand basis after changes are made. This is controlled by toggling the 

Refresh Documents on Demand  button on your Engagement CS 
toolbar. This option is toggled on by default. 
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When the option is enabled, you can open, update, and close 
workpapers multiple times without invoking the automatic refresh of the 
workpapers in the engagement. Workpapers that are outdated appear in 
the Tree View window in red text with an associated number in the 
Warning column indicating that it is outdated. 

 
 

Notes 

 Choose Edit > Refresh > Refresh Outdated Documents to refresh 
only those documents that have been flagged as outdated in the 
Tree View window. 

 When outdated documents exist in the engagement, the application 
prompts to refresh the current document or current engagement 
when you perform various tasks (such as printing, wrapping up, or 
checking in / checking out) in Engagement CS. 

 To sign off or modify an existing signoff, the current document needs 
to be refreshed if it is outdated. This includes signoffs for single 
documents, multiple documents, or the entire engagement. Note that 
if the Refresh documents upon Sign Off checkbox is marked in the 
Engagement CS User Preferences dialog, the document is 
automatically refreshed on signoff whether the on-demand toggle is 
turned on or off. 
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Setting up engagement properties  
If the group for which your staff ID has been set up has the appropriate 
privileges (predefined by the engagement staff in charge), you can use 
the Engagement Properties dialog to view, add, modify, or delete staff 
assignments for the current engagement on the Staff Assignments tab. 
You can also use the Workpaper Assignments tab to define access 
privileges for the workpapers and documents in the current engagement. 

To set up engagement-specific items in the application, open a client 
with an existing engagement in the Engagement CS workspace. 

 Choose File > Engagement Properties to open the Engagement 
Properties dialog. 

You can use the Engagement Properties dialog to perform the following 
tasks.  

 Display engagement information (on the General tab of the dialog). 

 Add, edit, or remove signoff information. 

 Assign specific staff and signoff types for the current engagement. 

 Assign workpapers and documents to staff members who are 
working on the engagement. 

 Assign specific privileges to individual staff members who are 
assigned to the current engagement. 

 View all activity that has taken place in the current engagement. 

When creating a new engagement, you can complete these tasks using 
the New Engagement wizard. 

Important! The ability to edit engagement properties is controlled by a 
security setting established by the staff in charge of the engagement. 
Otherwise you can only view the Engagement Properties dialog and 
update signoff information. 
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General tab 
Use this tab to enter general information on the current engagement. 

 

Identification 
 Name. This field is the name of the engagement which is displayed 

next to the engagement icon in the Tree View window (required 
field). 

 Description. This field is a short description of the selected 
engagement. 

 Engagement period ending date. This field is the ending date for 
the period of time that is being reviewed or audited. The date value 
automatically defaults to the current period ending date for the 
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General Ledger period, but can be changed to an existing Trial 
Balance period end date. 

 Number of years of balances to use. This field is the number of 
years of balances to use in the current engagement, which cannot 
exceed the number of years of balances to save that is specified in 
the General Ledger tab or Trial Balance tab of the Client Properties 
dialog in CSA. 

Engagement Dates 
Enter the beginning and ending dates for the engagement process. You 
can click the calendar button to the right of the date field to select a date 
from the calendar. 

Audit Documentation Dates 
 Audit engagement. To indicate that the engagement is an audit 

engagement, mark this checkbox. 

 Public entity. To indicate that the engagement is an audit 
engagement for a public entity, mark this checkbox. (This 
checkbox is available only if the Audit engagement checkbox is 
marked.)  

 Report Release Date. Use this field to specify the date on which 
permission was granted to the client to use the auditor’s report in 
connection with the financial statements. 

Signoffs 
 Add. Click this button to add a signoff to the engagement. You can 

select the appropriate type from the drop-down list in the Signoff 
dialog. Notice that the application automatically fills in the Name and 
Date fields with the current staff name and the date of the signoff 
(based on the current system date). 

 Edit. Click this button to edit an existing signoff. Staff members can 
edit only their own signoff information. The Signoff type field is 
available to edit. The Date field is available to edit only if the staff 
member has the Edit signoff date privilege set up on the Staff 
Privileges tab of the Engagement Properties dialog. 

 Remove. Click this button to remove your signoff from the 
engagement. (You cannot remove another staff member’s signoff.)  
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Staff Assignment tab 
As the staff in charge of the engagement, you can use this tab to assign 
staff members to the engagement.  

Note that if you have been assigned the Edit engagement properties 
group privilege, you can make changes on this tab when working in the 
Master Client Data. 

 

 Staff Name. Add each staff member in the Assign Staff grid who 
should be assigned to the current engagement. The drop-down list in 
this field includes all staff members who have been previously set up 
on the Staff tab of the Setup > System Configuration > 
Administration dialog and who are marked as Engagement CS 
users. 
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 Staff ID. This is the staff ID as entered for the staff member on the 
Staff tab of the Setup > System Configuration > Administration 
dialog. 

 Type. This is the staff member’s signoff type (Preparer, Reviewer, or 
one of three user-defined types). The type you select is the default 
for this staff member. If the field is left blank, this field defaults to the 
Preparer signoff type. 

Note: As with other grids used in CSA, you can delete an item in the grid 
by highlighting the row number, pressing the DELETE key on your 
keyboard, and then clicking the Yes button in the Confirmation dialog 
when prompted. 

Workpaper Assignments tab 
As the staff in charge of the engagement, you can use this tab to assign 
folders and workpapers to staff members in the current engagement. 

Note that if you have been assigned the Edit engagement properties 
group privilege, you can make changes on this tab when you are working 
in the Master Client Data.  
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 Engagement Staff. This is the staff ID and name of each staff 
member who has been selected on the Staff Assignment tab of the 
Engagement Properties dialog for the current engagement. 

 Assignments. These are the workpapers and documents in a Tree 
View format for the current engagement with checkboxes to the left 
of each folder and document in the tree. The following legend 
describes the icons used in the Tree View pane. 
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Checkbox legend 
 

 Assigned. The staff member has read / write access to the 
workpaper or folder. Only one staff member at a time can be 
assigned full access.  

 Read only. The staff member has read-only access to the 
workpaper or folder. 

 Not Assigned. The staff member has no access to the workpaper 
or folder. The staff member cannot view or open a folder or 
workpaper if not assigned to it. 

  

 All folders and workpapers in the engagement are marked as Read 
only by default when you open this page for the first time. 

 If a workpaper in a checked-out file is assigned to a staff member, 
the workpaper or folder may be marked as Read only or Not 
Assigned for all other staff members. (Read only is the default.) 

 When you select the type of assignment for the engagement or a 
folder, the application applies the same assignment to all available 
folders and workpapers in the selected engagement or folder. 

 The information on this tab is automatically updated when the 
workpaper assignment is changed at the workpaper level. (Refer to 
the “Assigning workpaper properties” section that begins on page 55 
of this guide.) 

Staff Privileges tab 
As the staff in charge of the engagement, you can use this tab to assign 
privileges to staff members working in the current engagement.  

Note that if you have been assigned the Edit engagement properties 
group privilege, you can make changes on this tab when working in the 
Master Client Data. 
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 Engagement Staff. These are the staff IDs and names that have 
been selected on the Staff Assignment tab of the Engagement 
Properties dialog for the current engagement. 
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 Privileges. Mark the checkbox for any of the following engagement 
functions to allow the engagement staff member to perform the 
specified task in the engagement. 

Function Description 
Edit general 
engagement 
properties 

Modify the properties on all tabs of the 
Engagement Properties dialog. 

Edit staff 
assignments 

Modify staff types on the Staff Assignment tab of 
the Engagement Properties dialog. 

Edit workpaper 
assignments 

Modify staff access privileges to folders and 
workpapers on the Workpaper Assignments tab 
of the Engagement Properties dialog. 

Edit staff 
privileges 

Assign/deassign staff for specific tasks in the 
current engagement. 

Delete 
engagement 

Delete the engagement from the engagement 
workspace.  

Undo check out 
files 

Undo the checked-out status of a document or 
workpaper in the engagement. 

Add potential 
journal entries* 

Add potential journal entries. (*See notes below.)  

Add all journal 
entries 

Enter any type of journal entry. 

Delete 
workpapers 

Delete workpapers. 

Edit workpapers 
assigned to other 
staff 

Open workpapers that are checked in to the 
Master Client Data (MCD), but are assigned to a 
different staff member. 

Delete Review 
Notes 

Delete review notes 

Edit signoff date Edit the signoff date. 

Clear Warning 2 Clear warnings from right-click context menu or 
Edit command menu in engagement workspace. 

Roll forward 
engagement 

Prepare the engagement to Roll Forward into the 
next year. 

Send to external 
source 

Store the current engagement for long-term 
storage in FileCabinet CS or GoFileRoom. 
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Function Description 
Multiple 
document signoff 

Sign off on multiple documents or workpapers at 
one time. 

Wrap up 
engagement 

Perform the wrap-up process. 

Undo wrap up Undo an engagement wrap-up that was 
previously completed. 

 

Notes 

 When setting up engagement users in Engagement CS, we 
recommend that you mark only the Add potential journal entries 
checkbox and not the Add all journal entry types checkbox. This 
enables staff assigned to the Trial Balance to review and change 
only potential journal entries entered by engagement staff members 
to another type of journal entry (Adjusting, Tax Adjustment, 
Reclassifying, or Other), as necessary. 

 The Engagement Staff privileges default to the global privileges that 
have been previously set up on the Groups tab of the Setup > 
System Configuration > Administration dialog. 

 These global options are overridden by any changes that the staff in 
charge makes on the Staff Privileges tab at the engagement level. 
This does not change the global privileges for the staff member. 
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History tab 
This tab briefly describes the nature of the activity that has taken place 
for the current engagement.  

 

 Description. This is the type of activity that took place. The following 
table lists the activities that are tracked by the application (where 
XXX represents the staff ID). 
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Created Edited staff privileges of (XXX) 

Backed up Edited workpaper assignments 

Restored Edited begin date 

Stored in FileCabinet CS Edited ending date 

Wrapped up Checked-out documents 

Rolled forward Received checked-out documents 
from (XXX) 

Renamed Checked-In documents 

Signed off Received checked-in documents 
from (XXX) 

Removed signoff Archived 

Added staff (XXX) Copy restored from archive 

Deleted staff (XXX) Edited engagement type 

Edited staff (XXX) Edited Report Release date 

  
 ID. This is the ID of the staff member who performed the activity. 

 Date/Time. This is the date and time that the activity took place. 

Note: Events appear in descending order, with the most recent 
appearing at the top of the list. 
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Setting up an engagement client in CSA 
In Trial Balance CS and Engagement CS, you can save hours of setup 
time by creating template clients and template engagements that can be 
used as a starting point for setting up new clients or engagements. 

Setting up template clients 
You can select and customize one of the available sample clients in 
Engagement CS to modify your own engagement. In the template client 
setup you can customize the following items for your client. 

 Chart of Accounts 

 Account groups 

 Grouping schedules 

 Financial statements 

This information can be transferred into new client databases to allow a 
quick and easy setup.  

Note: For information on setting up any of these items, refer to the Trial 
Balance CS Getting Started guide. You can view or print this guide in 
Portable Document Format (PDF) by searching on PDFs for Creative 
Solutions Accounting applications from the Search field in any CSA 
topic in the Help & How-To Center. 

Setting up template engagements 
When the general account information has been set up for the client, you 
can begin to set up single or multiple engagements in the template client. 
Creating the template engagement allows you to customize the 
engagements folder structure and create or insert audit programs, 
checklists, and other workpapers. For quick and easy setup, you can 
transfer an engagement created for the template client to other 
engagement clients. 

  

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/tb_gs.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/tb_gs.pdf
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Creating a new engagement 
After setting up the client in CSA, you can open that client in 
Engagement CS and add a new engagement. 

 Open the New Engagement wizard by choosing File > New > 
Engagement. 

The New Engagement – Start page of the New Engagement wizard lists 
three options. 

 

Note: The option to create a new engagement from PPC’s Checkpoint 
Tools is available only when you are licensed for and have the 
application installed. 
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Creating a new engagement from an existing engagement 
The option to Create from an existing engagement enables you to 
select an engagement from another Engagement CS client (or template 
client) and copy it to the active client. (For example, if you have already 
set up a small business template client with an Audit template 
engagement, you can copy that template engagement to the active 
client.) 

Note: When you copy Excel or Word workpapers from an existing 
engagement client, the application updates them to reflect the Chart of 
Accounts balances for the active client. 

1. Click the Create from an existing engagement option from the 
Start page of the New Engagement wizard, and click Next to 
continue. 

2. Highlight an existing client in the listview pane, select an 
engagement from the drop-down list, and then click Next. 
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3. On the New Engagement – Properties page, enter a name and 
description for the new engagement, select the engagement period 
end date, and then click Next. 

4. On the New Engagement – Staff Assignment page, select the staff 
members and signoff types, and then click Next. 

5. On the New Engagement – Workpaper Assignments page, assign 
workpapers to the appropriate staff members, and then click Next. 

6. On the New Engagement – Staff Privileges page, select the 
appropriate privileges, and then click Finish. 

Creating an engagement from PPC’s Practice Aids  
If you are a licensed user of PPC’s Practice Aids, you can create a new 
engagement from PPC’s engagement packages. 

For detailed information about creating an engagement from PPC’s 
Practice Aids, please refer to the appendix of the Engagement CS 
Tutorial. 

Creating a blank engagement 
The option to Create a blank engagement enables you to start a new 
engagement and set up folders, audit programs, checklists, and 
workpapers from scratch. 

Follow these steps to create a blank engagement. 

1. Click the Create a blank engagement option from the Start page of 
the New Engagement wizard, and then click Next. 

2. On the New Engagement – Properties page, enter the engagement 
name and description, select the engagement period end date, and 
then click Next. 

3. On the New Engagement – Staff Assignment page, select the staff 
members and signoff types for the new engagement, and then click 
Next. 

4. On the New Engagement – Staff Privileges page, select the appropriate privileges, and 
then click Finish. 
  

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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4  
Engagement Processing Overview 

This section of the Engagement CS Getting Started guide provides a 
brief overview of several of the main processing features in the 
application that are used by staff assigned to the engagement. 

Inserting an engagement document 
The New Document dialog enables you to add a document to an 
engagement, record information about the document, specify a name 
and workpaper reference, and assign the document to a staff member. 

 Choose File > New > Document or press CTRL+N to open the New 
Document dialog. 
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Excel / Word document types 
 Custom Excel workpaper or cash flow statement. (Create an Excel 

workpaper and define the columns with information from the client’s 
Trial Balance — such as account number, account description, and 
amounts. If the cash flow worksheet has been created, this selection 
also allows you to create an indirect or direct cash flow statement in 
Excel.) 

 Blank Excel workpaper 

 Blank Word workpaper 

PPC document types 
 Document from Checkpoint Tools 

 Document from the Reference Library 

 Document from SMART Practice Aids 
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Other document types 
 Document from an existing client 

 Document reference (Inserts a placeholder with a note explaining 
where a paper document is located.) 

 CSA financial statement, transmittal letter, or report 

 GoSystem Audit/Fund financial statement or workpaper 

 Confirmation reports form Capital Confirmation 

Scanned images 
You can insert scanned images directly into your engagement without 
first having to save the file to your local or network drive. (Available only 
if a scanner is installed on your workstation.) 

 Scan options (single page; multiple pages into a single file; multiple 
pages into separate files) 

 File types (PDF file; Word file) 

External document types 
Select an existing Excel, Word, or other third-party file to copy into the 
engagement. The original file remains, but a copy is made in the 
engagement, with links to the trial balance. 

Integrating with Excel and Word 
Engagement CS integrates with Microsoft Excel and Word so that trial 
balance information from CSA can be linked from within Excel and Word 
workpapers and documents. Engagement CS provides convenient 
toolbars in both Excel and Word. These toolbars combine the reliable 
linking of data from Engagement CS to Excel and Word and the ability to 
use Excel’s formatting and calculating features that are already familiar 
to you. Full-featured integration with Excel and Word enables you to 
perform the following tasks. 

 Add external Word and Excel workpapers to an engagement. 

 Work on the Excel or Word workpaper directly in the engagement 
workspace. 
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 Launch Excel or Word from within Engagement CS to link directly to 
the trial balance data in CSA. 

 Disconnect / reconnect Excel and Word workpapers in the 
engagement. 

 Use the Engagement CS add-in toolbars within Word and Excel 
(when the applications are launched from within Engagement CS) 
perform the following tasks. 

 Insert initials when a procedure is completed. 

 Insert a workpaper link. 

 Insert variables. 

 Insert multiple formulas. (Excel only.) 

 Insert custom tickmarks. 

 Insert tickmark legend. 

 Insert checkmarks. 

 Insert N/A. 

 Clear items during roll forward. 

 Custom format variables. (Word only.) 

 Hide or show zero balance rows. 

 Access Engagement CS-specific help topics for Word and Excel 
functionality. 

 Create your own custom Excel workpapers from within Engagement 
CS. 
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Note: For detailed examples of creating and working with Word and 
Excel workpapers from Engagement CS, refer to the Engagement CS 
Tutorial. 

Assigning workpaper properties 
The Workpaper Properties dialog allows you to view all information 
pertaining to a specific workpaper and designate the name and reference 
for the currently selected workpaper. You can also specify roll forward 
treatment of a workpaper, assign the workpaper to a specific staff 
member, track signoffs, and view the history of the current workpaper.  

 Highlight the document or workpaper in the Tree View window, right-
click to open the context menu, and then choose Workpaper 
Properties. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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Note: You cannot modify the properties for the selected workpaper when 
it is checked out to another team member. 

Identification 
 Workpaper Reference. Enter the workpaper reference to use for 

this document (up to 75 alphanumeric characters). Workpaper 
references must be unique within a single engagement. 

 Workpaper Name. Enter a name for the workpaper (up to 75 
alphanumeric characters). Workpaper names must be unique within 
a single engagement. 
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 Assigned to. Assign the document to a staff member by selecting 
the appropriate name from the drop-down list. If the workpaper is 
checked out, this option is unavailable (grayed).  

 Roll Forward. Select the appropriate action from the drop-down list.  

 Exclude. (Default option.) The workpaper is not rolled forward 
into next year’s engagement. If the Delete during Wrap Up 
checkbox is marked, the workpaper is flagged for deletion as 
part of the wrap-up process in the Workpaper Removal grid of 
the Wrap Up wizard. 

 Include. The workpaper is wrapped up and included in both the 
final engagement and in the new engagement created during the 
roll forward process.  

 Replace from PPC Template. The workpaper is replaced with a 
PPC Practice Aid from an available PPC title. 

 Replace from selected engagement. The application replaces 
the current version of the workpaper with another document from 
the selected engagement client.  

Note: If you select the Replace from PPC Template or Replace from 
selected engagement option from the Roll Forward drop-down list, the 
Delete during Wrap Up checkbox is unavailable (grayed). 

Signoffs 
 Name / Date / Signoff. These are the name of each staff member 

who has signed off on the document, the date, and the type of 
signoff (Preparer, Reviewer, or a user-defined type). 

 Add button. Click this button to have the application automatically 
insert the staff member’s name, the current system date, and the 
signoff type. 

 Edit button. Click this button to enable a staff member to edit the 
signoff type and (with the appropriate group privilege) to modify the 
signoff date or type. 

 Remove button. Click this button to Enable a staff member to 
remove his or her own signoff. 
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Note: Rather than opening the Workpaper Properties dialog to insert a 
signoff, you can right-click on a selected workpaper in the Tree View 
window to open the context menu and choose Document Sign Off to 
automatically insert a signoff for the selected workpaper. 

Events 
 Created by. This is the name of the staff member who created the 

document, as well as the date and time it was created. 

 Last Check in. This is the date and time the most recent Local to 
Master file was received. 

 Last Check out. This is the date and time the most recent Master to 
Local file was created. 

 History button. Click this button to open the History dialog, where 
you can view a history of all activity for the selected document 
(including a brief description of the activity, the ID of the staff 
member responsible for that activity, and the date and time of the 
activity. Events appear in descending order, with the most recent 
appearing at the top of the list. 
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Working with CSA trial balance data 
As the staff in charge of the engagement, you can open the Trial Balance 
view and work with journal entries from within Engagement CS. Choose 
Tasks > Trial Balance and select a trial balance view to open in the 
engagement workspace. You can also choose Tasks > Assign Trial 
Balance to assign the Trial Balance to a specific staff member. 

 All staff members with the appropriate group privilege can enter 
journal entries. They can view all journal entries but can edit only 
those they originated and that have not been checked into the 
Master Client Data. 

 All of the features of Trial Balance CS are available from within 
Engagement CS. (For further information, refer to the 
Trial Balance CS Getting Started guide.) 

 If you are assigned to the Trial Balance in the LCD or if you are 
working in the MCD and the Trial Balance has not been checked out, 
you can open the grid. If the client database is not available because 
it is in use or checked out, the application displays a Trial Balance 
Report when you choose Tasks > Trial Balance. 

 Only one staff member may access the client database at a time. 
This also includes staff performing work in other CSA applications. 

 If you are assigned the trial balance, you have access to everything 
on the Setup menu that is client specific, such as Chart of Accounts, 
Account Groups, Grouping Schedules, and other items. 

Trial Balance report 
This report lists the account number and description, as well as the 
unadjusted basis, adjustments, and adjusted basis. You can also choose 
to view Tax, Report, or Other basis by making the selection from the 
drop-down list. You can view Budget and Adjusted Budget balances by 
marking those checkboxes on the Trial Balance dialog in Engagement 
CS. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/tb_gs.pdf
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You can refresh or print the data, or click the Close button to close the 
report.  

 

Note: The staff member assigned to the Trial Balance has access to all 
journal entries. After the journal entries have been checked in, the staff 
member can then review them and make any necessary edits. 

 Tip  
To enable the staff member assigned the trial balance to easily identify 
which journal entries were added by other staff members, assign all 
other staff members the Add potential journal entries privilege. The 
staff member assigned the trial balance can then run Trial Balance 
reports to review and edit the journal entries. 

To open the Trial Balance view 
Trial Balance CS functionality is available from within Engagement CS. 
Choose Tasks > Trial Balance to open the Trial Balance window. 
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Note: Only one staff member can be assigned the trial balance. 

To work with journal entries 
Choose Tasks > Journal Entries to open the Adjusting Journal Entries 
window. 

 

 If you have access to the trial balance, you can edit or delete only 
the journal entries you have added since your last check-in or 
synchronization with the MCD. 
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 If you have access to the trial balance, you have complete access to 
journal entries. After the journal entries have been checked in, the 
owner of the trial balance can then change the journal entry type or 
make other edits, as needed. 

Working with cash flow worksheets 
Engagement CS enables the staff member that is assigned to the trial 
balance to create indirect and/or direct cash flow worksheets. 

 

 Create a cash flow worksheet based on account number or any 
number of grouping schedules, and with any balance type. 

 Analyze the differences between prior-period and current-period 
balances for a selected grouping code based on the balance type 
that was selected when the worksheet was created. 

 Analyze details about which accounts make up the specific cash flow 
sections and lines in the Cash Flow Analysis report to help you foot 
the cash flow statement after it is created. 

 Transfer customized cash flow lines from one Engagement CS client 
to another. 
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 Process the cash flow by each combination of location and/or 
department for engagement clients that have locations and/or 
departments set up. If only locations or departments exist in the 
client record, then you must create a cash flow worksheet for each 
department or location. 

 Create an indirect or direct cash flow statement in Excel using the 
Insert Engagement Document wizard. 

Note: For detailed information about creating and using the indirect / 
direct cash flow worksheets in Engagement CS, refer to the Engagement 
CS Tutorial. 

Working with review notes 
You can add review notes to a workpaper, folder, and engagement. A 
reviewer or another preparer of the engagement can clear and review 
notes at a later time. All notes must be cleared before wrapping up an 
engagement, or they can be deleted during the wrap-up process. 

Note: All previous notes recorded by staff members are retained in a 
thread in the Dialog pane of the Review Notes dialog and the Notes View 
window in the main Engagement CS workspace. 

Opening a review note 
You can open a review note in the Engagement CS workspace by using 
one of the following methods. 

 Double-click the note in the Notes View window. 

 With the workpaper, folder, or engagement highlighted in the Tree 
View window, choose Edit > Edit Review Note, and then select the 
review note that you want to view or modify. 

 On workpapers, if there is a sticky note attached to the review note 
and you are assigned to the document or workpaper, you can right-
click on the sticky note to open the context menu, and then choose 
Edit Note to open the Review Notes dialog. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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Adding sticky notes to workpapers 
A sticky note is a graphical note indicator that you can place on the read-
only copy of the document to highlight a specific area of the document in 
the Document View window of the engagement workspace.  

If you have marked the Prompt to attach sticky note when entering 
new review note option (in the Setup > User Preferences > 
Engagement CS User Preferences dialog), the application prompts you 
to add a sticky note to the current document when you have finished 
entering the text for a new review note in the Review Notes dialog. 

You can use either of the following methods to add a sticky note. 

 After creating the note from the Review Notes dialog, click OK and 
move your mouse pointer over the document image in the Document 
View Window of the engagement workspace, and click the Yes 
button to place the sticky note on the workpaper. 

 In the Notes View window, right-click the note for which you want to 
attach a sticky note. 

The application alerts you to the presence of a note by placing a yellow 
note on the icon in front of the document in the Tree View window. In 
addition, the subject and text of the note appear in the Notes View 
window. Click the plus ( ) or minus ( ) sign next to the subject to 
expand or collapse the view. 
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Notes 

 Sticky notes are not available for folders and engagements. 

 You can choose not to be prompted to add a sticky note by 
unmarking the Prompt to attach sticky note when entering new 
review note option on the Engagement CS tab of the Engagement 
CS User Preferences dialog (Setup > User Preferences). 

 You can use any of the following methods to view and/or respond to 
the review note associated with a sticky note. 

 Choose Edit > Edit Review Note and make your changes in the 
Review Notes dialog. 

 Double-click the yellow sticky note in the Document View window 
to open the Review Notes dialog and view the contents of the 
note in the Dialog pane. To view the subject of the note, hover 
the mouse cursor over the sticky note in the Document View 
window.  

 Double-click the note in the Notes View window. 

 To move a sticky note to a different location on the document, click 
the sticky note in the Document View window and, while holding the 
mouse button down, drag the sticky note to the new location on the 
document. 

 To remove the sticky note, right-click the sticky note and choose 
Remove Sticky Note. Click Yes when prompted. 

 To hide the sticky notes from view in the Document View window you 

can click the Show Hide Notes  button on the Engagement CS 
toolbar. 

Clearing and unclearing notes 
The staff member who is assigned to the workpaper can clear notes for 
that workpaper by opening the note and marking the Cleared checkbox. 
When the note is cleared, the name of the person who cleared it and the 
date appears in the Dialog pane. 
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Once a note has been cleared, the Reviewed checkbox becomes 
available. This allows the originator to mark the Reviewed checkbox, 
indicating that they have reviewed the cleared note. 
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If it is necessary to unclear the note, double-click the note in the Notes 
View window to open the Review Notes dialog, and unmark the Cleared 
checkbox. When the note is uncleared, the name of the person who 
uncleared it and the date appears in the Dialog pane.  

 



Engagement Processing Overview  

68 Engagement CS Getting Started 

Generating and printing diagnostic reports 
Workpaper Diagnostic report  

The Workpaper Diagnostic report provides information on the status of 
selected workpapers. Choose File > Diagnostic Reports > Workpaper 
to open the Workpaper Diagnostic Report dialog. The report lists 
information on the workpapers in the engagement.  

 Workpaper reference 

 Workpaper name 

 Warnings 

 Assigned (who the workpaper is assigned to) 

 Notes (number of review notes entered for the workpaper) 

 Preparer signoff 

 Reviewer signoff  

 Additional user-defined signoff types (Parameters can also be 
defined in the Setup > System Configuration > Signoff Types dialog 
in CSA.)  
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Notes 

 You can select different options to filter the workpapers listed in 
the diagnostic report. (All workpapers in the engagement are 
included in the report by default.) This feature can help you 
easily determine which workpapers have not been signed off or 
which workpapers are still checked out. 

 You can click the Send to engagement button to include the 
Workpaper Diagnostic report in the current engagement. 
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Report options 
The following options are available. 

 Sort order. You can choose how you want to sort the workpapers 
from the drop-down list. You can sort the selected workpapers by 
workpaper reference, workpaper name, warnings, assigned staff 
member, notes, preparer signoff, reviewer signoff, or by up to three 
additional signoff types that you can set up in the 
Setup > System Configuration > Signoff Types dialog.  

 Selected workpapers. By default, all workpapers are included in the 
diagnostic report. To limit the number of workpapers selected for the 
report, click the Browse button to open the Select Workpapers 
dialog, which displays a Tree View of the workpapers in the 
engagement. Mark the checkboxes next to the workpapers to include 
in the report. (By default, all checkboxes are marked.) You can also 
mark the checkbox next to a folder to include all workpapers within 
that folder.  

 Workpapers assigned to. By default, this checkbox is blank and all 
workpapers are included. To limit the workpapers included in the 
report to just those assigned to a particular staff member, mark the 
checkbox and select the staff member from the drop-down list. Staff 
member names in the drop-down list appear in alphabetical order by 
last name.  

 Checked out and disconnected workpapers only. By default, this 
checkbox is blank. Mark the checkbox to display only workpapers 
that are checked out or disconnected from the engagement. 

 Workpapers signed off by. By default, all workpapers are included 
in the report. To limit the workpapers included in the report by type of 
signoff, mark the checkbox next to the signoff type you want to 
exclude. 

 Refresh. After making changes in the dialog, click the Refresh 
button to update the data in the listview pane. 

 Print. Click this button to print the report (or right-click within the 
report body and choose Print). 

 Send to engagement. Click this button to include the workpaper 
diagnostic in the current engagement. 
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Notes Diagnostic Report  
The Notes Diagnostic Report provides information on the status of 
selected review notes. The report lists the notes for the current 
engagement and all folders and workpapers within the current 
engagement.  

Choose File > Diagnostic Reports > Notes to open the Notes 
Diagnostic Report dialog. The report groups notes are displayed by 
workpaper, and then by note number. 

Staff members can filter the notes to show only those notes the staff 
member wants to see. The report can be filtered by selected folders / 
workpapers, originator of the note, or current status of the note.  

 

Unsigned Program Steps report 
The Unsigned Program Steps report provides a list of all steps that 
have yet to be signed off by checking in PPC’s Checkpoint Tools 
audit programs for unsigned audit steps in the current engagement. 



Engagement Processing Overview  

72 Engagement CS Getting Started 

 

Scanning a document into Engagement CS 
Engagement CS supports virtually all scanners with a TWAIN interface. 
With TWAIN, you can access the scanner from the software in which you 
want to keep the image, scan the image, and save it directly into the 
software. TWAIN is the standard for scanner control software; nearly all 
scanners available today feature a TWAIN interface.  

Note: Network scanners can be used, but the scanning software must be 
installed locally on each computer that uses the Engagement CS 
scanning feature. 

For detailed information about scanning documents in Engagement CS, 
refer to the Engagement CS Tutorial. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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Printing to Engagement CS from other CS 
Professional Suite applications or from Windows-
based applications 

Engagement CS includes the Engagement CS print driver, which is 
installed to your local computer and enables you to print from other CS 
Professional Suite Accounting Products software or other Windows-
based software applications directly to Engagement CS for a selected 
client and engagement. 

For example, you can save a Microsoft Word document as a workpaper 
for an Engagement CS client. After selecting the Engagement CS driver 
from the Print dialog, you can select a specific engagement client to 
which the workpaper is to be sent.  

 

Important! All documents printed to an engagement client are initially 
filed in a {Not Yet Filed} folder displayed in the Tree View window. Be 
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sure to choose File > Process Unfiled Workpapers to assign the 
workpaper to the appropriate folder within your engagement.  

For detailed information about printing with the Engagement CS print 
driver in Engagement CS, refer to the Engagement CS Tutorial. 

Wrapping up the engagement 
The final retrieval, organization, and cleanup of engagement files are 
important elements in the final phase of wrapping up an engagement. 
With the use of the Wrap Up wizard, Engagement CS allows you to 
secure all the appropriate documents, workpapers, and checklists in the 
master engagement prior to performing the Roll Forward process. 

Note: Only those staff members with the Wrap Up Engagement group 
privilege are able to choose Tasks > Wrap Up and Tasks > Undo Wrap 
Up. (Both the Wrap Up and Undo Wrap Up commands are available only 
in the MCD.) 

With the Engagement CS Wrap Up wizard you can perform the following 
tasks. 

 Verify that all workpapers and documents are checked into the 
engagement. 

 View a Notes Diagnostic Report to identify selected notes that are 
still open. 

 Clear any open review notes. 

 Delete all review notes. 

 Display potential journal entries entered for the client’s current 
engagement period. 

 View a Workpaper Diagnostic Report to identify a list of workpapers 
based on level of signoff. 

 View the Unsigned Program Steps Report to verify that all steps in 
PPC’s Checkpoint Tools documents have been signed off correctly. 

 View a Wrap Up Summary Report that provides you with the 
following information regarding the engagement. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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 General information (engagement description and engagement 
dates) 

 Engagement staff 

 Engagement signoffs 

 History 

 Status of send / receive transfer files 

 Potential journal entries 

 Review notes that were cleared and/or deleted during the 
wrap-up 

 Workpapers deleted 

 Remove selected workpapers such as personal memos and 
documents that should not be included in the final engagement. 
These documents are marked in the Workpaper Properties dialog to 
be deleted during the wrap-up. 

 Perform a final cleanup that deletes any Send / Receive transfer files 
located in the default data paths. 

Note: When the wrap-up is complete, all documents in the engagement 
are locked down, but you can open them in the application as read-only. 
Any changes that you make to the read-only documents cannot be saved 
back to the wrapped up engagement. 

For detailed information about wrapping up an engagement, refer to the 
Engagement CS Tutorial. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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Sending the engagement to FileCabinet CS 
If you are a licensed user of FileCabinet CS and have the application 
installed, you can use the application to store the entire engagement for 
easy access and viewing in the future. This process can take place at 
any time throughout the engagement, but is usually performed by the 
staff in charge when the engagement is complete and you are ready for 
a secure lock-down of workpapers and financial statements. 

Notes 

 Engagements that are stored in FileCabinet CS cannot be altered. It 
is important to note that this is not a backup of the engagement but a 
printed copy of the engagement for storage purposes. In addition, 
engagement data is stored with the CSA client when it sent to 
FileCabinet CS. 

 Engagements that are backed up to FileCabinet CS are stored under 

the Engagement CS  icon. In addition, the stored engagement 
client has a corresponding subfolder labeled with the engagement 
period ending date (as defined in the General tab on the 
Engagement Properties dialog). 

 For detailed information about storing the engagement in FileCabinet 
CS, refer to the Engagement CS Tutorial. 

Sending the engagement to File/Email 
In Engagement CS you can choose File > Send Engagement to: 
File/Email to send engagement workpapers, or whole engagements to a 
file or as an email attachment as a bookmarked PDF. The file can be 
sent to your local hard drive or to a network location to which your 
workstation is connected or as an attachment in your resident MAPI-
compliant email application. 

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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Notes 

 This option is only available when you select an engagement in the 
Tree window of the engagement workspace. 

 You must refresh all outdated documents in the engagement before 
you send an engagement to a file or as an email attachment. 

 For detailed information about sending the engagement workpapers 
or whole engagements to a File or as an Email attachment enter 
Send to File/Email dialog in the search field in the Help & How-To 
Center. 

Sending the engagement to GoFileRoom 
Engagement CS provides you with the ability to send an entire 
engagement to GoFileRoom as a single bookmarked PDF file.  

When you have the appropriate add-in installed, you can use the File > 
Send Engagement to > GoFileRoom command to create a single PDF 
file from individual workpapers and save the PDF file or store the file in 
GoFileRoom.  

Notes 

 This option is available only when you have the GoFileRoom add-in 
installed and have selected an engagement in the Tree View 
Window of the engagement workspace.  

 The application retains the folder structure of the engagement in the 
layout of the bookmarks within the PDF that is created so that you 
can easily access information within the file. 
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Rolling forward the engagement 
With the Roll Forward feature in Engagement CS, you can copy the 
engagement to use as a template in the following year. The application 
creates a new engagement for the new period based on the structure of 
the current engagement, which remains unchanged. 

On the Roll Forward – Workpaper Settings page of the Roll Forward 
wizard, you can choose to override the selected Roll Forward Settings 
that were originally set up in the Workpaper Properties dialog for each 
workpaper in the source engagement. The following settings are 
available in the workpaper grid. 

 Include. Workpapers that are designated with this setting are carried 
forward into the new engagement during the Roll Forward process. 

 Exclude. Workpapers that are designated with this setting are not 
carried forward into the new engagement during the Roll Forward 
process. 

 Replace from selected engagement. Workpapers that are 
designated with this setting can be replaced with another document 
in a selected engagement client that you choose from the Select 
Template Engagement page of the Roll Forward wizard. 

 Replace from PPC template. Workpapers that are designated with 
this setting can be replaced with a PPC’s Practice Aid from the 
Replace Workpaper page of the Roll Forward wizard. To replace the 
current workpaper, click the Select Replacement Workpaper button 
to launch PPC’s Checkpoint Tools (when you are appropriately 
licensed and have the product installed), and select another practice 
aid title from the available list. 

Notes 

 Workpaper signoffs, history, and notes attached to the workpapers 
do not roll forward. However, links in Excel and Word workpapers 
are updated automatically to reflect the balances based on the new 
engagement period end date. For example, if an Excel workpaper 
displays 2014 and 2013 data prior to the Roll Forward, and then the 
client is advanced to 2015 during the Roll Forward process, the 
statements change accordingly to display 2015 and 2014 data. 



 Engagement Processing Overview 

Engagement CS Getting Started  79 

 You can choose to run the Roll Forward process at any time during 
engagement processing. (It is typically performed after the wrap-up 
or when the engagement is close to completion.) The existing 
engagement is used as a template to create the next year’s 
engagement.  

 The Roll Forward process can be performed by only those staff 
members who have the privilege assigned to them by the staff in 
charge. If a staff member without the appropriate privilege attempts 
to run the Roll Forward process, the application displays a message 
stating that “Staff ID XXX does not have the privileges to access this 
area of Engagement CS” (where XXX represents the staff ID). 

 For detailed information about rolling forward the engagement, refer 
to the Engagement CS Tutorial. 

Archiving engagements 
The archive feature in Engagement CS enables you to create a secure 
storage file for engagements that no longer need to be viewed in the 
engagement workspace. The application removes archives rom the Tree 
View window but backs them up with the engagement client. 

Notes 

 You can restore a working copy of the archived engagement back 
into Engagement CS. 

 You can delete any archives that you no longer need. 

 For detailed information about archiving an engagement, refer to the 
Engagement CS Tutorial. 

 

  

http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
http://cs.thomsonreuters.com/ua/acct_pr/csa/cs_us_en/pdfs/en_tutorial.pdf
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5 
Staff Collaboration 

This section of the Engagement CS Getting Started guide provides a 
brief overview of several of the main processing features in Engagement 
CS that are performed by staff members in a networked environment 
with the multi-staff feature enabled, or by staff members who have been 
assigned to work remotely on the Local Client Data in your client’s office. 

Using the multi-staff feature 
The multi-staff feature in Engagement CS is designed to provide you with 
maximum flexibility when multiple staff members are working on the 
same engagement. This feature allows you to make changes to 
workpapers (including signoffs and notes) at the same time as other 
engagement staff, which optimizes the engagement workflow and 
reduces the overall time spent to complete engagement tasks. In a 
typical engagement workflow scenario, specific tasks are assigned to 
multiple staff members throughout the different stages of the 
engagement. 

When connected in a networked environment with other engagement 
team members, the multi-staff feature provides an alternative to using 
different sets of client data in the staff collaboration scenario using the 
send and receive capabilities within the application. 

Note: To take advantage of the multi-staff functionality, you must be 
working in the same office and connected to the same network as the 
other staff who are currently assigned to the engagement. 
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Important! To enable multi-staff functionality for your Engagement CS 
client, be sure to mark the Enable multi-staff functionality in 
Engagement CS checkbox on the Trial Balance tab of the File > Client 
Properties dialog in CSA. 

With the appropriate privileges and workpapers assigned, you can 
perform the following tasks in a multi-staff environment. 

 Store data on a network drive where all engagement team members 
can access it. 

 Work on assigned workpapers separately but concurrently in the 
same engagement as other staff members. 

 Add and edit workpapers, create notes, and sign off on completed 
engagement documents (tasks for the staff in charge). 

 Access and perform multiple signoffs on workpapers, and create 
notes for other engagement staff that are refreshed automatically in 
real time for the whole engagement team (tasks for the staff in 
charge). 
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Using the send / receive feature 
The Tasks / Receive Documents command is available for the staff in 
charge of the engagement who needs to update the Master Client Data 
with engagement documents received from the field or for multiple staff 
in the field who are updating and sharing documents in the Local Client 
Data. This enables staff working in the field to receive a transfer file that 
consists of their assigned portions of the engagement with the data 
stored on their local computer. 

Staff Collaboration workflow 

 

Note: If only one staff member is working on the engagement, there is 
no need to send or receive documents. 
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Backing up the client database 
If you are working in the field and do not have access to your office 
network while at a client’s location, we recommend that the engagement 
staff in charge make a backup of the client database (and mark it as 
checked out in the Backup Clients dialog), and then restore the client 
database to a laptop to take into the field. Marking the client database as 
checked out insures that the client data on the network remains secure 
until the data is returned from the field. 

Do the following steps to back up and check out the engagement client 
from the MCD. 

1. Choose File > Backup to open the Backup dialog. 

2. Double-click one of the engagement clients to move it to the 
Selected pane of the Backup Clients dialog. 

3. Mark the Mark as checked out checkbox. Marking this checkbox 
prevents the client data from being modified while it is being used in 
the field. 

Important! Only the staff member who marks the client data as 
checked out during the backup of the client data is able to restore it. 

4. Back up the client data to a separate network location or removable 
media (such as a read / write CD or USB drive), and then open the 
laptop/local installation (X:\Wincsi\Laptop\CSAData, where X 
represents the drive location on the laptop) to restore the data. 

You can now choose to send documents via a transfer file from the Field 
Master Client Data on the laptop to be received by other staff members 
working in the field. 
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Sending a transfer file 
When multiple staff are working in an engagement with continuous 
network connectivity, the Send / Receive feature enables the staff in 
charge of the engagement and staff working in the field to exchange 
engagement documents and workpapers via a transfer file. The file can 
be created in a shared network location or on appropriate removable 
media for access by all staff members of the engagement team with the 
appropriate privileges. 

From the MCD 
The staff in charge of the engagement working in the Master Client Data 
would use the following procedure to create and send a transfer file for 
use by other staff members on the engagement team. The transfer file 
can include workpapers, documents, and trial balance information from 
the master engagement. 

1. Choose Tasks > Send Documents. 

2. When prompted, you can choose to back up your data prior to 
creating a transfer file. 

Note 

 We recommend that the engagement staff in charge make a 
backup of the MCD and mark it as checked out in the Backup 
Clients dialog. The staff in charge can restore the MCD to a 
laptop that they take into the field and send documents to other 
staff members from that location. Marking the client as checked 
out insures that the client data on the network remains secure 
until the data is returned from the field. Select the client and 
enter or browse to the location where you want to create the file. 

 The Mark as checked out checkbox is grayed out (unavailable) 
in the Backup Clients dialog when sending transfer files. 
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3. Use the Workpaper Assignments tab of the Send Documents dialog 
to select and assign documents and workpapers to specific staff in 
the field. 
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4. Enter or browse to the location where the transfer file that consists of 
assigned engagement documents, workpapers, and/or trial balance 
data is to be created, and click OK. 

From the LCD 
Staff working in the field would use the following procedure to create and 
send a transfer file that consists of updated workpapers and documents 
that have been reassigned to other staff working in the Local Client Data, 
or received back into the Master Client Data by the staff in charge of the 
engagement. 

1. Choose Tasks > Send Documents and choose whether or not to 
back up your data prior to creating a transfer file. 
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Note: We recommend that the engagement staff in charge make a 
backup of the client and mark it as checked out in the Backup Clients 
dialog prior to sending selected engagement documents in a transfer 
file. 

2. In the Transfer File Destination dialog you can choose to send a file 
back to the Master Client Data or to another staff member in the 
Local Client Data, or you can cancel the send process. 

 

3. To make any required changes to the current workpaper 
assignments, click the Workpaper Assignments tab of the Send 
Documents dialog. These assignments determine which staff have 
access to the documents in the field. 
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4. Click OK to make the transfer file of assigned engagement 
documents available for the staff in charge of the MCD or another 
staff working in the field to retrieve. 

 

Notes 

 If privileges for the engagement documents have been defined 
for the selected staff ID previously in the Engagement Properties 
dialog of the Master Client Data, by default those same 
privileges are automatically reflected in the Send Documents 
dialog. 

 Creating a transfer file in a shared folder on a local network or on 
removable media makes it easy for all staff members who are 
working on the engagement to access their assigned files from 
one central location. 

 If changes are made to the workpaper assignments while 
documents are being sent, the changes are displayed in the Tree 
View window of the client after the send is complete. 
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 To ensure the integrity of the data in the field, each document 
that has been assigned to a specific staff member in the field and 
included in a transfer file is locked and made unavailable from 
the MCD until after it has been received back into the MCD — or 
until the checked-out status for that document has been undone 
in the MCD (via the Edit / Undo Checkout command). 

 The application removes the Local Client Data from the local 
workstation/laptop when a transfer file is created that consists of 
all the assigned engagement documents and workpapers. A new 
transfer file must be received from the Master Client Data to 
make it available again. 

 The LCD remains available for updates when a transfer file is 
created by a staff member in the field that consists of some, but 
not all, engagement documents and workpapers. 

 Because it is not required, the Workpaper Assignments tab is 
unavailable when you choose to send engagement documents 
back to the MCD from the LCD. 

 When sending transfer files from the LCD, only documents 
available to the current staff member are available on the 
Workpapers to send and Workpaper Assignments tabs of the 
Send Documents dialog. 

Receiving a transfer file 
While working in the MCD as staff in charge of the engagement, or as a 
staff member working in the LCD, you can choose Tasks > Receive 
Documents to receive a file that consists of updated workpapers and 
documents that have previously been assigned to another staff member 
working in the LCD. The application copies the transfer file to a folder on 
a shared network location or to appropriate removable media for access 
by the staff in charge of the MCD or staff member in the field. 

Use these steps to receive the transfer file back into the MCD or into the 
LCD by another staff member working in the field. 

1. In the current engagement, choose Tasks > Receive Documents. 

2. Click the Browse button to navigate to the location where the 
transfer files are located. 
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3. In the Receive Documents dialog, select the transfer file that you 
want to receive. 

4. Click OK to receive the transfer file. 
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Notes 

 When you receive updated transfer files back into the MCD, the 
application makes them available again (read / write) for updating in 
the MCD. 

 When you receive a transfer file that was sent from the MCD, the 
application displays “Master” in the Created by staff column of the 
Receive Documents dialog. 

 When you receive a transfer file that was sent from the LCD, the 
application displays the staff ID in the Created by staff column of 
the Receive Documents dialog. 

Synchronizing engagement data 
If you are connected to the MCD via a network connection, there is no 
need to send and receive transfer files to update the MCD and LCD. You 
can update changes made to the LCD can be updated in the MCD using 
the synchronization process. 

During the synchronization process, engagement documents transfer 
both ways — from the master data to the laptop and back again — so 
that both parties have copies of the engagement data. 

While in the LCD, you can choose Tasks > Synchronize, and then enter 
or browse to the Office or Field Master Client Data location. Click OK to 
open the Send and Receive Files dialog. 
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Use the Send and Receive Files dialog to send engagement workpapers 
or documents and receive them from the Office or Field Master Client 
Data location. After you define these locations (Setup > User 
Preferences dialog) in the application, you can begin the synchronization 
process. 

Click the Synchronize button in the Send and Receive Files dialog to 
connect to the Office Master Client Data location. If that location is 
unavailable, the application attempts to locate the Field Master Client 
Data location.  

If neither location can be found, the application displays the following 
prompt. 
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Click OK to open the Send and Receive Files dialog. 

Notes 

 You may choose to synchronize with the MCD at any time if you 
have access to the MCD via a network connection. 

 You can choose which engagement files you want to synchronize 
with the MCD or LCD. 

Important! We strongly recommend that all members of the engagement 
team synchronize their LCD at the end of the day and at the beginning of 
the day to ensure that they have the most current engagement 
documents, workpapers, and trial balance (when applicable). 
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Appendix: 
Keyboard Shortcuts 

Keyboard shortcuts are special keys (such as F1 and ESC) that you use 
either alone or in combination with CTRL, SHIFT, or CTRL+SHIFT. 
These keyboard shortcuts enable you to access various types of help, to 
quickly navigate through fields in windows and dialogs, and to open 
drop-down lists without having to use the mouse. 

The following table lists the keyboard shortcuts in Engagement CS. You 
can also view this list of shortcuts in the CSA application by choosing 
Help > Keyboard Help. 

Accessing Help Shortcut Keys 
View overview help for the active window or dialog CTRL+F1 or F1 

Editing Shortcut Keys 
Cut CTRL+X 

Copy CTRL+C 

Paste CTRL+V 

Find a worksheet or document name in the Tree 
View window (based on the text you specify) 

CTRL+F 

Edit a custom fieldview CTRL+W 

Undo last change CTRL+Z 
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Navigating and Special Functions Shortcut Keys 
Find a record (based on the text you specify) CTRL+F 

Search in a drop-down list for specific text or 
character string (Press CTRL+R to continue 
searching for the next instance of the character 
string.) 

CTRL+L 

Resume search for the next instance of specific 
text or character string in a drop-down list 

CTRL+R 

New document CTRL+N 

Print CTRL+P 

Open engagement client CTRL+O 

Open the Signoff dialog CTRL+S 

Save data and return to the previous window or 
dialog 

F2 

Open a context menu relevant to the selected  
dialog or field 

F3 

Open the drop-down list attached to current field F4 

Refresh display F5 

Display the popup calculator (from amount field 
only) 

F7 

Switch between Transaction entry and Payroll 
Check entry 

F8 

Move to previous field F9 

Move to next field F10 

Switch focus between the grid section and the 
journal entry section in the split screen of the Trial 
Balance grid. 

F11 

Move to last character in current field END 

Press the default button ENTER 

Close dialog without saving changes ESC 

Move to first character of current field HOME 
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Navigating and Special Functions Shortcut Keys 
Move to first record in window or dialog (while in 
Browse mode) 

CTRL+HOME 

Move to last record in window or dialog (while in 
Browse mode) 

CTRL+END 

Move forward through fields or make selection from 
drop-down list 

TAB 

Move to next tabbed page CTRL+TAB 

Move to previous tabbed page SHIFT+CTRL+TAB 

Move one character to left within a field ← 

Move one character to right within a field → 

Move to beginning of field CTRL+← 

Move to end of field CTRL+→ 

From an MS Excel or MS Word workpaper 
opened from within Engagement CS 

 

Insert “N/A” notation at the cursor position CTRL+ALT+A 

Mark as procedure completed (by inserting user 
initials and system date at the cursor position) 

CTRL+ALT+G 

Insert a checkmark at the cursor position CTRL+ALT+J 
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