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In General 
This document explains various ways to reduce the amount of disk space used by CS Professional Suite® 
applications and Microsoft® Outlook® when run through Virtual Office CS® or Software as a Service 
(SaaS). You may occasionally need to perform these procedures to free up disk space. 

Note: You cannot reduce the amount of disk space required to store client data in the following 
applications: Accounting CS,™ Client Bookkeeping Solution,® Financial Analysis CS,® Planner CS,® and 
ToolBox CS.® 

Creative Solutions Accounting 
The following procedures will help reduce the amount of disk space used by Creative Solutions 
Accounting™ (CSA) data. Many of these procedures involve removing unnecessary items. You might want 
to back up client data before performing these procedures.  

Important!  

 After deleting client data, you need to compact the client database. See page 3 for detailed 
information. 

 After deleting global data, you need to compact the global database. See page 3 for detailed 
information. 

Compress client data files 
Enabling client data compression substantially decreases the amount of disk space required to store 
client data, but it also decreases the speed with which client data open and close. Because 
uncompressed client data files require an average of ten times more disk space than compressed files, 
we recommend that you compress the data files if disk space is a concern.  

1. In Creative Solutions Accounting, choose Help > Repair. 
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2. In the Clients tab of the Repair dialog, mark the Enable client data compression checkbox. 

3. Click Done.  

Reduce the number of years of general ledger transactions and 
balances to save 
If you are saving general ledger transactions and balances for more years than are required, you can 
conserve disk space by reducing the number of years to save. You must set the desired number of years 
on a client-by-client basis.  

Important! If you reduce the number of years of general ledger transactions and balances that are saved 
for a client and transactions and balances exist beyond the number of years specified, those transactions 
and balances will be deleted.  

1. In Creative Solutions Accounting, open the appropriate client database.  

2. Choose File > Client Properties. 

3. In the General Ledger tab of the Client Properties dialog, enter the smallest possible number that is 
appropriate for the client in the Years of transactions to save and the Years of balances to save fields.  

Important! If you enter 1 (current year) in this field, transactions for the year being closed will be 
deleted automatically when you close the year.  

4. If reducing the number of years of general ledger transactions and balances that are saved affects a 
year that contains transactions or balances, you must confirm the deletion of the data. Click Yes to 
continue.  

5. Click OK. 

Remove unnecessary payroll departments from employee records 
and from the client database 
If there are unused payroll departments in the employee records and/or client database, you can 
conserve disk space by removing them. 

Remove unnecessary payroll departments from each employee  
1. In Creative Solutions Accounting, open the appropriate client database. 

2. Choose Setup > Employees. 

3. In the Employees window, select the appropriate employee and click the Edit button. 

4. In the General tab, click the Edit depts button. 

5. Clear the checkboxes for all departments that are marked but not needed. 

6. Click OK to close the Edit Employee Departments dialog and return to the Employees window. 

Note: You cannot delete any payroll department to which an employee is assigned.  
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7. Click the Enter button to save the changes for the selected employee, and then close the window. 

Remove unnecessary payroll departments from the client database 
1. In Creative Solutions Accounting, open the appropriate client database. 

2. Choose Setup > Payroll Departments. 

3. Select the unnecessary departments and click the Delete button. 

Note: You cannot delete any payroll department to which an employee is assigned.  

4. Click Yes in the confirmation dialog.  

5. Click Done and then close the window. 

Compact the client database 
Due to the nature of the CSA database files, deleting information from a client record does not reduce the 
size of the client database automatically. You need to compact the client database to permanently 
remove records that have already been marked for deletion from the selected client database. 

1. In Creative Solutions Accounting, choose Help > Repair. 

2. In the Clients tab of the Repair dialog, highlight the ID and name and click the Compact Client button. 

3. A prompt appears stating that the client was compacted successfully. Click OK.  

4. Click Done.  

Compact the global database 
Due to the nature of the CSA database files, deleting information from a global record does not reduce 
the size of the global database automatically. You need to compact the global database to permanently 
remove records that have already been marked for deletion from the global database. 

1. In Creative Solutions Accounting, choose Help > Repair.  

2. In the Miscellaneous tab, click the Compact Global Database button.  

3. A prompt appears stating that the global database was compacted successfully. Click OK.  

4. Click Done.  

Archive client data 
You can back up your old or unused client data to a low-cost storage drive and delete the data from the 
production server. Please note that the archive drive is for backups only; storage of live data is not 
permitted. Follow these steps to change the backup / restore location. 

Note: If your firm is paying for additional premium production storage space, you might be able to save 
money by moving older data to the archive storage drive. For pricing details, log in to NetStaff CS, click 
the Help menu in the Home Dashboard, and choose Pricing information. 
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1. In Creative Solutions Accounting, choose Setup > User Preferences. 

2. In the Options dialog, click the File Locations tab. 

3. Enter W:\CSA_ARCHIVE in the Backup / Restore field. (You can also click the Browse button to 
navigate to the archive path.) 

4. Click OK. 

5. Choose File > Backup to use this new location. 

Once you have backed up your old, unused data, you can remove the clients by choosing File > Delete. 

Note: Do not use the archive location to store live production data. The archive drive allows you to store 
archived data at a lower cost; it does not perform at the same level as the production file servers.  

Restoring archived data 
Follow these steps to restore data that your firm backed up to the archive storage drive. 

1. In CSA, choose File > Restore.  

2. Verify that the restore path is W:\CSA_ARCHIVE. 

3. Highlight the client data that you want to restore and click the Restore button. 

Engagement CS 
To reduce the amount of space used to store scanned documents in Engagement CS,® set your scanner 
software to scan documents in black and white (instead of in grayscale or in color). 

FileCabinet CS 
The following procedures will help reduce the amount of disk space used by FileCabinet CS® data.  

Adjust the settings in your scanner software 
To reduce the amount of space used to store scanned documents, set your scanner software to scan 
documents in black and white (instead of in grayscale or in color). 

If you scan original documents (not copies or facsimiles) in black and white at 300 DPI, the resulting 
scans will be of high enough quality to send for Source Document Processing. 

Archive infrequently accessed documents to an alternate location 
FileCabinet CS enables you to free up disk space by moving older, seldom-used documents from the 
active data location and storing them in an archive location. By moving these documents to a different 
location (such as CD, a local hard drive, or an archive storage drive) and then compacting the client data, 
you can reduce the amount of disk space required in Virtual Office CS or SaaS.  
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Note: After you move documents from the active data location to local media, you will be able to access 
those documents only if you have access to the local media. 

1. Make sure that no one else is working in, printing files to, or backing up client data to FileCabinet CS.  

2. In FileCabinet CS, choose File > Archive. 

3. Click the Create archive option. 

4. Click the appropriate option. 

 Append the archive to this volume — Click this option to add to an existing volume of archived 
documents. 

 Begin a new volume with this archive — Click this option to start a new volume of archived 
documents, and then enter the volume label and any applicable comments in the fields provided. 

5. Click the Continue button. 

6. Click the appropriate option. 

 All contents of selected drawers — Click this option to archive all of the documents in all of the 
folders in the drawers that you will select later in this process.  

 Specific folders of selected drawers — Click this option to limit the archive to the documents 
contained in specific folders within the selected drawers. 

7. Click the Continue button to open the Archive dialog. 

8. In the left pane, highlight the drawers that you want to archive and click the Select button to move 
them to the right pane. 

9. Verify that the path listed in the Archive location group box points to your local drive or to your archive 
drive. (Local drives all have a $ after the initial letter; for example, C$ on Client (V:) is your local C: 
drive. Use W:\CABINET_ARCHIVE as the path to the archive storage drive location.) To change the 
archive location, click the Modify button.  

Note: Do not use the archive location to store live production data. The archive drive allows you to 
store archived data at a lower cost and does not perform at the same level as the production file 
servers. For pricing details, log in to NetStaff CS, click the Help menu in the Home Dashboard, and 
choose Pricing information. 

10. Click the Archive button to begin the archive process.  

During the archive process, data is deleted from the FileCabinet CS data location and stored only in the 
archive data location. After the archive process is complete, you can click a volume icon in the folders 
window to view archive information or double-click a volume icon to access archived documents.  

Note: After archiving, we recommend that you compact the data for optimal space savings. Please see 
the “Compact FileCabinet CS data files” section on page 6 for more information. 

Restoring archived data 
Follow these steps to restore data that your firm backed up to the archive storage drive. 

1. In FileCabinet CS, choose File > Archive. 
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2. Click the Restore archive option and click Continue. 

3. Verify that the restore path is W:\CABINET_ARCHIVE.  

4. Highlight the volumes that you want to restore, and click the Restore button. 

Reduce the number of data backups from CS Professional Suite 
applications into FileCabinet CS 
Most CS Professional Suite applications include a feature that enables you to back up the application’s 
data into FileCabinet CS automatically. Although this feature provides easy access to data backups, you 
might want to reduce the number of backups retained to minimize the disk space required for the 
corresponding FileCabinet CS drawer. For details on setting the options for this feature in each 
CS Professional Suite application, see the help in the respective application.  

Compact FileCabinet CS data files 
Due to the architecture of the FileCabinet CS drawer data files, it is possible for the data files to contain 
unused space, which results in larger files than necessary. This issue is most common after you delete or 
archive data. To reduce the amount of unused space in the data files, you should compact the data files 
periodically.  

1. Make sure that no one else is working in, printing files to, or backing up client data to FileCabinet CS. 

2. In FileCabinet CS, choose Help > Repair > Compact tab. 

3. In the Drawers available to compact pane on the left, highlight the drawers that contain the data files 
that you want to compact, and click the Select button. 

4. Click the Compact Drawers button. 

5. When the process is complete, click OK. 

Fixed Assets CS 
The following procedures will help reduce the amount of disk space used by Fixed Assets CS® data.  

Adjust the settings in your scanner software 
To reduce the amount of space used to store scanned documents, set your scanner software to scan 
documents in black and white (instead of in grayscale or in color). 

Limit the number of years of depreciation data retained 
You can reduce the amount of disk space used by Fixed Assets CS data by limiting the number of years 
for which depreciation data is retained. (Note that completing this procedure affects UltraTax CS® returns 
for years beyond the maximum number of years to be retained.) 
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1. In Fixed Assets CS, choose Setup > System Configuration.  

Note: Depending on your security configuration, you may need to enter the master password before 
you can open this dialog.  

2. Click the Options tab.  

3. Enter a number (2 – 10) to specify the maximum years’ data to be retained for all clients. This range 
includes the client’s current-year data files plus any prior-year data files. 

4. Click OK.  

When you close the client data to the next year, Fixed Assets CS will delete data that is older than the 
number of years shown in this field (minus one for the current year’s data files).  

Archive client data  
You can back up old or unused client data to a low-cost storage drive and delete the data from the 
production server. Please note that the archive drive is for backups only; storage of live data is not 
permitted. Follow these steps to change the backup / restore location. 

Note: If your firm is paying for additional premium production storage space, you might be able to save 
money by moving older data to the archive storage drive. For pricing details, log in to NetStaff CS, click 
the Help menu in the Home Dashboard, and choose Pricing information. 

1. In Fixed Assets CS, choose File > Backup. 

2. Click the Modify Backup Location button and enter W:\DSW_ARCHIVE. 

3. Click OK. 

4. Select the client data you want to back up and click the Backup button. 

Once you have backed up old, unused data, you can remove the client data by choosing File > Delete. 

Note: Do not use the archive location to store live production data. The archive drive allows you to store 
archived data at a lower cost; it does not perform at the same level as the production file servers.  

Restoring archived data 
Follow these steps to restore data that your firm backed up to the archive storage drive. 

1. In Fixed Assets CS, choose File > Restore.  

2. Verify that the restore path is specified as W:\DSW_ARCHIVE.  

3. Highlight the client data you wish to restore and click the Restore button. 
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Practice CS 
You can reduce the amount of disk space used by Practice CS® databases by deleting unnecessary 
databases, such as unused training and sample databases.  

1. Start Practice CS. 

2. In the login screen, select the database that you want to delete in the Open Firm field. 

3. Select the administrator staff ID and click OK.  

Tip: Staff ID JPH is the administrator for the sample database. Staff ID ADMIN might be the 
administrator for training databases. 

4. Choose File > Delete Firm. 

5. Practice CS warns you that it will permanently delete the firm database. 

6. Click OK to create the required backup of the database, and then click OK again to create the backup 
in the default location. 

7. To delete another database, choose File > Open Firm and repeat steps 4 – 6. 

UltraTax CS 
The following procedures will help reduce the amount of disk space used by UltraTax CS data.  

Remove prior-year data 
If you have prior-year data (such as data from 2000 or 2001 UltraTax CS) that you rarely need to access, 
you can back up that information to local media or to an archive storage drive and delete it from Virtual 
Office CS or SaaS.  

Notes 

 After you remove data from Virtual Office CS or SaaS and back it up to local media, you will be able 
to access that data only if you have access to the local media. 

 If your firm is paying for additional premium production storage space, you might be able to save 
money by moving older data to the archive storage drive. For pricing details, log in to NetStaff CS, 
click the Help menu in the Home Dashboard, and choose Pricing information. 

1. Start the appropriate version of UltraTax CS.  

2. Choose File > Backup. 

3. In the pane on the left, highlight the clients whose data you want to back up and click the Select 
button. 

4. Verify that the path listed in the Backup location field points to your local drive or to the archive 
storage drive. (Local drives all have a $ after the initial letter; for example, C$ on Client (V:) is your 
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local C: drive. Use W:\UTxx_ARCHIVE as the path to the archive storage drive location.) To change 
the backup location, click the Modify Backup Location button. 

Note: Do not use the archive location to store live production data. The archive drive allows you to 
store archived data at a lower cost; it does not perform at the same level as the production file 
servers.  

5. Click the Backup button. 

6. After you have backed up the clients’ data, delete the clients from UltraTax CS by choosing File > 
Delete.  

Restoring archived data 
Follow these steps to restore data that your firm backed up to the archive storage drive. 

1. In UltraTax CS, choose File > Restore.  

2. Verify that the restore path is W:\UTxx_ARCHIVE.  

3. Highlight the clients that you want to restore and click the Restore button. 

Delete client data that was proforma’d from the prior year but is not 
needed 
If you proforma’d data to the current year from the prior-year version of UltraTax CS but your firm will not 
prepare a return for that client in the current year, you can save disk space by deleting the client data 
from the current-year version of UltraTax CS without deleting prior-year depreciation data.  

1. In the current-year version of UltraTax CS, close all clients. 

2. Choose File > Delete to open the Delete Clients dialog. 

3. In the pane on the left, highlight the clients whose data was proforma’d from the prior year but is not 
needed, and click the Select button. 

4. Verify that the Delete Fixed Assets CS data checkbox is not marked. Note that this checkbox is 
available only if you are licensed for Fixed Assets CS.  

Note: If the Delete Fixed Assets CS data checkbox is marked, UltraTax CS will delete the current-
year depreciation data.  

5. Click the Delete button. 

Workpapers CS 
To reduce the amount of space used to store scanned documents in Workpapers CS,™ set your scanner 
software to scan documents in black and white (instead of in grayscale or in color). 
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Microsoft Outlook 
The following procedures will help reduce the amount of disk space used by Microsoft Outlook data. 

Compact the Outlook data file (or PST) 
Outlook stores data in PST files. If you delete items (such as email messages or appointments) from a 
PST file, the size of the file does not change until you compact the file. 

Note: Depending on the size of the PST file, it might take several minutes to compact the file. We 
recommend that you compact PST files every 1 – 2 months.  

1. In Outlook, click the File tab in the ribbon and then click the Info link on the left. 

2. Click the Account Settings button, and choose Account Settings. 

3. Click the Data Files tab, highlight the data file that you want to compact, and click the Settings button. 

4. Click the Advanced tab and then click the Outlook Data File Settings button. 

5. Click the Compact Now button. 

6. When the process is complete, click OK. 

Empty the Deleted Items folder 
When you delete items in Outlook, they go into a Deleted Items folder by default. You can set up Outlook 
to delete these items automatically or you can manually delete them. 

Automatically empty the Deleted Items folder 
1. In Outlook, click the File tab in the ribbon and then click the Options link on the left. 

2. In the Outlook Options dialog, click the Advanced link on the left. 

3. In the Outlook start and exit section, mark the Empty Deleted Items folders when exiting Outlook 
checkbox. 

4. Click OK.  

Manually empty the Deleted Items folder 
1. In Outlook, click the Mail button in the folder list. 

2. Right-click the Deleted Items folder, and choose Empty Folder from the context menu. 

Move inactive Outlook items to an archival data folder 
You can create an additional, archival Microsoft Outlook data file (called a PST file) to limit the size of 
your active PST file. You can then back up old items such as email messages, appointments, contacts, 
tasks, journal entries, notes, posted items, and documents in the archival PST file. 
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Note: If your firm is paying for additional premium production storage space, you might be able to save 
money by moving older items to archival PST files and storing the files on the archive storage drive. For 
pricing details, log in to NetStaff CS, click the Help menu in the Home Dashboard, and choose Pricing 
information. 

Follow these steps to create an archival PST file. 

1. In Outlook, click the File tab in the ribbon and then click the Info link on the left. 

2. Click the Account Settings button, and choose Account Settings. 

3. Click the Data Files tab, and then click the Add button. 

4. In the Create or Open Outlook Data File dialog, enter or navigate to W:\MSOFFICE_ARCHIVE as the 
path for the PST file. 

5. Enter a name in the File name field to indicate that the PST will be used for old items (for example, 
add “archive” to the file name). If multiple users will create archive PST files in this location, further 
customize the file name to indicate the user to whom the PST file belongs (for example, 
Jsmith_archive.pst). 

6. Click OK to create the PST file. 

7. In the Create Microsoft Personal Folders dialog, you can specify a unique name for the PST file and 
set a password. It’s helpful to give the PST file a recognizable name (such as Jsmith_archive) 
because the name will appear in various lists within Outlook. When you’ve finished making changes 
in this dialog, click OK. 

8. In the Account Settings dialog, click the Close button.  

The new PST file appears in the Outlook folder list. You can select messages or folders and drag them 
into the archive PST file. If you move large quantities of messages into the archive PST file, you should 
compact your data folders as outlined in “Compact the Outlook data file (or PST)” on page 10. 
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